summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-21 23:55:33 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-21 23:55:33 +0000
commit1856f46ed882e136bc8b01602cd65edb77f1bf50 (patch)
treeac305d1d6ce6036ad5f240f72939133d4f5d4c79 /sys-libs
parentVersion bump. (diff)
downloadgentoo-2-1856f46ed882e136bc8b01602cd65edb77f1bf50.tar.gz
gentoo-2-1856f46ed882e136bc8b01602cd65edb77f1bf50.tar.bz2
gentoo-2-1856f46ed882e136bc8b01602cd65edb77f1bf50.zip
Generate DT_SONAME in the shared lib on BSD hosts #123571 by Diego Pettenò.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/zlib/ChangeLog8
-rw-r--r--sys-libs/zlib/files/zlib-1.2.3-bsd-soname.patch15
-rw-r--r--sys-libs/zlib/zlib-1.2.3.ebuild6
3 files changed, 25 insertions, 4 deletions
diff --git a/sys-libs/zlib/ChangeLog b/sys-libs/zlib/ChangeLog
index 67c1cb251dbf..d26ac489eeff 100644
--- a/sys-libs/zlib/ChangeLog
+++ b/sys-libs/zlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/zlib
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.55 2005/07/22 06:22:47 hardave Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.56 2006/02/21 23:55:33 vapier Exp $
+
+ 21 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/zlib-1.2.3-bsd-soname.patch, zlib-1.2.3.ebuild:
+ Generate DT_SONAME in the shared lib on BSD hosts #123571 by Diego Pettenò.
22 Jul 2005; Hardave Riar <hardave@gentoo.org> zlib-1.2.3.ebuild:
Stable on mips, bug #99751.
diff --git a/sys-libs/zlib/files/zlib-1.2.3-bsd-soname.patch b/sys-libs/zlib/files/zlib-1.2.3-bsd-soname.patch
new file mode 100644
index 000000000000..4c98b9814482
--- /dev/null
+++ b/sys-libs/zlib/files/zlib-1.2.3-bsd-soname.patch
@@ -0,0 +1,15 @@
+Generate a DT_SONAME on *BSD machines
+
+http://bugs.gentoo.org/123571
+
+--- configure
++++ configure
+@@ -80,7 +80,7 @@
+ SFLAGS="${CFLAGS-"-O3"} -fPIC"
+ CFLAGS="$cflags"
+ case `(uname -s || echo unknown) 2>/dev/null` in
+- Linux | linux | GNU | GNU/*)
++ Linux | linux | GNU | GNU/* | *BSD | DragonFly)
+ LDSHARED=${LDSHARED-"$cc -shared -Wl,-soname,libz.so.1"}
+ MAPFILE=${MAPFILE-"-Wl,--version-script,mapfile"};;
+ CYGWIN* | Cygwin* | cygwin* | OS/2* )
diff --git a/sys-libs/zlib/zlib-1.2.3.ebuild b/sys-libs/zlib/zlib-1.2.3.ebuild
index 18392fef37ac..68c5ec394dac 100644
--- a/sys-libs/zlib/zlib-1.2.3.ebuild
+++ b/sys-libs/zlib/zlib-1.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.3.ebuild,v 1.7 2005/11/26 01:03:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.3.ebuild,v 1.8 2006/02/21 23:55:33 vapier Exp $
inherit eutils flag-o-matic
@@ -30,6 +30,8 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-1.2.1-configure.patch
# fix shared library test on -fPIC dependant archs
epatch "${FILESDIR}"/${PN}-1.2.1-fPIC.patch
+ # generate DT_SONAME on BSD hosts #123571
+ epatch "${FILESDIR}"/${PN}-1.2.3-bsd-soname.patch
}
src_compile() {