summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-09-08 09:19:39 +0000
committerDonny Davies <woodchip@gentoo.org>2001-09-08 09:19:39 +0000
commit50804c4e7a0238084c0c36e2d306570f80d9d73e (patch)
tree915897efe46329c32aaa53cc535a1fd334863a95 /sys-libs
parentremoved over-cautious "|| die" phrases (diff)
downloadgentoo-2-50804c4e7a0238084c0c36e2d306570f80d9d73e.tar.gz
gentoo-2-50804c4e7a0238084c0c36e2d306570f80d9d73e.tar.bz2
gentoo-2-50804c4e7a0238084c0c36e2d306570f80d9d73e.zip
some rc5/rc6 initscript cleanup work. also, added an -r5 which will *should* stop X from being pulled into emerge system when xfree is not in the profile/packages file. Hmm, hoping drobbins can decide what the proper fix is here.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gpm/files/digest-gpm-1.19.3-r52
-rw-r--r--sys-libs/gpm/files/gpm-1.19.3-r420
-rw-r--r--[-rwxr-xr-x]sys-libs/gpm/files/gpm-run (renamed from sys-libs/gpm/files/gpm-run-1.19.3-r3)0
-rw-r--r--[-rwxr-xr-x]sys-libs/gpm/files/gpm.rc5 (renamed from sys-libs/gpm/files/gpm-1.19.3-r3)0
-rw-r--r--sys-libs/gpm/files/gpm.rc613
-rw-r--r--[-rwxr-xr-x]sys-libs/gpm/files/svc-gpm (renamed from sys-libs/gpm/files/svc-gpm-1.19.3-r3)0
-rw-r--r--sys-libs/gpm/gpm-1.19.3-r3.ebuild7
-rw-r--r--sys-libs/gpm/gpm-1.19.3-r4.ebuild4
-rw-r--r--sys-libs/gpm/gpm-1.19.3-r5.ebuild48
9 files changed, 67 insertions, 27 deletions
diff --git a/sys-libs/gpm/files/digest-gpm-1.19.3-r5 b/sys-libs/gpm/files/digest-gpm-1.19.3-r5
new file mode 100644
index 000000000000..493f00000502
--- /dev/null
+++ b/sys-libs/gpm/files/digest-gpm-1.19.3-r5
@@ -0,0 +1,2 @@
+MD5 69337348611578f680dc8e2224296878 devfs.patch
+MD5 dbfc33e0d52d008eeec1c8f93885e3f9 gpm-1.19.3.tar.gz
diff --git a/sys-libs/gpm/files/gpm-1.19.3-r4 b/sys-libs/gpm/files/gpm-1.19.3-r4
deleted file mode 100644
index 46e382588366..000000000000
--- a/sys-libs/gpm/files/gpm-1.19.3-r4
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/sbin/runscript
-PIDFILE=/var/run/gpm.pid
-EXE=/usr/sbin/gpm
-
-start() {
- ebegin "Starting ${SERVICE}"
- start-stop-daemon --start --quiet --exec ${EXE} -- -m ${MOUSEDEV} -t ${MOUSE}
- eend ${?} "Started ${SERVICE}." "Error starting ${SERVICE}."
-}
-
-stop() {
- ebegin "Stopping ${SERVICE}"
- start-stop-daemon --stop --quiet --pidfile ${PIDFILE} --exec ${EXE}
- eend ${?} "Stopped ${SERVICE}." "Error stopping ${SERVICE}."
-}
-
-restart() {
- stop
- start
-}
diff --git a/sys-libs/gpm/files/gpm-run-1.19.3-r3 b/sys-libs/gpm/files/gpm-run
index ca5e87e11dac..ca5e87e11dac 100755..100644
--- a/sys-libs/gpm/files/gpm-run-1.19.3-r3
+++ b/sys-libs/gpm/files/gpm-run
diff --git a/sys-libs/gpm/files/gpm-1.19.3-r3 b/sys-libs/gpm/files/gpm.rc5
index d70040518a64..d70040518a64 100755..100644
--- a/sys-libs/gpm/files/gpm-1.19.3-r3
+++ b/sys-libs/gpm/files/gpm.rc5
diff --git a/sys-libs/gpm/files/gpm.rc6 b/sys-libs/gpm/files/gpm.rc6
new file mode 100644
index 000000000000..e460100fe6ef
--- /dev/null
+++ b/sys-libs/gpm/files/gpm.rc6
@@ -0,0 +1,13 @@
+#!/sbin/runscript
+
+start() {
+ ebegin "Starting gpm"
+ start-stop-daemon --start --quiet --exec /usr/sbin/gpm -- -m ${MOUSEDEV} -t ${MOUSE}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping gpm"
+ start-stop-daemon --stop --quiet --pidfile /var/run/gpm.pid
+ eend ${?}
+}
diff --git a/sys-libs/gpm/files/svc-gpm-1.19.3-r3 b/sys-libs/gpm/files/svc-gpm
index 5918c37469f9..5918c37469f9 100755..100644
--- a/sys-libs/gpm/files/svc-gpm-1.19.3-r3
+++ b/sys-libs/gpm/files/svc-gpm
diff --git a/sys-libs/gpm/gpm-1.19.3-r3.ebuild b/sys-libs/gpm/gpm-1.19.3-r3.ebuild
index 1711c4210ddf..717ebd926443 100644
--- a/sys-libs/gpm/gpm-1.19.3-r3.ebuild
+++ b/sys-libs/gpm/gpm-1.19.3-r3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.19.3-r3.ebuild,v 1.2 2001/08/23 19:26:06 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.19.3-r3.ebuild,v 1.3 2001/09/08 09:19:39 woodchip Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Console-based mouse driver"
@@ -51,8 +51,5 @@ src_install() {
doins gpm-root.conf
exeinto /etc/rc.d/init.d
- newexe ${FILESDIR}/${PN}-${PVR} ${PN}
- newexe ${FILESDIR}/svc-${PN}-${PVR} svc-${PN}
- exeinto /var/lib/supervise/services/${PN}
- newexe ${FILESDIR}/${PN}-run-${PVR} run
+ newexe ${FILESDIR}/gpm.rc5 gpm
}
diff --git a/sys-libs/gpm/gpm-1.19.3-r4.ebuild b/sys-libs/gpm/gpm-1.19.3-r4.ebuild
index 14a60c135d62..1329a0d924da 100644
--- a/sys-libs/gpm/gpm-1.19.3-r4.ebuild
+++ b/sys-libs/gpm/gpm-1.19.3-r4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.19.3-r4.ebuild,v 1.1 2001/08/24 04:35:16 chadh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.19.3-r4.ebuild,v 1.2 2001/09/08 09:19:39 woodchip Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Console-based mouse driver"
@@ -51,5 +51,5 @@ src_install() {
doins gpm-root.conf
exeinto /etc/init.d
- newexe ${FILESDIR}/${PN}-${PVR} ${PN}
+ newexe ${FILESDIR}/gpm.rc6 gpm
}
diff --git a/sys-libs/gpm/gpm-1.19.3-r5.ebuild b/sys-libs/gpm/gpm-1.19.3-r5.ebuild
new file mode 100644
index 000000000000..4652321fbf67
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.19.3-r5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.19.3-r5.ebuild,v 1.1 2001/09/08 09:19:39 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Console-based mouse driver"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/mouse/${P}.tar.gz ftp://ftp.prosa.it/pub/gpm/patches/devfs.patch"
+DEPEND="virtual/glibc >=sys-libs/ncurses-5.2 sys-devel/autoconf"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ cp ${FILESDIR}/gpmInt.h .
+ patch -p1 < ${DISTDIR}/devfs.patch
+ #this little hack turns of EMACS byte compilation. Really don't want this thing auto-detecting emacs
+ cp configure.in configure.in.orig
+ sed -e '45i\' -e 'EMACS=:\' -e 'ELISP=' configure.in.orig > configure.in || die
+ autoconf || die
+}
+
+src_compile() {
+ ./configure --prefix=/usr --sysconfdir=/etc/gpm || die
+ # without-curses is required to avoid cyclic dependencies to ncurses
+
+ cp Makefile Makefile.orig
+ #The emacs stuff turns off auto byte-"complication"
+ sed -e "s/doc//" Makefile.orig > Makefile
+ #-e '/$(EMACS)/c\' -e ' echo'
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ chmod 755 ${D}/usr/lib/libgpm.so.1.18.0
+ dodoc Announce COPYING ChangeLog FAQ MANIFEST README.*
+ docinto txt
+ dodoc doc/gpmdoc.txt
+
+ insinto /etc/gpm
+ doins gpm-root.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/gpm.rc6 gpm
+}