summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-01 12:58:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-01 12:58:41 +0000
commit588465c5ccb0e6b47fc658d35b88aa3b68eb8e21 (patch)
treeeb282e053edc1706e41d27137bd4e85792c7d757 /sys-libs
parentCleanup due bug #151880 (diff)
downloadgentoo-2-588465c5ccb0e6b47fc658d35b88aa3b68eb8e21.tar.gz
gentoo-2-588465c5ccb0e6b47fc658d35b88aa3b68eb8e21.tar.bz2
gentoo-2-588465c5ccb0e6b47fc658d35b88aa3b68eb8e21.zip
Make libunwind usage optional: clang is setup to use libgcc_s so there is no serious point for now in trying to avoid using libgcc_s.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxxrt/ChangeLog7
-rw-r--r--sys-libs/libcxxrt/libcxxrt-9999.ebuild13
-rw-r--r--sys-libs/libcxxrt/metadata.xml3
3 files changed, 15 insertions, 8 deletions
diff --git a/sys-libs/libcxxrt/ChangeLog b/sys-libs/libcxxrt/ChangeLog
index 8678985f23de..8d17a0d5215a 100644
--- a/sys-libs/libcxxrt/ChangeLog
+++ b/sys-libs/libcxxrt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libcxxrt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v 1.11 2013/05/31 15:54:40 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v 1.12 2013/06/01 12:58:41 aballier Exp $
+
+ 01 Jun 2013; Alexis Ballier <aballier@gentoo.org> libcxxrt-9999.ebuild,
+ metadata.xml:
+ Make libunwind usage optional: clang is setup to use libgcc_s so there is no
+ serious point for now in trying to avoid using libgcc_s.
*libcxxrt-0.0_p20130531 (31 May 2013)
diff --git a/sys-libs/libcxxrt/libcxxrt-9999.ebuild b/sys-libs/libcxxrt/libcxxrt-9999.ebuild
index c605dce95434..2a42a0d280b2 100644
--- a/sys-libs/libcxxrt/libcxxrt-9999.ebuild
+++ b/sys-libs/libcxxrt/libcxxrt-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/libcxxrt-9999.ebuild,v 1.6 2013/05/30 23:33:32 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/libcxxrt-9999.ebuild,v 1.7 2013/06/01 12:58:41 aballier Exp $
-EAPI=4
+EAPI=5
EGIT_REPO_URI="git://github.com/pathscale/libcxxrt.git"
@@ -26,9 +26,9 @@ if [ "${PV%9999}" = "${PV}" ] ; then
else
KEYWORDS=""
fi
-IUSE="static-libs"
+IUSE="libunwind static-libs"
-RDEPEND=">=sys-libs/libunwind-1.0.1-r1[static-libs?]"
+RDEPEND="libunwind? ( >=sys-libs/libunwind-1.0.1-r1[static-libs?] )"
DEPEND="${RDEPEND}
${DEPEND}"
@@ -40,12 +40,11 @@ src_prepare() {
src_compile() {
# Notes: we build -nodefaultlibs to avoid linking to gcc libs.
- # libcxxrt needs: dladdr (dlopen_lib), libunwind (or libgcc_s but we build
- # over libunwind) and the libc.
+ # libcxxrt needs: dladdr (dlopen_lib), libunwind or libgcc_s and the libc.
tc-export CC CXX AR
append-ldflags "-Wl,-z,defs" # make sure we are not underlinked
cd "${S}/src"
- LIBS="$(dlopen_lib) -lunwind -lc" emake shared
+ LIBS="$(dlopen_lib) -l$(usex libunwind unwind gcc_s) -lc" emake shared
use static-libs && emake static
}
diff --git a/sys-libs/libcxxrt/metadata.xml b/sys-libs/libcxxrt/metadata.xml
index 503e8a53624d..38e83d0c31d0 100644
--- a/sys-libs/libcxxrt/metadata.xml
+++ b/sys-libs/libcxxrt/metadata.xml
@@ -6,5 +6,8 @@
<email>aballier@gentoo.org</email>
<name>Alexis Ballier</name>
</maintainer>
+ <use>
+ <flag name="libunwind">Use <pkg>sys-libs/libunwind</pkg> instead of libgcc_s for unwinding. This should allow avoiding relying on <pkg>sys-devel/gcc</pkg> but for now clang is setup to use libgcc_s.</flag>
+ </use>
</pkgmetadata>