summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-16 14:11:51 +0000
committerMike Frysinger <vapier@gentoo.org>2008-11-16 14:11:51 +0000
commit7c5b59cfd8f3b2eec66d77bcdc9ab0c4bf3927cd (patch)
tree8ea914579b9c4d14a56f1f9ba5a4f4f14b45440b /sys-libs
parentWorkaround parallel install failures (use -j1 for install). (diff)
downloadgentoo-2-7c5b59cfd8f3b2eec66d77bcdc9ab0c4bf3927cd.tar.gz
gentoo-2-7c5b59cfd8f3b2eec66d77bcdc9ab0c4bf3927cd.tar.bz2
gentoo-2-7c5b59cfd8f3b2eec66d77bcdc9ab0c4bf3927cd.zip
Version bump #246944 by Arfrever Frehtes Taifersar Arahesis.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27.4 x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcap/ChangeLog8
-rw-r--r--sys-libs/libcap/files/2.14/0001-cleanup-build-system.patch146
-rw-r--r--sys-libs/libcap/libcap-2.14.ebuild43
3 files changed, 196 insertions, 1 deletions
diff --git a/sys-libs/libcap/ChangeLog b/sys-libs/libcap/ChangeLog
index 318d7c2e0e1e..7329a0f7451e 100644
--- a/sys-libs/libcap/ChangeLog
+++ b/sys-libs/libcap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libcap
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.74 2008/10/26 02:37:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.75 2008/11/16 14:11:51 vapier Exp $
+
+*libcap-2.14 (16 Nov 2008)
+
+ 16 Nov 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/2.14/0001-cleanup-build-system.patch, +libcap-2.14.ebuild:
+ Version bump #246944 by Arfrever Frehtes Taifersar Arahesis.
25 Oct 2008; Mike Frysinger <vapier@gentoo.org> libcap-2.11.ebuild:
Add fix for USE=-pam builds by Bruno #242748.
diff --git a/sys-libs/libcap/files/2.14/0001-cleanup-build-system.patch b/sys-libs/libcap/files/2.14/0001-cleanup-build-system.patch
new file mode 100644
index 000000000000..99a05e6fc57c
--- /dev/null
+++ b/sys-libs/libcap/files/2.14/0001-cleanup-build-system.patch
@@ -0,0 +1,146 @@
+From 8dfeef49b5acde14fc8749e89f7af53bb64f4054 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 31 May 2008 22:21:31 -0400
+Subject: [PATCH] cleanup build system
+
+This refactors the homebrewed build system to work much better "out of the
+box" for people. It moves tools/flags into appropriate env-overridable
+variables as well as simplifies the subdirectory handling and flag passing.
+A few bug fixes are also mixed in such as proper link order, parallel build
+failure due to local header generation, and splitting up of logic between
+binaries compiled and run on the build system and binaries compiled to run
+on the target system.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Make.Rules | 28 ++++++++++++++--------------
+ libcap/Makefile | 10 ++++++----
+ pam_cap/Makefile | 6 +++---
+ progs/Makefile | 2 +-
+ 4 files changed, 24 insertions(+), 22 deletions(-)
+
+diff --git a/Make.Rules b/Make.Rules
+index 6bf1562..660ae7d 100644
+--- a/Make.Rules
++++ b/Make.Rules
+@@ -42,27 +42,27 @@ MINOR=15
+
+ # Compilation specifics
+
+-KERNEL_HEADERS := $(topdir)/libcap/include
+-IPATH += -I$(topdir)/libcap/include -I$(KERNEL_HEADERS)
+-
+-CC := gcc
+-CFLAGS := -O2
+-BUILD_CC := $(CC)
+-BUILD_CFLAGS := $(CFLAGS) $(IPATH)
+-AR := ar
+-RANLIB := ranlib
+-DEBUG = -g #-DDEBUG
+-WARNINGS=-fPIC -Wall -Wwrite-strings \
++CC ?= gcc
++BUILD_CC ?= $(CC)
++AR ?= ar
++RANLIB ?= ranlib
++CFLAGS ?= -O2
++BUILD_CFLAGS ?= $(CFLAGS)
++WARNINGS=-Wall -Wwrite-strings \
+ -Wpointer-arith -Wcast-qual -Wcast-align \
+ -Wstrict-prototypes -Wmissing-prototypes \
+ -Wnested-externs -Winline -Wshadow
+ LD=$(CC) -Wl,-x -shared
+-LDFLAGS := #-g
++LDFLAGS ?= #-g
+
+-SYSTEM_HEADERS = /usr/include
++KERNEL_HEADERS = $(topdir)/libcap/include
++LIBCAP_CPPFLAGS = -I$(topdir)/libcap/include -I$(KERNEL_HEADERS)
++CPPFLAGS += $(LIBCAP_CPPFLAGS)
++BUILD_CPPFLAGS += $(LIBCAP_CPPFLAGS)
+ INCS=$(topdir)/libcap/include/sys/capability.h
+ LDFLAGS += -L$(topdir)/libcap
+-CFLAGS += -Dlinux $(WARNINGS) $(DEBUG) $(IPATH)
++CPPFLAGS += -Dlinux
++CFLAGS += $(WARNINGS)
+ PAM_CAP := $(shell if [ -f /usr/include/security/pam_modules.h ]; then echo yes ; else echo no ; fi)
+ INDENT := $(shell if [ -z "$(which ident 2>/dev/null)" ]; then echo "| indent -kr" ; fi)
+ DYNAMIC := $(shell if [ ! -d "$(topdir)/.git" ]; then echo yes; fi)
+diff --git a/libcap/Makefile b/libcap/Makefile
+index a47e672..0aa3e9a 100644
+--- a/libcap/Makefile
++++ b/libcap/Makefile
+@@ -24,7 +24,8 @@ OBJS=$(addsuffix .o, $(FILES))
+ MAJLIBNAME=$(LIBNAME).$(VERSION)
+ MINLIBNAME=$(MAJLIBNAME).$(MINOR)
+ GPERF_OUTPUT = _caps_output.gperf
+-LDFLAGS += -lattr
++LDLIBS += -lattr
++CFLAGS += -fPIC
+
+ all: $(MINLIBNAME) $(STALIBNAME)
+
+@@ -33,7 +35,7 @@ INCLUDE_GPERF_OUTPUT = -include $(GPERF_OUTPUT)
+ endif
+
+ _makenames: _makenames.c cap_names.sed
+- $(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
++ $(BUILD_CC) $(BUILD_CFLAGS) $(BUILD_CPPFLAGS) $< -o $@
+
+ cap_names.h: _makenames
+ ./_makenames > cap_names.h
+@@ -50,15 +52,15 @@ $(STALIBNAME): $(OBJS)
+ $(RANLIB) $@
+
+ $(MINLIBNAME): $(OBJS)
+- $(LD) $(CFLAGS) $(LDFLAGS) -Wl,-soname,$(MAJLIBNAME) -o $@ $^
++ $(LD) $(CFLAGS) $(LDFLAGS) -Wl,-soname,$(MAJLIBNAME) -o $@ $^ $(LDLIBS)
+ ln -sf $(MINLIBNAME) $(MAJLIBNAME)
+ ln -sf $(MAJLIBNAME) $(LIBNAME)
+
+ %.o: %.c $(INCLS)
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ cap_text.o: cap_text.c $(USE_GPERF_OUTPUT) $(INCLS)
+- $(CC) $(CFLAGS) $(INCLUDE_GPERF_OUTPUT) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(INCLUDE_GPERF_OUTPUT) -c $< -o $@
+
+ install: all
+ mkdir -p -m 0755 $(INCDIR)/sys
+diff --git a/pam_cap/Makefile b/pam_cap/Makefile
+index eae88ed..bef59d2 100644
+--- a/pam_cap/Makefile
++++ b/pam_cap/Makefile
+@@ -14,13 +14,13 @@ install: all
+ install -m 0755 pam_cap.so $(LIBDIR)/security
+
+ pam_cap.so: pam_cap.o
+- $(LD) $(LDFLAGS) -o pam_cap.so $< $(LDLIBS)
++ $(LD) $(CFLAGS) $(LDFLAGS) -o pam_cap.so $< $(LDLIBS)
+
+ pam_cap.o: pam_cap.c
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ testcompile: test.c pam_cap.o
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $+ -lpam -ldl $(LDLIBS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $+ -lpam -ldl $(LDLIBS)
+
+ clean:
+ rm -f *.o *.so testcompile *~
+diff --git a/progs/Makefile b/progs/Makefile
+index a1542dc..612cf86 100644
+--- a/progs/Makefile
++++ b/progs/Makefile
+@@ -22,7 +22,7 @@ $(BUILD): %: %.o
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $< $(LDLIBS)
+
+ %.o: %.c $(INCS)
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ install: all
+ mkdir -p -m 0755 $(SBINDIR)
+--
+1.6.0.3
+
diff --git a/sys-libs/libcap/libcap-2.14.ebuild b/sys-libs/libcap/libcap-2.14.ebuild
new file mode 100644
index 000000000000..7da7fdc23e44
--- /dev/null
+++ b/sys-libs/libcap/libcap-2.14.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-2.14.ebuild,v 1.1 2008/11/16 14:11:51 vapier Exp $
+
+inherit eutils multilib toolchain-funcs pam
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="http://www.friedhoff.org/posixfilecaps.html"
+SRC_URI="mirror://kernel/linux/libs/security/linux-privs/libcap${PV:0:1}/${P}.tar.bz2"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="pam"
+
+RDEPEND="sys-apps/attr
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}/*.patch
+ sed -i -e '/cap_setfcap.*morgan/s:^:#:' pam_cap/capability.conf
+}
+
+src_compile() {
+ tc-export BUILD_CC CC AR RANLIB
+ emake DYNAMIC=yes PAM_CAP=$(use pam && echo yes || echo no) || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" lib=$(get_libdir) || die
+
+ gen_usr_ldscript libcap.so
+ mv "${D}"/$(get_libdir)/libcap.a "${D}"/usr/$(get_libdir)/ || die
+
+ dopammod pam_cap/pam_cap.so
+ dopamsecurity '' pam_cap/capability.conf
+
+ dodoc CHANGELOG README doc/capability.notes
+}