summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-05-16 16:14:20 +0000
committerMike Frysinger <vapier@gentoo.org>2009-05-16 16:14:20 +0000
commit8dec7ff111d0ade179514fb60556b43464961246 (patch)
tree70a32f587d78f6e3ddc09c8759156a33be9a1dba /sys-libs
parentAdded ~x86. (diff)
downloadgentoo-2-8dec7ff111d0ade179514fb60556b43464961246.tar.gz
gentoo-2-8dec7ff111d0ade179514fb60556b43464961246.tar.bz2
gentoo-2-8dec7ff111d0ade179514fb60556b43464961246.zip
old
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcap/files/2.15/0001-build-system-fixes.patch154
-rw-r--r--sys-libs/libcap/libcap-2.15.ebuild48
2 files changed, 0 insertions, 202 deletions
diff --git a/sys-libs/libcap/files/2.15/0001-build-system-fixes.patch b/sys-libs/libcap/files/2.15/0001-build-system-fixes.patch
deleted file mode 100644
index 3f52ead45286..000000000000
--- a/sys-libs/libcap/files/2.15/0001-build-system-fixes.patch
+++ /dev/null
@@ -1,154 +0,0 @@
-From 7125b8dba3b9e0f072c87ad78f3458216fe3d749 Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Sun, 16 Nov 2008 09:10:31 -0500
-Subject: [PATCH] build system fixes
-
-This touches up the homebrewed build system to work much better "out of the
-box" for people. Specifically:
- - allow toolchain vars to be set via environment
- - CC / BUILD_CC / AR / RANLIB
- - CFLAGS / CPPFLAGS / LDFLAGS
- - split CPPFLAGS out of CFLAGS
- - break -fPIC out of global CFLAGS and only use where needed
- - use LDLIBS for libraries, not LDFLAGS
-
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
----
- Make.Rules | 28 ++++++++++++++--------------
- libcap/Makefile | 11 ++++++-----
- pam_cap/Makefile | 6 +++---
- progs/Makefile | 2 +-
- 4 files changed, 24 insertions(+), 23 deletions(-)
-
-diff --git a/Make.Rules b/Make.Rules
-index 4a3d49a..9859fa7 100644
---- a/Make.Rules
-+++ b/Make.Rules
-@@ -42,27 +42,27 @@ MINOR=15
-
- # Compilation specifics
-
--KERNEL_HEADERS := $(topdir)/libcap/include
--IPATH += -I$(topdir)/libcap/include -I$(KERNEL_HEADERS)
--
--CC := gcc
--CFLAGS := -O2
--BUILD_CC := $(CC)
--BUILD_CFLAGS := $(CFLAGS) $(IPATH)
--AR := ar
--RANLIB := ranlib
--DEBUG = -g #-DDEBUG
--WARNINGS=-fPIC -Wall -Wwrite-strings \
-+CC ?= gcc
-+BUILD_CC ?= $(CC)
-+AR ?= ar
-+RANLIB ?= ranlib
-+CFLAGS ?= -O2
-+BUILD_CFLAGS ?= $(CFLAGS)
-+WARNINGS=-Wall -Wwrite-strings \
- -Wpointer-arith -Wcast-qual -Wcast-align \
- -Wstrict-prototypes -Wmissing-prototypes \
- -Wnested-externs -Winline -Wshadow
- LD=$(CC) -Wl,-x -shared
--LDFLAGS := #-g
-+LDFLAGS ?= #-g
-
--SYSTEM_HEADERS = /usr/include
-+KERNEL_HEADERS = $(topdir)/libcap/include
-+LIBCAP_CPPFLAGS = -I$(topdir)/libcap/include -I$(KERNEL_HEADERS)
-+CPPFLAGS += $(LIBCAP_CPPFLAGS)
-+BUILD_CPPFLAGS += $(LIBCAP_CPPFLAGS)
- INCS=$(topdir)/libcap/include/sys/capability.h
- LDFLAGS += -L$(topdir)/libcap
--CFLAGS += -Dlinux $(WARNINGS) $(DEBUG) $(IPATH)
-+CPPFLAGS += -Dlinux
-+CFLAGS += $(WARNINGS)
- PAM_CAP := $(shell if [ -f /usr/include/security/pam_modules.h ]; then echo yes ; else echo no ; fi)
- INDENT := $(shell if [ -n "$(which indent 2>/dev/null)" ]; then echo "| indent -kr" ; fi)
- DYNAMIC := $(shell if [ ! -d "$(topdir)/.git" ]; then echo yes; fi)
-diff --git a/libcap/Makefile b/libcap/Makefile
-index a47e672..7a938a8 100644
---- a/libcap/Makefile
-+++ b/libcap/Makefile
-@@ -16,7 +16,7 @@ FILES=cap_alloc cap_proc cap_extint cap_flag cap_text
- # no support).
- ifeq ($(LIBATTR),yes)
- FILES += cap_file
--LDFLAGS += -lattr
-+LDLIBS += -lattr
- endif
-
- INCLS=libcap.h cap_names.h $(INCS)
-@@ -24,6 +24,7 @@ OBJS=$(addsuffix .o, $(FILES))
- MAJLIBNAME=$(LIBNAME).$(VERSION)
- MINLIBNAME=$(MAJLIBNAME).$(MINOR)
- GPERF_OUTPUT = _caps_output.gperf
-+CFLAGS += -fPIC
-
- all: $(MINLIBNAME) $(STALIBNAME)
-
-@@ -33,7 +34,7 @@ INCLUDE_GPERF_OUTPUT = -include $(GPERF_OUTPUT)
- endif
-
- _makenames: _makenames.c cap_names.sed
-- $(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
-+ $(BUILD_CC) $(BUILD_CFLAGS) $(BUILD_CPPFLAGS) $< -o $@
-
- cap_names.h: _makenames
- ./_makenames > cap_names.h
-@@ -50,15 +51,15 @@ $(STALIBNAME): $(OBJS)
- $(RANLIB) $@
-
- $(MINLIBNAME): $(OBJS)
-- $(LD) $(CFLAGS) $(LDFLAGS) -Wl,-soname,$(MAJLIBNAME) -o $@ $^
-+ $(LD) $(CFLAGS) $(LDFLAGS) -Wl,-soname,$(MAJLIBNAME) -o $@ $^ $(LDLIBS)
- ln -sf $(MINLIBNAME) $(MAJLIBNAME)
- ln -sf $(MAJLIBNAME) $(LIBNAME)
-
- %.o: %.c $(INCLS)
-- $(CC) $(CFLAGS) -c $< -o $@
-+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
-
- cap_text.o: cap_text.c $(USE_GPERF_OUTPUT) $(INCLS)
-- $(CC) $(CFLAGS) $(INCLUDE_GPERF_OUTPUT) -c $< -o $@
-+ $(CC) $(CFLAGS) $(CPPFLAGS) $(INCLUDE_GPERF_OUTPUT) -c $< -o $@
-
- install: all
- mkdir -p -m 0755 $(INCDIR)/sys
-diff --git a/pam_cap/Makefile b/pam_cap/Makefile
-index eae88ed..bef59d2 100644
---- a/pam_cap/Makefile
-+++ b/pam_cap/Makefile
-@@ -14,13 +14,13 @@ install: all
- install -m 0755 pam_cap.so $(LIBDIR)/security
-
- pam_cap.so: pam_cap.o
-- $(LD) $(LDFLAGS) -o pam_cap.so $< $(LDLIBS)
-+ $(LD) $(CFLAGS) $(LDFLAGS) -o pam_cap.so $< $(LDLIBS)
-
- pam_cap.o: pam_cap.c
-- $(CC) $(CFLAGS) -c $< -o $@
-+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
-
- testcompile: test.c pam_cap.o
-- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $+ -lpam -ldl $(LDLIBS)
-+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $@ $+ -lpam -ldl $(LDLIBS)
-
- clean:
- rm -f *.o *.so testcompile *~
-diff --git a/progs/Makefile b/progs/Makefile
-index a1542dc..612cf86 100644
---- a/progs/Makefile
-+++ b/progs/Makefile
-@@ -22,7 +22,7 @@ $(BUILD): %: %.o
- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $< $(LDLIBS)
-
- %.o: %.c $(INCS)
-- $(CC) $(CFLAGS) -c $< -o $@
-+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
-
- install: all
- mkdir -p -m 0755 $(SBINDIR)
---
-1.6.0.4
-
diff --git a/sys-libs/libcap/libcap-2.15.ebuild b/sys-libs/libcap/libcap-2.15.ebuild
deleted file mode 100644
index 3acd91ed800d..000000000000
--- a/sys-libs/libcap/libcap-2.15.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-2.15.ebuild,v 1.10 2009/01/17 17:18:14 vapier Exp $
-
-inherit eutils multilib toolchain-funcs pam
-
-DESCRIPTION="POSIX 1003.1e capabilities"
-HOMEPAGE="http://www.friedhoff.org/posixfilecaps.html"
-SRC_URI="mirror://kernel/linux/libs/security/linux-privs/libcap${PV:0:1}/${P}.tar.bz2"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="pam"
-
-RDEPEND="sys-apps/attr
- pam? ( virtual/pam )"
-DEPEND="${RDEPEND}
- sys-kernel/linux-headers"
-
-src_unpack() {
- unpack ${P}.tar.bz2
- cd "${S}"
- epatch "${FILESDIR}"/${PV}/*.patch
- sed -i -e '/cap_setfcap.*morgan/s:^:#:' pam_cap/capability.conf
- sed -i \
- -e "/^PAM_CAP/s:=.*:=$(use pam && echo yes || echo no):" \
- -e '/^DYNAMIC/s:=.*:=yes:' \
- -e "/^lib=/s:=.*:=$(get_libdir):" \
- Make.Rules
-}
-
-src_compile() {
- tc-export BUILD_CC CC AR RANLIB
- emake || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
-
- gen_usr_ldscript libcap.so
- mv "${D}"/$(get_libdir)/libcap.a "${D}"/usr/$(get_libdir)/ || die
-
- dopammod pam_cap/pam_cap.so
- dopamsecurity '' pam_cap/capability.conf
-
- dodoc CHANGELOG README doc/capability.notes
-}