summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2004-07-21 21:09:59 +0000
committerGuy Martin <gmsoft@gentoo.org>2004-07-21 21:09:59 +0000
commit9e8c0e284c06e3855d2798a8f086dcb1f915d738 (patch)
treef26d7d84e1a36fe7500815b4baa79e5da4a5ff88 /sys-libs
parentstable on ppc64, bug #57575 (Manifest recommit) (diff)
downloadgentoo-2-9e8c0e284c06e3855d2798a8f086dcb1f915d738.tar.gz
gentoo-2-9e8c0e284c06e3855d2798a8f086dcb1f915d738.tar.bz2
gentoo-2-9e8c0e284c06e3855d2798a8f086dcb1f915d738.zip
Added patches for hppa.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog5
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040619.ebuild20
2 files changed, 19 insertions, 6 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 19bc51792e08..ddbd0b1d4b1a 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.210 2004/07/20 10:59:01 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.211 2004/07/21 21:09:59 gmsoft Exp $
+
+ 21 Jul 2004; Guy Martin <gmsoft@gentoo.org> glibc-2.3.4.20040619:
+ Added patches for hppa.
20 Jul 2004; Alexander Gabert <pappy@gentoo.org>
glibc-2.3.3.20040420.ebuild:
diff --git a/sys-libs/glibc/glibc-2.3.4.20040619.ebuild b/sys-libs/glibc/glibc-2.3.4.20040619.ebuild
index ae0fb812f13b..6255bcd2f378 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040619.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040619.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619.ebuild,v 1.17 2004/07/19 23:21:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619.ebuild,v 1.18 2004/07/21 21:06:43 gmsoft Exp $
inherit eutils flag-o-matic gcc
@@ -27,9 +27,12 @@ S="${WORKDIR}/${PN}-${BASE_PV}"
DESCRIPTION="GNU libc6 (also called glibc2) C library"
HOMEPAGE="http://sources.redhat.com/glibc/"
+HPPA_PATCHES=2004-06-04
+
SRC_URI="http://ftp.gnu.org/gnu/${PN}/${PN}-${BASE_PV}.tar.bz2
ftp://sources.redhat.com/pub/${PN}/snapshots/${PN}-${BASE_PV}.tar.bz2
- mirror://gentoo/${PN}-manpages-${NEW_PV}.tar.bz2"
+ mirror://gentoo/${PN}-manpages-${NEW_PV}.tar.bz2
+ hppa? ( http://parisc-linux.org/~carlos/glibc-work/glibc-hppa-patches-${HPPA_PATCHES}.tar.gz )"
if [ -z "${BRANCH_UPDATE}" ]; then
SRC_URI="${SRC_URI}
http://ftp.gnu.org/gnu/${PN}/${PN}-linuxthreads-${BASE_PV}.tar.bz2
@@ -41,7 +44,7 @@ fi
LICENSE="LGPL-2"
SLOT="2.2"
-KEYWORDS="-* ~x86 ~mips ~amd64"
+KEYWORDS="-* ~x86 ~mips ~amd64 ~hppa"
IUSE="nls pic build nptl erandom hardened makecheck multilib debug"
# We need new cleanup attribute support from gcc for NPTL among things ...
@@ -330,9 +333,16 @@ do_arch_arm_patches() {
do_arch_hppa_patches() {
- cd ${S};
+ einfo "Applying hppa specific path of ${HPPA_PATCHES} ..."
+ cd ${T}
+ unpack glibc-hppa-patches-${HPPA_PATCHES}.tar.gz
+ cd ${S}
+ export EPATCH_OPTS=-p1
+ for i in ${T}/glibc-hppa-patches-${HPPA_PATCHES}/*.diff
+ do
+ patch -p 1 < ${i}
+ done
- # Any needed patches for hppa go here
}