summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-07 06:32:04 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-07 06:32:04 +0000
commitc5343321faf6fa3a0bdaa5efa45dd70aee8ce608 (patch)
tree679cf186dd1f9f766dd9a0f091fa70233e8f388b /sys-libs
parentVersion bump, mostly fixing a few cjk issues in previous version (diff)
downloadgentoo-2-c5343321faf6fa3a0bdaa5efa45dd70aee8ce608.tar.gz
gentoo-2-c5343321faf6fa3a0bdaa5efa45dd70aee8ce608.tar.bz2
gentoo-2-c5343321faf6fa3a0bdaa5efa45dd70aee8ce608.zip
allow people to build linuxthreads again (ugh)
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.5.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/sys-libs/glibc/glibc-2.5.ebuild b/sys-libs/glibc/glibc-2.5.ebuild
index b2b3e149e99b..9ae018d088db 100644
--- a/sys-libs/glibc/glibc-2.5.ebuild
+++ b/sys-libs/glibc/glibc-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5.ebuild,v 1.5 2006/10/07 05:55:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5.ebuild,v 1.6 2006/10/07 06:32:04 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -39,8 +39,6 @@ DESCRIPTION="GNU libc6 (also called glibc2) C library"
HOMEPAGE="http://www.gnu.org/software/libc/libc.html"
LICENSE="LGPL-2"
-# note that nptl/nptlonly/glibc-compat20 are for upgrade checks only.
-# we dont generally support these things in this version.
IUSE="nls build nptl nptlonly hardened multilib selinux glibc-omitfp profile glibc-compat20"
export CBUILD=${CBUILD:-${CHOST}}
@@ -1029,16 +1027,9 @@ pkg_setup() {
fi
fi
- if use glibc-compat20 ; then
- eerror "This version no longer provides compatibility with old broken"
- eerror "applications. If you need this support, call your vendor"
- eerror "and tell them to release an update that isn't broken."
- die "non-TLS symbol errno@glibc_2.0 not supported"
- fi
- if want_linuxthreads ; then
- ewarn "glibc-2.5 is nptl-only!"
- [[ ${CTARGET} == i386-* ]] && eerror "NPTL requires a CHOST of i486 or better"
- die "please add USE='nptl nptlonly' to make.conf"
+ if want_nptl && [[ ${CTARGET} == i386-* ]] ; then
+ eerror "NPTL requires a CHOST of i486 or better"
+ die "please fix your CHOST"
fi
if use nptlonly && ! use nptl ; then