summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-24 05:29:04 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-24 05:29:04 +0000
commitb27ab2b0475d34e75f384b3f9e50bb7b4674200b (patch)
treecdaacd181a3774d35b664e47c31a29a69955eb8a /sys-power
parentUSE flag change qt->qt3/qt4 bug #137785 (diff)
downloadgentoo-2-b27ab2b0475d34e75f384b3f9e50bb7b4674200b.tar.gz
gentoo-2-b27ab2b0475d34e75f384b3f9e50bb7b4674200b.tar.bz2
gentoo-2-b27ab2b0475d34e75f384b3f9e50bb7b4674200b.zip
Fix cleanup ebuild #137576 by Tristan Heaven.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/athcool/ChangeLog8
-rw-r--r--sys-power/athcool/athcool-0.3.11.ebuild18
-rw-r--r--sys-power/athcool/files/athcool-0.3.11-build.patch32
3 files changed, 50 insertions, 8 deletions
diff --git a/sys-power/athcool/ChangeLog b/sys-power/athcool/ChangeLog
index cbe04937bd0c..157b50291cdf 100644
--- a/sys-power/athcool/ChangeLog
+++ b/sys-power/athcool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/athcool
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/ChangeLog,v 1.3 2005/06/27 13:19:22 lisa Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/ChangeLog,v 1.4 2006/06/24 05:29:04 vapier Exp $
+
+ 24 Jun 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/athcool-0.3.11-build.patch, athcool-0.3.11.ebuild:
+ Fix cleanup ebuild #137576 by Tristan Heaven.
*athcool-0.3.11 (27 Jun 2005)
diff --git a/sys-power/athcool/athcool-0.3.11.ebuild b/sys-power/athcool/athcool-0.3.11.ebuild
index bf13ee273a5f..7f2e7ce943a0 100644
--- a/sys-power/athcool/athcool-0.3.11.ebuild
+++ b/sys-power/athcool/athcool-0.3.11.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/athcool-0.3.11.ebuild,v 1.2 2006/02/18 06:43:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/athcool/athcool-0.3.11.ebuild,v 1.3 2006/06/24 05:29:04 vapier Exp $
+
+inherit eutils
DESCRIPTION="small utility to toggle Powersaving mode for AMD Athlon/Duron processors"
HOMEPAGE="http://members.jcom.home.ne.jp/jacobi/linux/softwares.html#athcool"
@@ -13,20 +15,24 @@ IUSE=""
DEPEND="sys-apps/pciutils"
-src_compile() {
- emake CFLAGS="${CFLAGS}" || die
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
}
src_install() {
- einstall || die
+ emake install DESTDIR="${D}" || die
doinitd "${FILESDIR}"/athcool
dodoc README ChangeLog
}
pkg_postinst() {
- ewarn "WARNING: Depending on your motherboard and/or hardware components, enabling powersaving mode may cause:"
+ ewarn "WARNING: Depending on your motherboard and/or hardware components,"
+ ewarn "enabling powersaving mode may cause:"
ewarn " * noisy or distorted sound playback"
ewarn " * a slowdown in harddisk performance"
ewarn " * system locks or instability"
- ewarn "If you met those problems, you should not use athcool. Please use athcool AT YOUR OWN RISK!"
+ ewarn "If you met those problems, you should not use athcool. Please use"
+ ewarn "athcool AT YOUR OWN RISK!"
}
diff --git a/sys-power/athcool/files/athcool-0.3.11-build.patch b/sys-power/athcool/files/athcool-0.3.11-build.patch
new file mode 100644
index 000000000000..e29f0a2e9b39
--- /dev/null
+++ b/sys-power/athcool/files/athcool-0.3.11-build.patch
@@ -0,0 +1,32 @@
+--- Makefile.orig 2006-06-24 01:30:31.000000000 -0400
++++ Makefile 2006-06-24 01:31:17.000000000 -0400
+@@ -14,10 +14,10 @@
+ SRCS = athcool.c scanpci.c
+ OBJS = $(SRCS:.c=.o)
+
+-CC = gcc
++CC ?= gcc
+ RM = rm -f
+-CFLAGS = -O2 -Wall
+-DEFS = -I. -I$(includedir) -DPACKAGE=\"$(PACKAGE)\" -DVERSION=\"$(VERSION)\"
++CFLAGS += -Wall
++DEFS = -I. -DPACKAGE=\"$(PACKAGE)\" -DVERSION=\"$(VERSION)\"
+ #DEFS += -DENABLE_FORCEID=1
+ #DEFS += -DDISABLE_WRITE_REG=1
+ LIBS = -lpci
+@@ -30,13 +30,13 @@
+ all: $(PACKAGE)
+
+ $(PACKAGE): $(OBJS)
+- $(CC) $(CFLAGS) $(OBJS) $(LIBS) -o $@
++ $(CC) $(CFLAGS) $(OBJS) $(LIBS) -o $@ $(LDFLAGS)
+
+ install: install-program install-man # install-script
+
+ install-program:
+ [ -d $(sbindir) ] || install -m 755 -d $(sbindir)
+- install -s $(PACKAGE) $(sbindir)
++ install $(PACKAGE) $(sbindir)
+
+ install-man:
+ [ -d $(mandir)/man8 ] || install -m 755 -d $(mandir)/man8