summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-11-20 09:25:20 +0000
committerThilo Bangert <bangert@gentoo.org>2009-11-20 09:25:20 +0000
commit7daf90a6b2ef6053d5564b200052e480df1e4186 (patch)
tree113d685111d837bc4cfe075ffd02d1b956039786 /sys-process/cronie
parentcleanup (diff)
downloadgentoo-2-7daf90a6b2ef6053d5564b200052e480df1e4186.tar.gz
gentoo-2-7daf90a6b2ef6053d5564b200052e480df1e4186.tar.bz2
gentoo-2-7daf90a6b2ef6053d5564b200052e480df1e4186.zip
version bump
(Portage version: 2.2_rc50/cvs/Linux i686)
Diffstat (limited to 'sys-process/cronie')
-rw-r--r--sys-process/cronie/ChangeLog8
-rw-r--r--sys-process/cronie/cronie-1.4.3.ebuild52
-rw-r--r--sys-process/cronie/files/cronie-1.4.3-pamd9
3 files changed, 68 insertions, 1 deletions
diff --git a/sys-process/cronie/ChangeLog b/sys-process/cronie/ChangeLog
index 23f41c80c5d0..53ea47185dc5 100644
--- a/sys-process/cronie/ChangeLog
+++ b/sys-process/cronie/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/cronie
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.6 2009/08/23 20:12:43 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.7 2009/11/20 09:25:20 bangert Exp $
+
+*cronie-1.4.3 (20 Nov 2009)
+
+ 20 Nov 2009; Thilo Bangert <bangert@gentoo.org> +cronie-1.4.3.ebuild,
+ +files/cronie-1.4.3-pamd:
+ version bump
*cronie-1.4.1 (23 Aug 2009)
diff --git a/sys-process/cronie/cronie-1.4.3.ebuild b/sys-process/cronie/cronie-1.4.3.ebuild
new file mode 100644
index 000000000000..d734c5313132
--- /dev/null
+++ b/sys-process/cronie/cronie-1.4.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.3.ebuild,v 1.1 2009/11/20 09:25:20 bangert Exp $
+
+EAPI="2"
+
+inherit cron eutils pam
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron."
+SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
+HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+
+LICENSE="ISC BSD BSD-2"
+KEYWORDS="~x86"
+IUSE="inotify pam"
+
+DEPEND="pam? ( virtual/pam )"
+RDEPEND="${DEPEND}"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+src_configure() {
+ SPOOL_DIR="/var/spool/cron/crontabs" econf \
+ $(use_with inotify ) \
+ $(use_with pam ) \
+ --with-daemon_username=cron \
+ --with-daemon_groupname=cron \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+
+ docrondir
+ fowners root:cron /usr/bin/crontab
+ fperms 2750 /usr/bin/crontab
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-1.2-crontab" crontab
+ newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+ keepdir /etc/cron.d
+ newinitd "${FILESDIR}/${PN}-1.2-initd" cronie
+ newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+
+ dodoc NEWS AUTHORS README
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+}
diff --git a/sys-process/cronie/files/cronie-1.4.3-pamd b/sys-process/cronie/files/cronie-1.4.3-pamd
new file mode 100644
index 000000000000..4b4fd4cf1f05
--- /dev/null
+++ b/sys-process/cronie/files/cronie-1.4.3-pamd
@@ -0,0 +1,9 @@
+#
+# The PAM configuration file for the cron daemon
+#
+#
+# No PAM authentication called, auth modules not needed
+account required pam_access.so
+account include system-auth
+session required pam_loginuid.so
+session include system-auth