summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-03 19:37:22 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-03 19:37:22 +0000
commitbf6560ed84eac0c6847c87643555664e5552ae45 (patch)
treeb914201d7cc4b90f2688e1611059a5dc6759bdf0 /sys-process/htop
parentNeeds to block the old versions of app-misc/pip before that tool was moved to... (diff)
downloadgentoo-2-bf6560ed84eac0c6847c87643555664e5552ae45.tar.gz
gentoo-2-bf6560ed84eac0c6847c87643555664e5552ae45.tar.bz2
gentoo-2-bf6560ed84eac0c6847c87643555664e5552ae45.zip
sys-process/htop: Add compatibility patch for ncurses[tinfo]
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sys-process/htop')
-rw-r--r--sys-process/htop/ChangeLog8
-rw-r--r--sys-process/htop/files/htop-1.0.2-tinfo.patch50
-rw-r--r--sys-process/htop/htop-1.0.2-r1.ebuild64
-rw-r--r--sys-process/htop/metadata.xml18
4 files changed, 130 insertions, 10 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index 5f444bce02a8..51ab11686a4a 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/htop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.136 2013/01/01 19:33:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.137 2013/05/03 19:37:22 jlec Exp $
+
+*htop-1.0.2-r1 (03 May 2013)
+
+ 03 May 2013; Justin Lecher <jlec@gentoo.org> +htop-1.0.2-r1.ebuild,
+ +files/htop-1.0.2-tinfo.patch, metadata.xml:
+ Add compatibility patch for ncurses[tinfo]
01 Jan 2013; Raúl Porcel <armin76@gentoo.org> htop-1.0.2.ebuild:
sh stable wrt #447952
diff --git a/sys-process/htop/files/htop-1.0.2-tinfo.patch b/sys-process/htop/files/htop-1.0.2-tinfo.patch
new file mode 100644
index 000000000000..e7fb43d25a9e
--- /dev/null
+++ b/sys-process/htop/files/htop-1.0.2-tinfo.patch
@@ -0,0 +1,50 @@
+ Makefile.am | 2 ++
+ configure.ac | 20 ++++++++++++--------
+ 2 files changed, 14 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 05a72e7..7908937 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -36,6 +36,8 @@ SUFFIXES = .h
+ BUILT_SOURCES = $(myhtopheaders)
+ htop_SOURCES = $(myhtopheaders) $(myhtopsources) config.h
+
++htop_LDADD = $(NCURSES_LIBS)
++
+ profile:
+ $(MAKE) all CFLAGS="" AM_CPPFLAGS="-pg -O2"
+
+diff --git a/configure.ac b/configure.ac
+index ff6901b..6226d90 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -89,16 +89,20 @@ fi
+
+ AC_ARG_ENABLE(unicode, [AC_HELP_STRING([--enable-unicode], [enable Unicode support])], ,enable_unicode="yes")
+ if test "x$enable_unicode" = xyes; then
+- AC_CHECK_LIB([ncursesw], [refresh], [], [
+- missing_libraries="$missing_libraries libncursesw"
+- AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
++ PKG_CHECK_MODULES([NCURSES], [ncursesw],[
++ AC_CHECK_LIB([ncursesw], [refresh], [], [
++ missing_libraries="$missing_libraries libncursesw"
++ AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
++ ])
++ AC_CHECK_HEADERS([ncursesw/curses.h],[:],
++ [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
++ [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])
+ ])
+- AC_CHECK_HEADERS([ncursesw/curses.h],[:],
+- [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
+- [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])
+ else
+- AC_CHECK_LIB([ncurses], [refresh], [], [missing_libraries="$missing_libraries libncurses"])
+- AC_CHECK_HEADERS([curses.h],[:],[missing_headers="$missing_headers $ac_header"])
++ PKG_CHECK_MODULES([NCURSES], [ncurses],[
++ AC_CHECK_LIB([ncurses], [refresh], [], [missing_libraries="$missing_libraries libncurses"])
++ AC_CHECK_HEADERS([curses.h],[:],[missing_headers="$missing_headers $ac_header"])
++ ])
+ fi
+
+ if test ! -z "$missing_libraries"; then
diff --git a/sys-process/htop/htop-1.0.2-r1.ebuild b/sys-process/htop/htop-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..be5709594175
--- /dev/null
+++ b/sys-process/htop/htop-1.0.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-1.0.2-r1.ebuild,v 1.1 2013/05/03 19:37:22 jlec Exp $
+
+EAPI=4
+
+# autotools for auto* dependencies
+inherit autotools eutils
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="kernel_FreeBSD kernel_linux openvz unicode vserver"
+
+RDEPEND="sys-libs/ncurses[unicode?]"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README )
+
+pkg_setup() {
+ if use kernel_FreeBSD && ! [[ -f ${ROOT}/compat/linux/proc/stat && -f ${ROOT}/compat/linux/proc/meminfo ]]; then
+ eerror
+ eerror "htop requires linprocfs mounted at /compat/linux/proc to build and function."
+ eerror "To mount it, type:"
+ [ -d /compat/linux/proc ] || eerror "mkdir -p /compat/linux/proc"
+ eerror "mount -t linprocfs none /compat/linux/proc"
+ eerror "Alternatively, place this information into /etc/fstab"
+ eerror
+ die "htop needs /compat/linux/proc mounted"
+ fi
+
+ if ! has_version sys-process/lsof; then
+ ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+}
+
+src_prepare() {
+ rm missing || die
+ sed -i -e '1c\#!'"${EPREFIX}"'/usr/bin/python' \
+ scripts/MakeHeader.py || die
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+src_configure() {
+ [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
+
+ myconf=''
+
+ use kernel_FreeBSD && myconf="${myconf} --with-proc=/compat/linux/proc"
+
+ econf \
+ $(use_enable openvz) \
+ $(use_enable kernel_linux cgroup) \
+ $(use_enable vserver) \
+ $(use_enable unicode) \
+ --enable-taskstats \
+ ${myconf}
+}
diff --git a/sys-process/htop/metadata.xml b/sys-process/htop/metadata.xml
index 4ed6d14fbf64..cb2b58bcfb07 100644
--- a/sys-process/htop/metadata.xml
+++ b/sys-process/htop/metadata.xml
@@ -1,15 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>idl0r@gentoo.org</email>
- <name>Christian Ruppert</name>
- </maintainer>
- <use>
- <flag name="openvz">Enable openvz support</flag>
- <flag name="vserver">Enable vserver support</flag>
- </use>
- <longdescription>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <use>
+ <flag name="openvz">Enable openvz support</flag>
+ <flag name="vserver">Enable vserver support</flag>
+ </use>
+ <longdescription>
htop is an interactive process viewer for Linux. It aims to be a 'better top':
you can scroll the process list vertically and horizontally, and select a
process to be killed with the arrow keys instead of by typing its process id.