summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-11 00:52:13 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-11 00:52:13 +0000
commit73a73df3b013adac68657a1ba974f80cd9068d3b (patch)
tree14c627c36a41d9d2c28929a79cfd4a04584f6a1e /sys-process/lsof
parentold (diff)
downloadgentoo-2-73a73df3b013adac68657a1ba974f80cd9068d3b.tar.gz
gentoo-2-73a73df3b013adac68657a1ba974f80cd9068d3b.tar.bz2
gentoo-2-73a73df3b013adac68657a1ba974f80cd9068d3b.zip
Version bump #95676 by Andrej Kacian.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-process/lsof')
-rw-r--r--sys-process/lsof/ChangeLog9
-rw-r--r--sys-process/lsof/files/digest-lsof-4.751
-rw-r--r--sys-process/lsof/lsof-4.75.ebuild60
3 files changed, 68 insertions, 2 deletions
diff --git a/sys-process/lsof/ChangeLog b/sys-process/lsof/ChangeLog
index df0fc8fcd819..1f4124af7cfb 100644
--- a/sys-process/lsof/ChangeLog
+++ b/sys-process/lsof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/lsof
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.5 2005/04/09 13:22:43 corsair Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/ChangeLog,v 1.6 2005/06/11 00:52:13 vapier Exp $
+
+*lsof-4.75 (11 Jun 2005)
+
+ 11 Jun 2005; Mike Frysinger <vapier@gentoo.org> +lsof-4.75.ebuild:
+ Version bump #95676 by Andrej Kacian.
09 Apr 2005; Markus Rothe <corsair@gentoo.org> lsof-4.73.ebuild:
Stable on ppc64
diff --git a/sys-process/lsof/files/digest-lsof-4.75 b/sys-process/lsof/files/digest-lsof-4.75
new file mode 100644
index 000000000000..dd6a0f14aa73
--- /dev/null
+++ b/sys-process/lsof/files/digest-lsof-4.75
@@ -0,0 +1 @@
+MD5 ec4e62f1e70aaac52b58bdacf0cc9c05 lsof_4.75.tar.gz 978144
diff --git a/sys-process/lsof/lsof-4.75.ebuild b/sys-process/lsof/lsof-4.75.ebuild
new file mode 100644
index 000000000000..5ef5b8776bf7
--- /dev/null
+++ b/sys-process/lsof/lsof-4.75.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.75.ebuild,v 1.1 2005/06/11 00:52:13 vapier Exp $
+
+inherit eutils flag-o-matic fixheadtails toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="Lists open files for running Unix processes"
+HOMEPAGE="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/README"
+SRC_URI="ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.gz
+ ftp://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static"
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}/${MY_P}_src
+
+src_unpack() {
+ unpack ${A}
+ cd ${MY_P}
+ tar xf ${MY_P}_src.tar || die
+
+ # now patch the scripts to automate everything
+ cd "${S}"
+ ht_fix_file Configure Customize
+ touch .neverInv
+ epatch "${FILESDIR}"/4.73-answer-config.patch
+}
+
+src_compile() {
+ # #26576 lsof 4.71 compile with -fstack-protector
+ use alpha && filter-flags -fstack-protector
+ use static && append-ldflags -static
+
+ ./Configure linux || die "configure failed"
+
+ # Make sure we use proper toolchain
+ sed -i \
+ -e "/^CC=/s:cc:$(tc-getCC):" \
+ -e "/^AR=/s:ar:$(tc-getAR):" \
+ -e "/^RANLIB=/s:ranlib:$(tc-getRANLIB):" \
+ Makefile lib/Makefile
+
+ emake all || die "emake failed"
+}
+
+src_install() {
+ dosbin lsof || die "dosbin"
+ dolib lib/liblsof.a || die "dolib"
+
+ insinto /usr/share/lsof/scripts
+ doins scripts/*
+
+ doman lsof.8
+ dodoc 00*
+}