summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-25 15:48:10 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-25 15:48:10 +0000
commit2e93c368602184e7ecfe2fa9519674a61d3139f7 (patch)
tree9bf58e87f3cc49bc6dbd6ec43a43fd9829d1791c /sys-process/psinfo
parentFix deprecation warnings. (diff)
downloadgentoo-2-2e93c368602184e7ecfe2fa9519674a61d3139f7.tar.gz
gentoo-2-2e93c368602184e7ecfe2fa9519674a61d3139f7.tar.bz2
gentoo-2-2e93c368602184e7ecfe2fa9519674a61d3139f7.zip
New addition, thanks Jiri Tyr for first ebuild, #242208
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/psinfo')
-rw-r--r--sys-process/psinfo/ChangeLog10
-rw-r--r--sys-process/psinfo/files/psinfo-0.12-asneeded.patch36
-rw-r--r--sys-process/psinfo/metadata.xml8
-rw-r--r--sys-process/psinfo/psinfo-0.12.ebuild32
4 files changed, 86 insertions, 0 deletions
diff --git a/sys-process/psinfo/ChangeLog b/sys-process/psinfo/ChangeLog
new file mode 100644
index 000000000000..255dc0832d62
--- /dev/null
+++ b/sys-process/psinfo/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-process/psinfo
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psinfo/ChangeLog,v 1.1 2011/04/25 15:48:10 jlec Exp $
+
+*psinfo-0.12 (25 Apr 2011)
+
+ 25 Apr 2011; Justin Lecher <jlec@gentoo.org> +psinfo-0.12.ebuild,
+ +files/psinfo-0.12-asneeded.patch, +metadata.xml:
+ New addition, thanks Jiri Tyr for first ebuild, #242208
+
diff --git a/sys-process/psinfo/files/psinfo-0.12-asneeded.patch b/sys-process/psinfo/files/psinfo-0.12-asneeded.patch
new file mode 100644
index 000000000000..97cfd7f817fb
--- /dev/null
+++ b/sys-process/psinfo/files/psinfo-0.12-asneeded.patch
@@ -0,0 +1,36 @@
+ Makefile | 17 ++++++++++-------
+ 1 files changed, 10 insertions(+), 7 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 2964607..fb4ece8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,10 +1,10 @@
+-CC=gcc
+-CFLAGS=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual -Wswitch -Wshadow -Wcast-align -Wno-unused-parameter -Wchar-subscripts -Winline -Wnested-externs -Wredundant-decls
++CC ?=gcc
++CFLAGS ?=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual -Wswitch -Wshadow -Wcast-align -Wno-unused-parameter -Wchar-subscripts -Winline -Wnested-externs -Wredundant-decls
+ INSTALL=install
+-LDFLAGS=
++LDFLAGS ?=
+ SOURCES=psinfo.c
+ EXECUTABLE=psinfo
+-TARGETDIR=/usr/local/bin
++TARGETDIR=/usr/bin
+
+ all: $(EXECUTABLE)
+
+@@ -12,7 +12,10 @@ clean:
+ rm -f $(EXECUTABLE)
+
+ install: $(EXECUTABLE)
+- $(INSTALL) -m 755 psinfo $(TARGETDIR)
++ $(INSTALL) -D -m 755 psinfo $(DESTDIR)/$(TARGETDIR)/$(EXECUTABLE)
+
+-$(EXECUTABLE): $(SOURCES)
+- $(CC) $(CFLAGS) -o $@ $(SOURCES) $(LDFLAGS)
++$(EXECUTABLE): psinfo.o
++ $(CC) $(LDFLAGS) -o $@ psinfo.o
++
++psinfo.o: psinfo.c
++ $(CC) $(CFLAGS) -c psinfo.c
diff --git a/sys-process/psinfo/metadata.xml b/sys-process/psinfo/metadata.xml
new file mode 100644
index 000000000000..9aa75ad4091e
--- /dev/null
+++ b/sys-process/psinfo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-process/psinfo/psinfo-0.12.ebuild b/sys-process/psinfo/psinfo-0.12.ebuild
new file mode 100644
index 000000000000..a0278348801a
--- /dev/null
+++ b/sys-process/psinfo/psinfo-0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psinfo/psinfo-0.12.ebuild,v 1.1 2011/04/25 15:48:10 jlec Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Process information and statistics using the kernel /proc interface"
+HOMEPAGE="http://www.ward.nu/computer/psinfo/"
+SRC_URI="http://www.ward.nu/computer/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE=""
+
+src_prepare () {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ tc-export CC
+}
+
+#src_compile() {
+# emake \
+# CFLAGS="${CFLAGS}" \
+# CC=$(tc-getCC)
+#}
+
+#src_install() {
+# dobin ${PN}
+# dodoc README
+#}