summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-03 17:20:51 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-03 17:20:51 +0000
commitfd59101c3de0c5d160c5daefcfb8677919c5818b (patch)
treef0e9f088fb114d5e480a4876b7dabb21eb3030eb /sys-process/supervise-scripts/supervise-scripts-3.4.ebuild
parentNew snapshot version (diff)
downloadgentoo-2-fd59101c3de0c5d160c5daefcfb8677919c5818b.tar.gz
gentoo-2-fd59101c3de0c5d160c5daefcfb8677919c5818b.tar.bz2
gentoo-2-fd59101c3de0c5d160c5daefcfb8677919c5818b.zip
Moved from sys-apps/supervise-scripts to sys-process/supervise-scripts.
Diffstat (limited to 'sys-process/supervise-scripts/supervise-scripts-3.4.ebuild')
-rw-r--r--sys-process/supervise-scripts/supervise-scripts-3.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-process/supervise-scripts/supervise-scripts-3.4.ebuild b/sys-process/supervise-scripts/supervise-scripts-3.4.ebuild
new file mode 100644
index 000000000000..e278b371fc87
--- /dev/null
+++ b/sys-process/supervise-scripts/supervise-scripts-3.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/supervise-scripts/supervise-scripts-3.4.ebuild,v 1.1 2005/03/03 17:20:51 ciaranm Exp $
+
+DESCRIPTION="Starting and stopping daemontools managed services"
+HOMEPAGE="http://untroubled.org/supervise-scripts/"
+SRC_URI="http://untroubled.org/supervise-scripts/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/daemontools-0.70"
+
+src_compile() {
+ echo '/usr/bin' > conf-bin
+ emake || die
+}
+
+src_install() {
+ dobin \
+ svc-add svc-isdown svc-isup svc-remove \
+ svc-start svc-status svc-stop \
+ svc-waitdown svc-waitup svscan-add-to-inittab \
+ svscan-start svscan-stopall || die
+ dodoc ANNOUNCEMENT ChangeLog NEWS README TODO VERSION
+ doman *.[0-9]
+}