summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Marichez <falco@gentoo.org>2007-04-08 21:50:44 +0000
committerRaphaël Marichez <falco@gentoo.org>2007-04-08 21:50:44 +0000
commitc2555b6e60a6327e6e9b6c9abb17ec5411acd726 (patch)
treefb827f1cf4b45acd880fe6d3d5de06753c40d2e1 /sys-process/vixie-cron
parentMarking amd64 stable (diff)
downloadgentoo-2-c2555b6e60a6327e6e9b6c9abb17ec5411acd726.tar.gz
gentoo-2-c2555b6e60a6327e6e9b6c9abb17ec5411acd726.tar.bz2
gentoo-2-c2555b6e60a6327e6e9b6c9abb17ec5411acd726.zip
Revision bump, fixes bug 164466
(Portage version: 2.1.2.2)
Diffstat (limited to 'sys-process/vixie-cron')
-rw-r--r--sys-process/vixie-cron/ChangeLog8
-rw-r--r--sys-process/vixie-cron/files/digest-vixie-cron-4.1-r106
-rw-r--r--sys-process/vixie-cron/files/vixie-cron-4.1-hardlink.patch11
-rw-r--r--sys-process/vixie-cron/vixie-cron-4.1-r10.ebuild124
4 files changed, 148 insertions, 1 deletions
diff --git a/sys-process/vixie-cron/ChangeLog b/sys-process/vixie-cron/ChangeLog
index 64baf5767d9b..ae360d453a1f 100644
--- a/sys-process/vixie-cron/ChangeLog
+++ b/sys-process/vixie-cron/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/vixie-cron
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/vixie-cron/ChangeLog,v 1.43 2007/03/26 07:54:43 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/vixie-cron/ChangeLog,v 1.44 2007/04/08 21:50:44 falco Exp $
+
+*vixie-cron-4.1-r10 (08 Apr 2007)
+
+ 08 Apr 2007; Raphael Marichez <falco@gentoo.org>
+ +files/vixie-cron-4.1-hardlink.patch, +vixie-cron-4.1-r10.ebuild:
+ Revision bump, fixes bug 164466
26 Mar 2007; Alec Warner <antarus@gentoo.org> vixie-cron-4.1-r9.ebuild:
Remove dependency on portage: ref bug 162516
diff --git a/sys-process/vixie-cron/files/digest-vixie-cron-4.1-r10 b/sys-process/vixie-cron/files/digest-vixie-cron-4.1-r10
new file mode 100644
index 000000000000..4b0d91076cd4
--- /dev/null
+++ b/sys-process/vixie-cron/files/digest-vixie-cron-4.1-r10
@@ -0,0 +1,6 @@
+MD5 c674b03c6e76798b1c74f6070df167cc vixie-cron-4.1-gentoo-r4.patch.bz2 4204
+RMD160 1d439c0bb473e8307a5c33e2449efdd9ca6fc4f5 vixie-cron-4.1-gentoo-r4.patch.bz2 4204
+SHA256 8de14b11da567f7859df3dcf71802f32ac1b3650ae07c6cb6dbc259e1f6da7fc vixie-cron-4.1-gentoo-r4.patch.bz2 4204
+MD5 09dc04f9879684d27c64c910174a9536 vixie-cron-4.1.tar.bz2 54246
+RMD160 a7f6aaa6deb9924d56da8dca3e2e323e0786f97e vixie-cron-4.1.tar.bz2 54246
+SHA256 fd25119b301e0e8306ec27ee912298740c5c8ae879bac02381429cf355d1122d vixie-cron-4.1.tar.bz2 54246
diff --git a/sys-process/vixie-cron/files/vixie-cron-4.1-hardlink.patch b/sys-process/vixie-cron/files/vixie-cron-4.1-hardlink.patch
new file mode 100644
index 000000000000..cabdef02e67b
--- /dev/null
+++ b/sys-process/vixie-cron/files/vixie-cron-4.1-hardlink.patch
@@ -0,0 +1,11 @@
+--- database.c.orig 2007-04-08 21:06:16.913019387 +0200
++++ database.c 2007-04-08 21:06:29.489736093 +0200
+@@ -251,7 +251,7 @@
+ log_it(fname, getpid(), "WRONG FILE OWNER", tabname);
+ goto next_crontab;
+ }
+- if (statbuf->st_nlink != 1) {
++ if (statbuf->st_nlink != 1 && pw != NULL) {
+ log_it(fname, getpid(), "BAD LINK COUNT", tabname);
+ goto next_crontab;
+ }
diff --git a/sys-process/vixie-cron/vixie-cron-4.1-r10.ebuild b/sys-process/vixie-cron/vixie-cron-4.1-r10.ebuild
new file mode 100644
index 000000000000..2ce0e0070d94
--- /dev/null
+++ b/sys-process/vixie-cron/vixie-cron-4.1-r10.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/vixie-cron/vixie-cron-4.1-r10.ebuild,v 1.1 2007/04/08 21:50:44 falco Exp $
+
+inherit cron toolchain-funcs pam
+
+# no useful homepage, bug #65898
+HOMEPAGE="ftp://ftp.isc.org/isc/cron/"
+DESCRIPTION="Paul Vixie's cron daemon, a fully featured crond implementation"
+
+SELINUX_PATCH="${P}-selinux.diff"
+GENTOO_PATCH_REV="r4"
+
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/${P}-gentoo-${GENTOO_PATCH_REV}.patch.bz2"
+
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="selinux pam debug"
+
+DEPEND="selinux? ( sys-libs/libselinux )
+ pam? ( virtual/pam )"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ pam? ( virtual/pam )"
+
+#vixie-cron supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+pkg_setup() {
+ enewgroup crontab
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${WORKDIR}/${P}-gentoo-${GENTOO_PATCH_REV}.patch
+ epatch ${FILESDIR}/crontab.5.diff
+ epatch ${FILESDIR}/${P}-commandline.patch
+ epatch ${FILESDIR}/${P}-basename.diff
+ epatch ${FILESDIR}/${P}-setuid_check.patch
+ epatch ${FILESDIR}/${P}-hardlink.patch
+
+ use pam && epatch ${FILESDIR}/${P}-pam.patch
+ use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}
+}
+
+src_compile() {
+ # we need to tinker with ldflags since we're installing as setuid. see
+ # "[gentoo-core] Heads up changes in suid handing with portage >=51_pre21"
+ # for details. Note that we do the sed fixes here rather than in unpack so
+ # that our changes to LDFLAGS are picked up.
+
+ append-ldflags $(bindnow-flags)
+ use debug && append-flags -DDEBUGGING
+
+ sed -i -e "s:gcc \(-Wall.*\):$(tc-getCC) \1 ${CFLAGS}:" \
+ -e "s:^\(LDFLAGS[ \t]\+=\).*:\1 ${LDFLAGS}:" Makefile \
+ || die "sed Makefile failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ docrondir -m 1730 -o root -g crontab
+ docron
+ docrontab -m 2755 -o root -g crontab
+
+ # /etc stuff
+ insinto /etc
+ newins ${FILESDIR}/crontab-3.0.1-r4 crontab
+ newins ${FILESDIR}/${P}-cron.deny cron.deny
+
+ keepdir /etc/cron.d
+ newpamd ${FILESDIR}/pamd.compatible cron
+ newinitd ${FILESDIR}/vixie-cron.rc6 vixie-cron
+
+ # doc stuff
+ doman crontab.1 crontab.5 cron.8
+ dodoc ${FILESDIR}/crontab
+ dodoc CHANGES CONVERSION FEATURES MAIL README THANKS
+}
+
+pkg_postinst() {
+ if [[ -f ${ROOT}/etc/init.d/vcron ]]
+ then
+ ewarn "Please run:"
+ ewarn "rc-update del vcron"
+ ewarn "rc-update add vixie-cron default"
+ fi
+
+ # bug 71326
+ if [[ -u ${ROOT}/etc/pam.d/cron ]] ; then
+ echo
+ ewarn "Warning: previous ebuilds didn't reset permissions prior"
+ ewarn "to installing crontab, resulting in /etc/pam.d/cron being"
+ ewarn "installed with the SUID and executable bits set."
+ ewarn
+ ewarn "Run the following as root to set the proper permissions:"
+ ewarn " chmod 0644 /etc/pam.d/cron"
+ echo
+ fi
+
+ # bug 164466
+ if has_version '<sys-process/vixie-cron-4.1-r10' ; then
+ echo
+ ewarn "Previous ebuilds didn't correctly set permissions on"
+ ewarn "the crontabs spool directory. Proper permissions are"
+ ewarn "now being set on ${ROOT}var/spool/cron/crontabs/"
+ ewarn "Look at this directory if you have a specific configuration"
+ ewarn "that needs special ownerships or permissions."
+ echo
+ chmod 1730 "${ROOT}/var/spool/cron/crontabs" || die "chmod failed"
+ chgrp -R crontab "${ROOT}/var/spool/cron/crontabs" || die "chgrp failed"
+ cd "${ROOT}/var/spool/cron/crontabs/"
+ for cronfile in * ; do
+ [[ $cronfile == ".keep" ]] || chown "$cronfile:crontab" "$cronfile" \
+ || ewarn "chown failed on $cronfile, you probably have an orphan file."
+ done
+ fi
+
+ cron_pkg_postinst
+}