summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-02 03:59:20 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-02 03:59:20 +0000
commitef794bdccb27a47fe47efcfbfea31f0adb0807b3 (patch)
tree682669347df5523d79586a72235ba4bae8d7a28f /sys-process
parentadding misc maintainer note to ebuild, super bad form but otherwise it will b... (diff)
downloadgentoo-2-ef794bdccb27a47fe47efcfbfea31f0adb0807b3.tar.gz
gentoo-2-ef794bdccb27a47fe47efcfbfea31f0adb0807b3.tar.bz2
gentoo-2-ef794bdccb27a47fe47efcfbfea31f0adb0807b3.zip
bump; rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/glances/ChangeLog8
-rw-r--r--sys-process/glances/glances-2.1.2.ebuild (renamed from sys-process/glances/glances-2.1.1.ebuild)2
-rw-r--r--sys-process/glances/glances-2.1.ebuild65
3 files changed, 8 insertions, 67 deletions
diff --git a/sys-process/glances/ChangeLog b/sys-process/glances/ChangeLog
index 76d66ca8ff39..c3d7cf9c73db 100644
--- a/sys-process/glances/ChangeLog
+++ b/sys-process/glances/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/glances
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/ChangeLog,v 1.21 2014/10/10 15:23:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/ChangeLog,v 1.22 2014/11/02 03:59:20 idella4 Exp $
+
+*glances-2.1.2 (02 Nov 2014)
+
+ 02 Nov 2014; Ian Delaney <idella4@gentoo.org> +glances-2.1.2.ebuild,
+ -glances-2.1.1.ebuild, -glances-2.1.ebuild:
+ bump; rm old
*glances-2.1.1 (10 Oct 2014)
diff --git a/sys-process/glances/glances-2.1.1.ebuild b/sys-process/glances/glances-2.1.2.ebuild
index 8573250d766f..3deb282945e2 100644
--- a/sys-process/glances/glances-2.1.1.ebuild
+++ b/sys-process/glances/glances-2.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/glances-2.1.1.ebuild,v 1.1 2014/10/10 15:23:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/glances-2.1.2.ebuild,v 1.1 2014/11/02 03:59:20 idella4 Exp $
EAPI=5
diff --git a/sys-process/glances/glances-2.1.ebuild b/sys-process/glances/glances-2.1.ebuild
deleted file mode 100644
index ad20a77c6a75..000000000000
--- a/sys-process/glances/glances-2.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/glances-2.1.ebuild,v 1.1 2014/09/24 08:26:07 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-PYTHON_REQ_USE="ncurses"
-
-inherit distutils-r1 linux-info
-
-MYPN=Glances
-MYP=${MYPN}-${PV}
-
-DESCRIPTION="CLI curses based monitoring tool"
-HOMEPAGE="https://github.com/nicolargo/glances"
-SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="chart doc hddtemp snmp web"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-# There is another optional extra batinfo, absent from portage
-RDEPEND="${DEPEND}
- >=dev-python/psutil-2.0.0[${PYTHON_USEDEP}]
- hddtemp? ( app-admin/hddtemp )
- snmp? ( dev-python/pysnmp[${PYTHON_USEDEP}] )
- web? ( dev-python/bottle[${PYTHON_USEDEP}] )
- chart? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
-
-CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS"
-
-S="${WORKDIR}/${MYP}"
-
-pkg_setup() {
- linux-info_pkg_setup
-}
-
-python_prepare_all() {
- sed -e "s:share/doc/glances:share/doc/${PF}:g" \
- -e "s/'COPYING',//" \
- -e "s:/etc:${EPREFIX}/etc:" \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use doc; then
- mkdir "${D}"usr/share/doc/${P}/html || die
- mv "${D}"usr/share/doc/${P}/{glances-doc.html,images/} "${D}"usr/share/doc/${P}/html/ || die
- else
- rm -rf "${D}"usr/share/doc/${P}/{glances-doc.html,images/} || die
- fi
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "${PN} can gain additional functionality with following packages:"
- elog " dev-python/jinja - export statistics to HTML"
- elog " app-admin/hddtemp - monitor hard drive temperatures"
- fi
-}