summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-09 17:45:28 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-09 17:45:28 +0000
commit0899e2c2c13ce7425f7956763cf6687f0b9377d1 (patch)
treeb0e18021e5f2e98547b3b8a662f62c007447087c /virtual/ruby-threads
parentAdd a version for ruby20. (diff)
downloadgentoo-2-0899e2c2c13ce7425f7956763cf6687f0b9377d1.tar.gz
gentoo-2-0899e2c2c13ce7425f7956763cf6687f0b9377d1.tar.bz2
gentoo-2-0899e2c2c13ce7425f7956763cf6687f0b9377d1.zip
Add version for ruby20.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'virtual/ruby-threads')
-rw-r--r--virtual/ruby-threads/ChangeLog9
-rw-r--r--virtual/ruby-threads/ruby-threads-4.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/virtual/ruby-threads/ChangeLog b/virtual/ruby-threads/ChangeLog
index 0f61070f5424..1f856ae00eab 100644
--- a/virtual/ruby-threads/ChangeLog
+++ b/virtual/ruby-threads/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for virtual/ruby-threads
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-threads/ChangeLog,v 1.19 2012/10/28 19:30:44 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-threads/ChangeLog,v 1.20 2013/07/09 17:45:28 graaff Exp $
+
+*ruby-threads-4 (09 Jul 2013)
+
+ 09 Jul 2013; Hans de Graaff <graaff@gentoo.org> +ruby-threads-4.ebuild:
+ Add version for ruby20.
28 Oct 2012; Raúl Porcel <armin76@gentoo.org> ruby-threads-0.ebuild,
ruby-threads-1.ebuild:
diff --git a/virtual/ruby-threads/ruby-threads-4.ebuild b/virtual/ruby-threads/ruby-threads-4.ebuild
new file mode 100644
index 000000000000..65088cb1fab0
--- /dev/null
+++ b/virtual/ruby-threads/ruby-threads-4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-threads/ruby-threads-4.ebuild,v 1.1 2013/07/09 17:45:28 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby20"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for a ruby interpreter with threading enabled."
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="${USE_RUBY}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-macos"
+IUSE=""
+
+RDEPEND="dev-lang/ruby:2.0"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
+
+# DEVELOPERS' NOTE!
+#
+# This virtual has multiple version that ties one-by-one with the Ruby
+# implementation they provide the value for; this is to simplify
+# keywording practise that has been shown to be very messy for other
+# virtuals.
+#
+# Make sure that you DO NOT change the version of the virtual's
+# ebuilds unless you're adding a new implementation; instead simply
+# revision-bump it.
+#
+# A reference to ~${PV} for each of the version has to be added to
+# profiles/base/package.use.force to make sure that they are always
+# used with their own implementation.
+#
+# ruby_add_[br]depend will take care of depending on multiple versions
+# without any frown.