summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-12-31 11:36:30 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-12-31 11:36:30 +0000
commitc8650f35508e4db6b5bdc39d6b15d6693a590e04 (patch)
tree296ea5fb0fc0abadd1efc4ea6397159475ad3da9 /www-apache/mod_gnutls/mod_gnutls-0.4.2.1.ebuild
parentVersion bump (diff)
downloadgentoo-2-c8650f35508e4db6b5bdc39d6b15d6693a590e04.tar.gz
gentoo-2-c8650f35508e4db6b5bdc39d6b15d6693a590e04.tar.bz2
gentoo-2-c8650f35508e4db6b5bdc39d6b15d6693a590e04.zip
version bump; #203834
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'www-apache/mod_gnutls/mod_gnutls-0.4.2.1.ebuild')
-rw-r--r--www-apache/mod_gnutls/mod_gnutls-0.4.2.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/www-apache/mod_gnutls/mod_gnutls-0.4.2.1.ebuild b/www-apache/mod_gnutls/mod_gnutls-0.4.2.1.ebuild
new file mode 100644
index 000000000000..3beab48db01c
--- /dev/null
+++ b/www-apache/mod_gnutls/mod_gnutls-0.4.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_gnutls/mod_gnutls-0.4.2.1.ebuild,v 1.1 2007/12/31 11:36:29 hollow Exp $
+
+inherit apache-module ssl-cert
+
+KEYWORDS="~amd64 ~sparc ~x86"
+
+DESCRIPTION="mod_gnutls uses GnuTLS to provide SSL v3, TLS 1.0 and TLS 1.1 encryption for Apache2, similarly to mod_ssl."
+HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_gnutls/"
+SRC_URI="http://www.outoforder.cc/downloads/${PN}/${P}.tar.bz2"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=net-libs/gnutls-2.1.8"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="47_${PN}"
+APACHE2_MOD_DEFINE="GNUTLS"
+
+DOCFILES="LICENSE NOTICE README"
+
+need_apache2
+
+src_compile() {
+ econf --with-apxs=${APXS2} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ mv -f "src/.libs/libmod_gnutls.so" "src/.libs/${PN}.so"
+
+ insinto "${APACHE2_CONFDIR}"
+ doins data/rsafile data/dhfile
+
+ keepdir "${APACHE2_CONFDIR}/ssl"
+ keepdir /var/cache/${PN}
+
+ apache-module_src_install
+}