summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-31 19:34:43 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-31 19:34:43 +0000
commitb65dd2f2a078f7f0cd5c63c572a87d2ada93eea9 (patch)
treea49eee11d719e8d28780817ae7f18a716c40fca5 /www-apache/mod_python
parentupdate metadata; cleanup (diff)
downloadgentoo-2-b65dd2f2a078f7f0cd5c63c572a87d2ada93eea9.tar.gz
gentoo-2-b65dd2f2a078f7f0cd5c63c572a87d2ada93eea9.tar.bz2
gentoo-2-b65dd2f2a078f7f0cd5c63c572a87d2ada93eea9.zip
fix depend.apache usage wrt #208033; cleanup
(Portage version: 2.1.4)
Diffstat (limited to 'www-apache/mod_python')
-rw-r--r--www-apache/mod_python/ChangeLog6
-rw-r--r--www-apache/mod_python/files/16_mod_python.conf21
-rw-r--r--www-apache/mod_python/metadata.xml1
-rw-r--r--www-apache/mod_python/mod_python-3.3.1.ebuild4
4 files changed, 16 insertions, 16 deletions
diff --git a/www-apache/mod_python/ChangeLog b/www-apache/mod_python/ChangeLog
index 17c3bd87284d..7e31fc657894 100644
--- a/www-apache/mod_python/ChangeLog
+++ b/www-apache/mod_python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/mod_python
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_python/ChangeLog,v 1.10 2008/01/11 20:24:24 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_python/ChangeLog,v 1.11 2008/01/31 19:34:43 hollow Exp $
+
+ 31 Jan 2008; Benedikt Böhm <hollow@gentoo.org> files/16_mod_python.conf,
+ metadata.xml, mod_python-3.3.1.ebuild:
+ fix depend.apache usage wrt #208033; cleanup
11 Jan 2008; Doug Klima <cardoe@gentoo.org> mod_python-3.3.1.ebuild:
fix ${ROOT} issue
diff --git a/www-apache/mod_python/files/16_mod_python.conf b/www-apache/mod_python/files/16_mod_python.conf
index ae4657e89776..9fbe3624a003 100644
--- a/www-apache/mod_python/files/16_mod_python.conf
+++ b/www-apache/mod_python/files/16_mod_python.conf
@@ -1,36 +1,33 @@
<IfDefine PYTHON>
LoadModule python_module modules/mod_python.so
-#
# Mod_python is a module that embeds the Python language interpreter
# within the server, allowing Apache handlers to be written in Python.
-#
# This will cause files beneath /home/httpd/htdocs with the extension .spam
# to be handled by the Python script /home/httpd/htdocs/eggs.py
#
#<Directory /home/httpd/htdocs>
-# <IfModule mod_mime.c>
-# AddHandler python-program .spam
-# </IfModule>
-# PythonHandler eggs
+# AddHandler python-program .spam
+# PythonHandler eggs
#</Directory>
# This will cause all requests to the /python heirachy of your
# webserver to be handled by the python script /path/to/myhandler.py
#
#<Location /python>
-# SetHandler python-program
-# PythonPath "sys.path + ['/path/to']"
-# PythonHandler myhandler
+# SetHandler python-program
+# PythonPath "sys.path + ['/path/to']"
+# PythonHandler myhandler
#</Location>
# This will cause all requests to the /python heirachy of your
# webserver to be handled by mod_python's Publisher handler
#
#<Location /python>
-# SetHandler python-program
-# PythonHandler mod_python.publisher
+# SetHandler python-program
+# PythonHandler mod_python.publisher
#</Location>
-
</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_python/metadata.xml b/www-apache/mod_python/metadata.xml
index 64623d02849f..99ca41f6b9ce 100644
--- a/www-apache/mod_python/metadata.xml
+++ b/www-apache/mod_python/metadata.xml
@@ -1,6 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-
<pkgmetadata>
<herd>apache</herd>
<herd>python</herd>
diff --git a/www-apache/mod_python/mod_python-3.3.1.ebuild b/www-apache/mod_python/mod_python-3.3.1.ebuild
index 13c6f0f14cfc..76b8e67d4fd7 100644
--- a/www-apache/mod_python/mod_python-3.3.1.ebuild
+++ b/www-apache/mod_python/mod_python-3.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_python/mod_python-3.3.1.ebuild,v 1.8 2008/01/11 20:24:24 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_python/mod_python-3.3.1.ebuild,v 1.9 2008/01/31 19:34:43 hollow Exp $
inherit python apache-module multilib
@@ -32,7 +32,7 @@ src_unpack() {
}
src_compile() {
- econf --with-apxs=${APXS2} || die "econf failed"
+ econf --with-apxs=${APXS} || die "econf failed"
sed -i -e 's/ -Wl,--hash-style//' src/Makefile
emake OPT="`apxs2 -q CFLAGS` -fPIC" || die "econf failed"
}