summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-03-22 16:54:37 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-03-22 16:54:37 +0000
commit0f6e2d4f722b33f7d0c003918768f184cd3e086e (patch)
tree0e54233885736d9267c8247ea8dd95749c6e2b94 /www-apache
parentamd64 stable, bug #204850 (diff)
downloadgentoo-2-0f6e2d4f722b33f7d0c003918768f184cd3e086e.tar.gz
gentoo-2-0f6e2d4f722b33f7d0c003918768f184cd3e086e.tar.bz2
gentoo-2-0f6e2d4f722b33f7d0c003918768f184cd3e086e.zip
version bumps wrt #209632
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_security/ChangeLog10
-rw-r--r--www-apache/mod_security/files/99_mod_security-2.1.1.conf8
-rw-r--r--www-apache/mod_security/mod_security-2.1.6.ebuild50
-rw-r--r--www-apache/mod_security/mod_security-2.5.1.ebuild62
4 files changed, 121 insertions, 9 deletions
diff --git a/www-apache/mod_security/ChangeLog b/www-apache/mod_security/ChangeLog
index 61e45e83f6b4..13c42e1ebb8a 100644
--- a/www-apache/mod_security/ChangeLog
+++ b/www-apache/mod_security/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apache/mod_security
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.11 2008/01/31 19:28:43 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.12 2008/03/22 16:54:37 hollow Exp $
+
+*mod_security-2.5.1 (22 Mar 2008)
+*mod_security-2.1.6 (22 Mar 2008)
+
+ 22 Mar 2008; Benedikt Böhm <hollow@gentoo.org>
+ -files/99_mod_security-2.1.1.conf, +mod_security-2.1.6.ebuild,
+ +mod_security-2.5.1.ebuild:
+ version bumps wrt #209632
31 Jan 2008; Benedikt Böhm <hollow@gentoo.org>
files/99_mod_security-2.1.1.conf, files/2.1.2/99_mod_security.conf:
diff --git a/www-apache/mod_security/files/99_mod_security-2.1.1.conf b/www-apache/mod_security/files/99_mod_security-2.1.1.conf
deleted file mode 100644
index 819e52fd2538..000000000000
--- a/www-apache/mod_security/files/99_mod_security-2.1.1.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-<IfDefine SECURITY>
-LoadModule security2_module modules/mod_security2.so
-
-# use Core Rule Set by default:
-Include /etc/apache2/modules.d/mod_security/*.conf
-</IfDefine>
-
-# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_security/mod_security-2.1.6.ebuild b/www-apache/mod_security/mod_security-2.1.6.ebuild
new file mode 100644
index 000000000000..d1b4300e2dd2
--- /dev/null
+++ b/www-apache/mod_security/mod_security-2.1.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.1.6.ebuild,v 1.1 2008/03/22 16:54:37 hollow Exp $
+
+inherit apache-module
+
+MY_P=${P/mod_security-/modsecurity-apache_}
+MY_P=${MY_P/_rc/-rc}
+
+DESCRIPTION="Web application firewall and Intrusion Detection System for Apache."
+HOMEPAGE="http://www.modsecurity.org/"
+SRC_URI="http://www.modsecurity.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+APXS2_ARGS="-DWITH_LIBXML2 -I/usr/include/libxml2 -lxml2 -S LIBEXECDIR=${S} -c -o ${PN}2.so ${S}/apache2/*.c"
+APACHE2_MOD_FILE=".libs/${PN}2.so"
+APACHE2_MOD_CONF="2.1.2/99_mod_security"
+APACHE2_MOD_DEFINE="SECURITY"
+
+need_apache2
+
+src_install() {
+ apache-module_src_install
+
+ # install documentation
+ dodoc CHANGES
+ newdoc rules/CHANGELOG CHANGES.crs
+ newdoc rules/README README.crs
+ dohtml doc/*.html doc/*.gif doc/*.jpg doc/*.css doc/*.pdf
+ cp -r "${S}"/doc/html-multipage "${D}"/usr/share/doc/${P}/html/
+
+ # Prepare the core ruleset
+ sed -i -e 's:logs/:/var/log/apache2/:g' "${S}"/rules/*.conf
+ for i in "${S}"/rules/*.conf; do
+ mv $i ${i/modsecurity_crs_/}
+ done
+
+ # Install core ruleset
+ insinto ${APACHE_MODULES_CONFDIR}/mod_security/
+ doins "${S}"/rules/*.conf
+}
diff --git a/www-apache/mod_security/mod_security-2.5.1.ebuild b/www-apache/mod_security/mod_security-2.5.1.ebuild
new file mode 100644
index 000000000000..853a8353b580
--- /dev/null
+++ b/www-apache/mod_security/mod_security-2.5.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.5.1.ebuild,v 1.1 2008/03/22 16:54:37 hollow Exp $
+
+inherit apache-module
+
+MY_P=${P/mod_security-/modsecurity-apache_}
+MY_P=${MY_P/_rc/-rc}
+
+DESCRIPTION="Web application firewall and Intrusion Detection System for Apache."
+HOMEPAGE="http://www.modsecurity.org/"
+SRC_URI="http://www.modsecurity.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="lua"
+
+DEPEND="dev-libs/libxml2
+ lua? ( >=dev-lang/lua-5.1 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+APACHE2_MOD_FILE="apache2/.libs/${PN}2.so"
+APACHE2_MOD_CONF="2.1.2/99_mod_security"
+APACHE2_MOD_DEFINE="SECURITY"
+
+need_apache2
+
+src_compile() {
+ cd apache2
+
+ econf --with-apxs="${APXS}" \
+ --without-curl \
+ $(use_with lua) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ apache-module_src_install
+
+ # install documentation
+ dodoc CHANGES
+ newdoc rules/CHANGELOG CHANGES.crs
+ newdoc rules/README README.crs
+ dohtml doc/*.html doc/*.gif doc/*.jpg doc/*.css doc/*.pdf
+ insinto /usr/share/doc/${P}/html/
+ doins -r doc/html-multipage
+
+ # Prepare the core ruleset
+ sed -i -e 's:logs/:/var/log/apache2/:g' "${S}"/rules/*.conf
+ for i in "${S}"/rules/*.conf; do
+ mv $i ${i/modsecurity_crs_/}
+ done
+
+ # Install core ruleset
+ insinto ${APACHE_MODULES_CONFDIR}/mod_security/
+ doins "${S}"/rules/*.conf
+}