summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-09-24 13:02:45 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-09-24 13:02:45 +0000
commit49b29a2b48ef06e2e055b64d8527ccb25ca3dc6f (patch)
tree947f464fe7715e362fc9b7087024d043249f8834 /www-apache
parentAdd an ebuild for the ModSecurity Core Rule Set split out of mod_security its... (diff)
downloadgentoo-2-49b29a2b48ef06e2e055b64d8527ccb25ca3dc6f.tar.gz
gentoo-2-49b29a2b48ef06e2e055b64d8527ccb25ca3dc6f.tar.bz2
gentoo-2-49b29a2b48ef06e2e055b64d8527ccb25ca3dc6f.zip
Add a new revision that doesn't install the Core Rule Set and rather rely on www-apache/modsecurity-crs.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_security/ChangeLog9
-rw-r--r--www-apache/mod_security/mod_security-2.5.12-r1.ebuild86
2 files changed, 94 insertions, 1 deletions
diff --git a/www-apache/mod_security/ChangeLog b/www-apache/mod_security/ChangeLog
index 08e021b6e07a..2c0002d69657 100644
--- a/www-apache/mod_security/ChangeLog
+++ b/www-apache/mod_security/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apache/mod_security
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.42 2010/06/02 06:31:39 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.43 2010/09/24 13:02:45 flameeyes Exp $
+
+*mod_security-2.5.12-r1 (24 Sep 2010)
+
+ 24 Sep 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +mod_security-2.5.12-r1.ebuild:
+ Add a new revision that doesn't install the Core Rule Set and rather rely
+ on www-apache/modsecurity-crs.
02 Jun 2010; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove chtekk from metadata.xml (#103720)
diff --git a/www-apache/mod_security/mod_security-2.5.12-r1.ebuild b/www-apache/mod_security/mod_security-2.5.12-r1.ebuild
new file mode 100644
index 000000000000..8edbc69174ba
--- /dev/null
+++ b/www-apache/mod_security/mod_security-2.5.12-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.5.12-r1.ebuild,v 1.1 2010/09/24 13:02:45 flameeyes Exp $
+
+EAPI=2
+
+inherit apache-module autotools
+
+MY_P=${P/mod_security-/modsecurity-apache_}
+MY_P=${MY_P/_rc/-rc}
+
+DESCRIPTION="Web application firewall and Intrusion Detection System for Apache."
+HOMEPAGE="http://www.modsecurity.org/"
+SRC_URI="http://www.modsecurity.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="lua"
+
+DEPEND="dev-libs/libxml2
+ lua? ( >=dev-lang/lua-5.1 )
+ www-servers/apache[apache2_modules_unique_id]"
+RDEPEND="${DEPEND}"
+PDEPEND="www-apache/modsecurity-crs"
+
+S="${WORKDIR}/${MY_P}"
+
+APACHE2_MOD_FILE="apache2/.libs/${PN}2.so"
+APACHE2_MOD_CONF="2.5.10/99_mod_security"
+APACHE2_MOD_DEFINE="SECURITY"
+
+need_apache2
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.5.10-as-needed.patch
+
+ cd apache2
+ eautoreconf
+}
+
+src_configure() {
+ cd apache2
+
+ econf --with-apxs="${APXS}" \
+ --without-curl \
+ $(use_with lua) \
+ || die "econf failed"
+}
+
+src_compile() {
+ cd apache2
+
+ APXS_FLAGS=
+ for flag in ${CFLAGS}; do
+ APXS_FLAGS="${APXS_FLAGS} -Wc,${flag}"
+ done
+
+ # Yes we need to prefix it _twice_
+ for flag in ${LDFLAGS}; do
+ APXS_FLAGS="${APXS_FLAGS} -Wl,${flag}"
+ done
+
+ emake \
+ APXS_CFLAGS="${CFLAGS}" \
+ APXS_LDFLAGS="${LDFLAGS}" \
+ APXS_EXTRA_CFLAGS="${APXS_FLAGS}" \
+ || die "emake failed"
+}
+
+src_test() {
+ cd apache2
+ emake test || die
+}
+
+src_install() {
+ apache-module_src_install
+
+ # install documentation
+ dodoc CHANGES || die
+ dohtml -r doc/* || die
+
+ keepdir /var/cache/mod_security || die
+ fowners apache:apache /var/cache/mod_security || die
+ fperms 0770 /var/cache/mod_security || die
+}