summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Marineau <marineam@gentoo.org>2006-06-07 16:34:20 +0000
committerMichael Marineau <marineam@gentoo.org>2006-06-07 16:34:20 +0000
commitfc08543a5c669b1df7cd7e38caab924992c2d60e (patch)
tree9414a46978b886a7acbdfb9ec5c981d7a5eb0877 /www-apps/ampache/ampache-3.3.1.7.ebuild
parentremoved .quake4-bin-1.2.1.ebuild.swp from the manifest (diff)
downloadgentoo-2-fc08543a5c669b1df7cd7e38caab924992c2d60e.tar.gz
gentoo-2-fc08543a5c669b1df7cd7e38caab924992c2d60e.tar.bz2
gentoo-2-fc08543a5c669b1df7cd7e38caab924992c2d60e.zip
Require the nessicary php use flags.
(Portage version: 2.0.54-r2)
Diffstat (limited to 'www-apps/ampache/ampache-3.3.1.7.ebuild')
-rw-r--r--www-apps/ampache/ampache-3.3.1.7.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/www-apps/ampache/ampache-3.3.1.7.ebuild b/www-apps/ampache/ampache-3.3.1.7.ebuild
index 3d4d44c5b35d..c5d6f3654962 100644
--- a/www-apps/ampache/ampache-3.3.1.7.ebuild
+++ b/www-apps/ampache/ampache-3.3.1.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ampache-3.3.1.7.ebuild,v 1.1 2006/02/10 03:08:31 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ampache-3.3.1.7.ebuild,v 1.2 2006/06/07 16:34:20 marineam Exp $
-inherit webapp
+inherit webapp depend.php
DESCRIPTION="Ampache is a PHP-based tool for managing, updating and playing your audio files via a web interface."
HOMEPAGE="http://www.ampache.org/"
@@ -16,6 +16,14 @@ RDEPEND="virtual/httpd-php
dev-db/mysql"
DEPEND=""
+need_php
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ require_php_with_use pcre session unicode iconv xml mysql gd zlib
+}
+
src_compile() {
einfo "Nothing to compile"
}