summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-08-18 11:33:44 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-08-18 11:33:44 +0000
commit9841b95d1f45e34582d7a8109cb56eb629562eaf (patch)
treef70194b81bc0d666cc6d845b94466e731fc8366e /www-apps/drupal
parentVersion bump, bug #234912, thank Tiziano Müller for report. Removed unused. (diff)
downloadgentoo-2-9841b95d1f45e34582d7a8109cb56eb629562eaf.tar.gz
gentoo-2-9841b95d1f45e34582d7a8109cb56eb629562eaf.tar.bz2
gentoo-2-9841b95d1f45e34582d7a8109cb56eb629562eaf.zip
version bump wrt security #234714
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/ChangeLog9
-rw-r--r--www-apps/drupal/drupal-5.10.ebuild51
-rw-r--r--www-apps/drupal/drupal-6.4.ebuild56
3 files changed, 115 insertions, 1 deletions
diff --git a/www-apps/drupal/ChangeLog b/www-apps/drupal/ChangeLog
index 5a04b03fd678..c488a176c467 100644
--- a/www-apps/drupal/ChangeLog
+++ b/www-apps/drupal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/drupal
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.49 2008/07/31 20:41:04 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.50 2008/08/18 11:33:44 hollow Exp $
+
+*drupal-6.4 (18 Aug 2008)
+*drupal-5.10 (18 Aug 2008)
+
+ 18 Aug 2008; Benedikt Böhm <hollow@gentoo.org> +drupal-5.10.ebuild,
+ +drupal-6.4.ebuild:
+ version bump wrt security #234714
*drupal-5.9 (31 Jul 2008)
diff --git a/www-apps/drupal/drupal-5.10.ebuild b/www-apps/drupal/drupal-5.10.ebuild
new file mode 100644
index 000000000000..b995240831a9
--- /dev/null
+++ b/www-apps/drupal/drupal-5.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-5.10.ebuild,v 1.1 2008/08/18 11:33:44 hollow Exp $
+
+inherit webapp eutils depend.php
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="http://drupal.org/"
+SRC_URI="http://drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ require_php_with_use expat
+ else
+ require_php_with_use xml
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt"
+ dodoc ${docs}
+ rm -f ${docs} INSTALL
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/drupal/drupal-6.4.ebuild b/www-apps/drupal/drupal-6.4.ebuild
new file mode 100644
index 000000000000..c6fdcbde5c07
--- /dev/null
+++ b/www-apps/drupal/drupal-6.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-6.4.ebuild,v 1.1 2008/08/18 11:33:44 hollow Exp $
+
+inherit webapp eutils depend.php
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="http://drupal.org/"
+SRC_URI="http://drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ local flags="expat"
+ else
+ local flags="xml"
+ fi
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ die "Re-install ${PHP_PKG} with ${flags} and either gd or gd-external"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt
+
+ cp sites/default/{default.settings.php,settings.php}
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}