summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-12-03 17:30:46 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-12-03 17:30:46 +0000
commitadadc29e6816fa35aa071dace513ee5c83130daa (patch)
treec57a922ea098fca2ad24afb0298e7404d9173103 /www-apps/gallery
parentdriver version bump. fixes known issues with firefox 3 image corruption. mobi... (diff)
downloadgentoo-2-adadc29e6816fa35aa071dace513ee5c83130daa.tar.gz
gentoo-2-adadc29e6816fa35aa071dace513ee5c83130daa.tar.bz2
gentoo-2-adadc29e6816fa35aa071dace513ee5c83130daa.zip
Added www-apps/gallery-1.5.10 in response to sec issue #249277.
(Portage version: 2.1.4.5)
Diffstat (limited to 'www-apps/gallery')
-rw-r--r--www-apps/gallery/ChangeLog7
-rw-r--r--www-apps/gallery/gallery-1.5.10.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/www-apps/gallery/ChangeLog b/www-apps/gallery/ChangeLog
index 20e19d8b9782..d7b83c0b1f32 100644
--- a/www-apps/gallery/ChangeLog
+++ b/www-apps/gallery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/gallery
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.165 2008/12/03 16:09:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.166 2008/12/03 17:30:46 wrobel Exp $
+
+*gallery-1.5.10 (03 Dec 2008)
+
+ 03 Dec 2008; Gunnar Wrobel <wrobel@gentoo.org> +gallery-1.5.10.ebuild:
+ Added www-apps/gallery-1.5.10 in response to sec issue #249277.
03 Dec 2008; Jeroen Roovers <jer@gentoo.org> gallery-2.3.ebuild:
Stable for HPPA (bug #213322).
diff --git a/www-apps/gallery/gallery-1.5.10.ebuild b/www-apps/gallery/gallery-1.5.10.ebuild
new file mode 100644
index 000000000000..9cc2c954db55
--- /dev/null
+++ b/www-apps/gallery/gallery-1.5.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-1.5.10.ebuild,v 1.1 2008/12/03 17:30:46 wrobel Exp $
+
+inherit webapp depend.php confutils
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="imagemagick netpbm unzip zip"
+
+RDEPEND="media-libs/jpeg
+ imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )"
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ confutils_require_any imagemagick netpbm
+ require_php_with_use pcre session
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ gunzip ChangeLog.archive.gz
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc AUTHORS ChangeLog ChangeLog.archive README
+ dohtml docs/*
+
+ cp -r . "${D}/${MY_HTDOCSDIR}"
+ rm -rf "${D}/${MY_HTDOCSDIR}"/{AUTHORS,ChangeLog,ChangeLog.archive,README,LICENSE.txt,docs/}
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}