summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-10-29 06:21:54 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-10-29 06:21:54 +0000
commita4c0074b427d420e356d9182e320ea1d14f60fd6 (patch)
treee79468238c9bc5219cc9ebf1a71049b26d216935 /www-apps/horizon
parentnew nova packages (diff)
downloadgentoo-2-a4c0074b427d420e356d9182e320ea1d14f60fd6.tar.gz
gentoo-2-a4c0074b427d420e356d9182e320ea1d14f60fd6.tar.bz2
gentoo-2-a4c0074b427d420e356d9182e320ea1d14f60fd6.zip
new horizon packages
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'www-apps/horizon')
-rw-r--r--www-apps/horizon/ChangeLog9
-rw-r--r--www-apps/horizon/horizon-2013.1.4.ebuild (renamed from www-apps/horizon/horizon-2013.1.3-r2.ebuild)2
-rw-r--r--www-apps/horizon/horizon-2013.2.ebuild42
3 files changed, 51 insertions, 2 deletions
diff --git a/www-apps/horizon/ChangeLog b/www-apps/horizon/ChangeLog
index 04e93f68b87f..83e34da452f9 100644
--- a/www-apps/horizon/ChangeLog
+++ b/www-apps/horizon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/horizon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/ChangeLog,v 1.14 2013/10/23 06:19:19 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/ChangeLog,v 1.15 2013/10/29 06:21:54 prometheanfire Exp $
+
+*horizon-2013.2 (29 Oct 2013)
+*horizon-2013.1.4 (29 Oct 2013)
+
+ 29 Oct 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +horizon-2013.1.4.ebuild, +horizon-2013.2.ebuild, -horizon-2013.1.3-r2.ebuild:
+ new horizon packages
*horizon-2013.2.9999 (23 Oct 2013)
diff --git a/www-apps/horizon/horizon-2013.1.3-r2.ebuild b/www-apps/horizon/horizon-2013.1.4.ebuild
index 60759e98d10c..0c43fa201674 100644
--- a/www-apps/horizon/horizon-2013.1.3-r2.ebuild
+++ b/www-apps/horizon/horizon-2013.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/horizon-2013.1.3-r2.ebuild,v 1.1 2013/09/13 20:49:41 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/horizon-2013.1.4.ebuild,v 1.1 2013/10/29 06:21:54 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
diff --git a/www-apps/horizon/horizon-2013.2.ebuild b/www-apps/horizon/horizon-2013.2.ebuild
new file mode 100644
index 000000000000..12b3ab13b486
--- /dev/null
+++ b/www-apps/horizon/horizon-2013.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/horizon-2013.2.ebuild,v 1.1 2013/10/29 06:21:54 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Horizon is a Django-based project aimed at providing a complete
+OpenStack Dashboard."
+HOMEPAGE="https://launchpad.net/horizon"
+SRC_URI="http://launchpad.net/${PN}/havana/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/django-1.4[${PYTHON_USEDEP}]
+ <dev-python/django-1.6[${PYTHON_USEDEP}]
+ >=dev-python/django-compressor-1.3[${PYTHON_USEDEP}]
+ >=dev-python/django-openstack-auth-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/kombu-2.4.8[${PYTHON_USEDEP}]
+ >=dev-python/lesscpy-0.9j[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ >=dev-python/python-cinderclient-1.0.5[${PYTHON_USEDEP}]
+ >=dev-python/python-glanceclient-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/python-heatclient-0.2.3[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/python-novaclient-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/python-neutronclient-2.3.0[${PYTHON_USEDEP}]
+ <dev-python/python-neutronclient-3[${PYTHON_USEDEP}]
+ >=dev-python/python-swiftclient-1.5[${PYTHON_USEDEP}]
+ >=dev-python/python-ceilometerclient-1.0.5[${PYTHON_USEDEP}]
+ <dev-python/python-troveclient-1[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2010h[${PYTHON_USEDEP}]
+ >=dev-python/lockfile-0.8[${PYTHON_USEDEP}]"