summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElfyn McBratney <beu@gentoo.org>2005-09-08 13:09:32 +0000
committerElfyn McBratney <beu@gentoo.org>2005-09-08 13:09:32 +0000
commit6d6c8b871e27515eaa9a4f5550229c8ac02cfe7d (patch)
tree230057761913fc35b23a3a2df8065d2dd4679ab1 /www-apps/swish-e/swish-e-2.2.2-r2.ebuild
parentFixed dependencies, bug #105224. (diff)
downloadgentoo-2-6d6c8b871e27515eaa9a4f5550229c8ac02cfe7d.tar.gz
gentoo-2-6d6c8b871e27515eaa9a4f5550229c8ac02cfe7d.tar.bz2
gentoo-2-6d6c8b871e27515eaa9a4f5550229c8ac02cfe7d.zip
Rev bumps (include more docs/example configs).
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-apps/swish-e/swish-e-2.2.2-r2.ebuild')
-rw-r--r--www-apps/swish-e/swish-e-2.2.2-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-apps/swish-e/swish-e-2.2.2-r2.ebuild b/www-apps/swish-e/swish-e-2.2.2-r2.ebuild
new file mode 100644
index 000000000000..003acc28a745
--- /dev/null
+++ b/www-apps/swish-e/swish-e-2.2.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/swish-e/swish-e-2.2.2-r2.ebuild,v 1.1 2005/09/08 13:09:32 beu Exp $
+
+inherit perl-module
+
+DESCRIPTION="Simple Web Indexing System for Humans - Enhanced"
+HOMEPAGE="http://www.swish-e.org/"
+SRC_URI="http://www.swish-e.org/Download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="doc perl"
+
+DEPEND=">=sys-libs/zlib-1.1.3
+ dev-libs/libxml2
+ dev-perl/libwww-perl"
+
+src_compile() {
+ econf || die "configuration failed"
+ emake || die "emake failed"
+
+ # closing stdin causes e-swish build system use a
+ # non-interactive mode <mkennedy@gentoo.org>
+ use perl && cd perl \
+ && exec <&- \
+ && perl-module_src_compile
+}
+
+src_install() {
+ dobin src/swish-e || die "dobin failed"
+ dodoc INSTALL README
+ if use doc; then
+ mkdir -p "${D}"/usr/share/doc/${PF}
+ cp -r html conf "${D}"/usr/share/doc/${PF} || die "cp failed"
+ fi
+ use perl && cd perl \
+ && perl-module_src_install
+}