summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-06-03 08:32:40 +0000
committerTorsten Veller <tove@gentoo.org>2009-06-03 08:32:40 +0000
commit8ffdea006ae6844190afcce1d14d0fab81c18fcc (patch)
tree64f70ca77d53d1629be7e5e366d028a07f37d0fc /www-apps/swish-e
parentadding Kenneth and myself as maintainers (diff)
downloadgentoo-2-8ffdea006ae6844190afcce1d14d0fab81c18fcc.tar.gz
gentoo-2-8ffdea006ae6844190afcce1d14d0fab81c18fcc.tar.bz2
gentoo-2-8ffdea006ae6844190afcce1d14d0fab81c18fcc.zip
Fixes bugs 261853 and bug 248477
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'www-apps/swish-e')
-rw-r--r--www-apps/swish-e/ChangeLog11
-rw-r--r--www-apps/swish-e/files/perl-makefile-2.patch11
-rw-r--r--www-apps/swish-e/metadata.xml4
-rw-r--r--www-apps/swish-e/swish-e-2.4.7.ebuild81
4 files changed, 102 insertions, 5 deletions
diff --git a/www-apps/swish-e/ChangeLog b/www-apps/swish-e/ChangeLog
index c2e40d397b5e..bdda0db8947d 100644
--- a/www-apps/swish-e/ChangeLog
+++ b/www-apps/swish-e/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/swish-e
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/swish-e/ChangeLog,v 1.14 2009/03/30 16:21:43 loki_val Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/swish-e/ChangeLog,v 1.15 2009/06/03 08:32:40 tove Exp $
+
+*swish-e-2.4.7 (03 Jun 2009)
+
+ 03 Jun 2009; Torsten Veller <tove@gentoo.org> +swish-e-2.4.7.ebuild,
+ +files/perl-makefile-2.patch, metadata.xml:
+ Version bump (#261853).
+ Fixes #248477. Thanks to Kent Fredric.
30 Mar 2009; Peter Alfredsen <loki_val@gentoo.org> swish-e-2.4.3.ebuild,
swish-e-2.4.3-r1.ebuild, swish-e-2.4.3-r2.ebuild, swish-e-2.4.4.ebuild,
diff --git a/www-apps/swish-e/files/perl-makefile-2.patch b/www-apps/swish-e/files/perl-makefile-2.patch
new file mode 100644
index 000000000000..1803d7fa29ef
--- /dev/null
+++ b/www-apps/swish-e/files/perl-makefile-2.patch
@@ -0,0 +1,11 @@
+diff -ur swish-e-2.4.7-orig/perl/Makefile.PL swish-e-2.4.7/perl/Makefile.PL
+--- swish-e-2.4.7-orig/perl/Makefile.PL 2009-04-05 03:58:33.000000000 +0200
++++ swish-e-2.4.7/perl/Makefile.PL 2009-06-03 09:39:10.000000000 +0200
+@@ -23,6 +23,7 @@
+ NORECURS => 1, # keep it from recursing into subdirectories
+ DIR => [],
+ XSPROTOARG => '-noprototypes',
++ CCFLAGS => '-I../src',
+ PREREQ_PM => { 'File::Spec' => '0.8', },
+ test => { TESTS => 't/*.t', },
+ clean => {
diff --git a/www-apps/swish-e/metadata.xml b/www-apps/swish-e/metadata.xml
index 86672fe64c10..658fa253f598 100644
--- a/www-apps/swish-e/metadata.xml
+++ b/www-apps/swish-e/metadata.xml
@@ -3,8 +3,6 @@
<pkgmetadata>
<herd>perl</herd>
<maintainer>
- <email>perl@gentoo.org</email>
- <description>Primary Maintainer</description>
+ <email>maintainer-needed@gentoo.org</email>
</maintainer>
- <longdescription></longdescription>
</pkgmetadata>
diff --git a/www-apps/swish-e/swish-e-2.4.7.ebuild b/www-apps/swish-e/swish-e-2.4.7.ebuild
new file mode 100644
index 000000000000..1dbe2b74939c
--- /dev/null
+++ b/www-apps/swish-e/swish-e-2.4.7.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/swish-e/swish-e-2.4.7.ebuild,v 1.1 2009/06/03 08:32:40 tove Exp $
+
+EAPI=2
+
+inherit perl-module eutils
+
+DESCRIPTION="Simple Web Indexing System for Humans - Enhanced"
+HOMEPAGE="http://www.swish-e.org/"
+SRC_URI="http://www.swish-e.org/distribution/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc perl pdf mp3"
+
+DEPEND=">=sys-libs/zlib-1.1.3
+ dev-libs/libxml2
+ pdf? ( virtual/poppler-utils )
+ perl? ( dev-perl/libwww-perl
+ dev-perl/HTML-Parser
+ dev-perl/HTML-Tagset
+ dev-perl/MIME-Types
+ dev-perl/HTML-Template
+ dev-perl/HTML-FillInForm
+ dev-perl/Template-Toolkit
+ mp3? ( dev-perl/MP3-Tag )
+ )"
+
+PATCHES=( "${FILESDIR}/perl-makefile-2.patch" )
+
+pkg_setup() {
+ if has_version 'www-apps/swish-e'; then
+ ewarn "Your old swish-e indexes may not be compatible with this version."
+ fi
+}
+
+src_configure() {
+ default
+ if use perl; then
+ cd "${S}/perl"
+ chmod u+x "${S}/swish-config"
+ myconf="SWISHBINDIR=${S} SWISHIGNOREVER SWISHSKIPTEST"
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ #emake -j1 || die "emake failed"
+ default
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+# dobin src/swish-e || die "dobin failed"
+ make DESTDIR="${D}" install || die
+ dodoc INSTALL README || die
+
+ if use doc; then
+ dodir /usr/share/doc/${PF}
+ cp -r html conf "${D}"/usr/share/doc/${PF} || die "cp failed"
+ fi
+
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_install
+ fi
+}
+
+pkg_postinst() {
+ einfo "If you wish to be able to index MS Word documents, "
+ einfo "emerge app-text/catdoc"
+ einfo
+ einfo "If you wish to be able to index MS Excel Spreadsheets,"
+ einfo "emerge dev-perl/SpreadSheet-ParseExcel and"
+ einfo "dev-perl/HTML-Parser"
+}