summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-06-09 21:13:54 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-06-09 21:13:54 +0000
commit2e3a13427c0c98e6997659c2c27b63cba3479e78 (patch)
tree9afd0e81ef514d2d70bcb36b7ed7b0d21287b27b /www-apps/tikiwiki
parentRemoved 2.4.0 in favor of 2.4.1. See bug #131323, by Markus Heule <mib at ipw... (diff)
downloadgentoo-2-2e3a13427c0c98e6997659c2c27b63cba3479e78.tar.gz
gentoo-2-2e3a13427c0c98e6997659c2c27b63cba3479e78.tar.bz2
gentoo-2-2e3a13427c0c98e6997659c2c27b63cba3479e78.zip
Version bump wrt security bug #134483.
(Portage version: 2.1_rc2-r3)
Diffstat (limited to 'www-apps/tikiwiki')
-rw-r--r--www-apps/tikiwiki/ChangeLog8
-rw-r--r--www-apps/tikiwiki/files/digest-tikiwiki-1.9.3.23
-rw-r--r--www-apps/tikiwiki/tikiwiki-1.9.3.2.ebuild83
3 files changed, 93 insertions, 1 deletions
diff --git a/www-apps/tikiwiki/ChangeLog b/www-apps/tikiwiki/ChangeLog
index 8fcd4188b7ad..a1710147835c 100644
--- a/www-apps/tikiwiki/ChangeLog
+++ b/www-apps/tikiwiki/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/tikiwiki
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.27 2006/05/04 14:04:13 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.28 2006/06/09 21:13:54 rl03 Exp $
+
+*tikiwiki-1.9.3.2 (09 Jun 2006)
+
+ 09 Jun 2006; Renat Lumpau <rl03@gentoo.org> -tikiwiki-1.9.3.1.ebuild,
+ +tikiwiki-1.9.3.2.ebuild:
+ Version bump wrt security bug #134483.
*tikiwiki-1.9.3.1 (04 May 2006)
diff --git a/www-apps/tikiwiki/files/digest-tikiwiki-1.9.3.2 b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.3.2
new file mode 100644
index 000000000000..e602f3eb67ab
--- /dev/null
+++ b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.3.2
@@ -0,0 +1,3 @@
+MD5 28ec7aaeed22e3a622839c2c780f5a61 tikiwiki-1.9.3.2.tar.bz2 6522618
+RMD160 ff5f0d58b4246e9d4268738445185c2264f7505f tikiwiki-1.9.3.2.tar.bz2 6522618
+SHA256 e577bf15fef0681f67f859cda75ea498f4f2c327bd5d88ab0a7aedd4d4425f11 tikiwiki-1.9.3.2.tar.bz2 6522618
diff --git a/www-apps/tikiwiki/tikiwiki-1.9.3.2.ebuild b/www-apps/tikiwiki/tikiwiki-1.9.3.2.ebuild
new file mode 100644
index 000000000000..2432b8c88cfb
--- /dev/null
+++ b/www-apps/tikiwiki/tikiwiki-1.9.3.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-1.9.3.2.ebuild,v 1.1 2006/06/09 21:13:54 rl03 Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Full-featured Web Content Management System using PHP and Smarty Templates"
+HOMEPAGE="http://tikiwiki.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+IUSE="mysql postgres graphviz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/php
+ mysql? ( >=dev-db/mysql-4 )
+ postgres? ( dev-db/postgresql )
+ graphviz? ( media-gfx/graphviz )
+"
+pkg_setup () {
+ webapp_pkg_setup
+ use mysql && require_php_with_use mysql
+ use postgres && require_php_with_use postgres
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local DIR
+ local DIRENTRY
+ local DIRS="backups db dump files img/trackers img/wiki
+ img/wiki_up modules/cache temp
+ templates_c templates styles maps whelp mods
+ lib/Galaxia/processes"
+
+ # Ensure that directories exist, some don't.
+ # (part of setup.sh)
+ for DIR in ${DIRS}; do
+ mkdir -p ${DIR}
+ done
+
+ # Remove the execute permission from the setup.sh script
+ # and rename it. Its actions have been incorporated here.
+ chmod a-x setup.sh
+ mv setup.sh setup.sh.done
+
+ # Install the minimal doc (points to web page)
+ #
+ dodoc doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+
+ # The bulk goes into htdocs
+ # but don't copy INSTALL and README
+ cp -pPR [[:lower:]]* ${D}/${MY_HTDOCSDIR}
+
+ # Recursively set server ownership to allow server to write
+ # This is the rough equivalent of the setup.sh script
+ # provided in the distribution.
+ # Note: Cannot use xargs or find -exec here because
+ # these don't work with shell functions.
+ #
+ webapp_serverowned ${MY_HTDOCSDIR}
+ for DIR in ${DIRS}; do
+ find ${DIR} | while read DIRENTRY; do
+ webapp_serverowned ${MY_HTDOCSDIR}/${DIRENTRY}
+ done
+ done
+ webapp_serverowned ${MY_HTDOCSDIR}/tiki-install.php
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_src_install
+}
+
+pkg_config() {
+ einfo "Type in your MySQL root password to create an empty tiki database:"
+ mysqladmin -u root -p create tikiwiki
+}
+
+pkg_postinst() {
+ einfo "To setup a MySQL database, run:"
+ einfo "\"emerge --config =${PF}\""
+ einfo "If you are using PostgreSQL, consult your documentation"
+ webapp_pkg_postinst
+}