summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2014-06-21 18:27:05 +0000
committerAlfredo Tupone <tupone@gentoo.org>2014-06-21 18:27:05 +0000
commit5569c56905180f5ae2c5df10d0bf005b21add5c1 (patch)
tree8dbf7cfb7fdee752e36261596d64959eb2126320 /www-apps
parentCreate group "input" wrt bugs #246847 and #514174 (diff)
downloadgentoo-2-5569c56905180f5ae2c5df10d0bf005b21add5c1.tar.gz
gentoo-2-5569c56905180f5ae2c5df10d0bf005b21add5c1.tar.bz2
gentoo-2-5569c56905180f5ae2c5df10d0bf005b21add5c1.zip
Build fix. Bug #514162
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/webmcp/ChangeLog8
-rw-r--r--www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch46
2 files changed, 51 insertions, 3 deletions
diff --git a/www-apps/webmcp/ChangeLog b/www-apps/webmcp/ChangeLog
index 96132d330ddb..7bb016d74f4d 100644
--- a/www-apps/webmcp/ChangeLog
+++ b/www-apps/webmcp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/webmcp
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/webmcp/ChangeLog,v 1.1 2013/04/24 08:15:15 tupone Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/webmcp/ChangeLog,v 1.2 2014/06/21 18:27:05 tupone Exp $
+
+ 21 Jun 2014; Tupone Alfredo <tupone@gentoo.org>
+ files/webmcp-1.2.5-gentoo.patch:
+ Build fix. Bug #514162 by Patrick Lauer
*webmcp-1.2.5 (24 Apr 2013)
diff --git a/www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch b/www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch
index e318f0328ead..2cd506583e6b 100644
--- a/www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch
+++ b/www-apps/webmcp/files/webmcp-1.2.5-gentoo.patch
@@ -41,7 +41,7 @@
# TODO: check alternatives to -D_GNU_SOURCE -fPIC
# using libtool?
-CFLAGS = -O2 -D_GNU_SOURCE -fPIC -Wall -I /usr/include -I /usr/local/include
-+CPPFLAGS = -D_GNU_SOURCE -I /usr/include
++CPPFLAGS = -D_GNU_SOURCE
# additional C compiler flags for parts which depend on PostgreSQL
CFLAGS_PGSQL = -I /usr/include/postgresql -I /usr/include/postgresql/server -I /usr/local/include/postgresql -I /usr/local/include/postgresql/server
@@ -95,3 +95,47 @@
#define EXTOS_MAX_ERRLEN 80
#define EXTOS_EXEC_MAX_ARGS 64
+--- framework/accelerator/Makefile.old 2014-06-21 20:15:21.019918183 +0200
++++ framework/accelerator/Makefile 2014-06-21 20:15:44.700471794 +0200
+@@ -4,7 +4,7 @@
+ $(LD) $(LDFLAGS) -o webmcp_accelerator.$(SLIB_EXT) webmcp_accelerator.o
+
+ webmcp_accelerator.o: webmcp_accelerator.c
+- $(CC) -c $(CFLAGS) -o webmcp_accelerator.o webmcp_accelerator.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC -o webmcp_accelerator.o webmcp_accelerator.c
+
+ clean::
+ rm -f webmcp_accelerator.so webmcp_accelerator.o
+--- libraries/extos/Makefile.old 2014-06-21 20:18:25.594611956 +0200
++++ libraries/extos/Makefile 2014-06-21 20:18:50.457183029 +0200
+@@ -4,7 +4,7 @@
+ $(LD) $(LDFLAGS) -o extos.$(SLIB_EXT) extos.o -lrt -lcrypt -llua
+
+ extos.o: extos.c
+- $(CC) -c $(CFLAGS) -o extos.o extos.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC -o extos.o extos.c
+
+ clean::
+ rm -f extos.so extos.o
+--- libraries/mondelefant/Makefile.old 2014-06-21 20:19:58.218962359 +0200
++++ libraries/mondelefant/Makefile 2014-06-21 20:20:24.527476578 +0200
+@@ -4,7 +4,7 @@
+ $(LD) $(LDFLAGS) $(LDFLAGS_PGSQL) -o mondelefant_native.$(SLIB_EXT) mondelefant_native.o -lpq -llua
+
+ mondelefant_native.o: mondelefant_native.c
+- $(CC) -c $(CFLAGS) $(CFLAGS_PGSQL) -o mondelefant_native.o mondelefant_native.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC $(CFLAGS_PGSQL) -o mondelefant_native.o mondelefant_native.c
+
+ test:: mondelefant_native.so mondelefant.lua
+ lua -l mondelefant
+--- libraries/multirand/Makefile.old 2014-06-21 20:21:36.950197127 +0200
++++ libraries/multirand/Makefile 2014-06-21 20:22:04.967703944 +0200
+@@ -4,7 +4,7 @@
+ $(LD) $(LDFLAGS) -o multirand.$(SLIB_EXT) multirand.o -llua
+
+ multirand.o: multirand.c
+- $(CC) -c $(CFLAGS) -o multirand.o multirand.c
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -fPIC -o multirand.o multirand.c
+
+ clean::
+ rm -f multirand.so multirand.o