summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2015-03-13 15:28:54 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2015-03-13 15:28:54 +0000
commitddc54b6caa259aa7943e7d719d304e855c0f076c (patch)
treeed06cbc04c91ac2e108b4e5a17e4d206ac3f94c5 /www-apps
parentFix multilib support (bug #524396). Remove old. (diff)
downloadgentoo-2-ddc54b6caa259aa7943e7d719d304e855c0f076c.tar.gz
gentoo-2-ddc54b6caa259aa7943e7d719d304e855c0f076c.tar.bz2
gentoo-2-ddc54b6caa259aa7943e7d719d304e855c0f076c.zip
Bump version
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/cgit/ChangeLog7
-rw-r--r--www-apps/cgit/cgit-0.11.2.ebuild94
2 files changed, 100 insertions, 1 deletions
diff --git a/www-apps/cgit/ChangeLog b/www-apps/cgit/ChangeLog
index d739c80eb1da..87effc0df694 100644
--- a/www-apps/cgit/ChangeLog
+++ b/www-apps/cgit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/cgit
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/ChangeLog,v 1.31 2015/03/05 19:16:29 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/ChangeLog,v 1.32 2015/03/13 15:28:54 zx2c4 Exp $
+
+*cgit-0.11.2 (13 Mar 2015)
+
+ 13 Mar 2015; Jason A. Donenfeld <zx2c4@gentoo.org> +cgit-0.11.2.ebuild:
+ Bump version
*cgit-0.11.1-r1 (05 Mar 2015)
diff --git a/www-apps/cgit/cgit-0.11.2.ebuild b/www-apps/cgit/cgit-0.11.2.ebuild
new file mode 100644
index 000000000000..6fe5eaf51ccb
--- /dev/null
+++ b/www-apps/cgit/cgit-0.11.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/cgit-0.11.2.ebuild,v 1.1 2015/03/13 15:28:54 zx2c4 Exp $
+
+EAPI=5
+
+WEBAPP_MANUAL_SLOT="yes"
+
+inherit webapp eutils multilib user toolchain-funcs
+
+[[ -z "${CGIT_CACHEDIR}" ]] && CGIT_CACHEDIR="/var/cache/${PN}/"
+
+GIT_V="2.3.2"
+
+DESCRIPTION="a fast web-interface for git repositories"
+HOMEPAGE="http://git.zx2c4.com/cgit/about"
+SRC_URI="mirror://kernel/software/scm/git/git-${GIT_V}.tar.xz
+ http://git.zx2c4.com/cgit/snapshot/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +highlight +lua +jit"
+
+RDEPEND="
+ dev-vcs/git
+ sys-libs/zlib
+ dev-libs/openssl:0
+ virtual/httpd-cgi
+ highlight? ( || ( dev-python/pygments app-text/highlight ) )
+ lua? ( jit? ( dev-lang/luajit ) !jit? ( dev-lang/lua ) )
+"
+# ebuilds without WEBAPP_MANUAL_SLOT="yes" are broken
+DEPEND="${RDEPEND}
+ !<www-apps/cgit-0.8.3.3
+ doc? ( app-text/docbook-xsl-stylesheets
+ >=app-text/asciidoc-8.5.1 )
+"
+
+pkg_setup() {
+ webapp_pkg_setup
+ enewuser "${PN}"
+}
+
+src_prepare() {
+ rmdir git || die
+ mv "${WORKDIR}"/git-"${GIT_V}" git || die
+
+ echo "prefix = ${EPREFIX}/usr" >> cgit.conf
+ echo "libdir = ${EPREFIX}/usr/$(get_libdir)" >> cgit.conf
+ echo "CGIT_SCRIPT_PATH = ${MY_CGIBINDIR}" >> cgit.conf
+ echo "CGIT_DATA_PATH = ${MY_HTDOCSDIR}" >> cgit.conf
+ echo "CACHE_ROOT = ${CGIT_CACHEDIR}" >> cgit.conf
+ echo "DESTDIR = ${D}" >> cgit.conf
+ if use lua; then
+ if use jit; then
+ echo "LUA_PKGCONFIG = luajit" >> cgit.conf
+ else
+ echo "LUA_PKGCONFIG = lua" >> cgit.conf
+ fi
+ else
+ echo "NO_LUA = 1" >> cgit.conf
+ fi
+}
+
+src_compile() {
+ emake V=1 AR="$(tc-getAR)" CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ use doc && emake V=1 doc-man
+}
+
+src_install() {
+ webapp_src_preinst
+
+ emake V=1 AR="$(tc-getAR)" CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" install
+
+ insinto /etc
+ doins "${FILESDIR}"/cgitrc
+
+ dodoc README
+ use doc && doman cgitrc.5
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+
+ keepdir "${CGIT_CACHEDIR}"
+ fowners ${PN}:${PN} "${CGIT_CACHEDIR}"
+ fperms 700 "${CGIT_CACHEDIR}"
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ ewarn "If you intend to run cgit using web server's user"
+ ewarn "you should change ${CGIT_CACHEDIR} permissions."
+}