summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-03-03 21:35:46 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-03-03 21:35:46 +0000
commitdf15fff99d3e9cb841cf58685ae0b5e7e8e95f7a (patch)
treef63fdeb96c0dd0d33e8d5faab972ee045daa8044 /www-apps
parentinitial commit (diff)
downloadgentoo-2-df15fff99d3e9cb841cf58685ae0b5e7e8e95f7a.tar.gz
gentoo-2-df15fff99d3e9cb841cf58685ae0b5e7e8e95f7a.tar.bz2
gentoo-2-df15fff99d3e9cb841cf58685ae0b5e7e8e95f7a.zip
version bump wrt security #212227
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/tikiwiki/ChangeLog7
-rw-r--r--www-apps/tikiwiki/tikiwiki-1.9.10.1.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/www-apps/tikiwiki/ChangeLog b/www-apps/tikiwiki/ChangeLog
index 883079aba703..c7f2e28988a4 100644
--- a/www-apps/tikiwiki/ChangeLog
+++ b/www-apps/tikiwiki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/tikiwiki
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.55 2008/02/22 16:34:03 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.56 2008/03/03 21:35:46 hollow Exp $
+
+*tikiwiki-1.9.10.1 (03 Mar 2008)
+
+ 03 Mar 2008; Benedikt Böhm <hollow@gentoo.org> +tikiwiki-1.9.10.1.ebuild:
+ version bump wrt security #212227
22 Feb 2008; Benedikt Böhm <hollow@gentoo.org> tikiwiki-1.9.9.ebuild:
ebuild cleanup wrt #208584
diff --git a/www-apps/tikiwiki/tikiwiki-1.9.10.1.ebuild b/www-apps/tikiwiki/tikiwiki-1.9.10.1.ebuild
new file mode 100644
index 000000000000..ecdc79444616
--- /dev/null
+++ b/www-apps/tikiwiki/tikiwiki-1.9.10.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-1.9.10.1.ebuild,v 1.1 2008/03/03 21:35:46 hollow Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Full-featured Web Content Management System using PHP and Smarty Templates"
+HOMEPAGE="http://tikiwiki.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+IUSE="mysql postgres graphviz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="graphviz? ( media-gfx/graphviz )"
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup () {
+ webapp_pkg_setup
+
+ local my_flags=
+ use mysql && my_flags="${my_flags} mysql"
+ use postgres && my_flags="${my_flags} postgres"
+
+ require_php_with_use ${my_flags}
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # Remove the execute permission from the setup.sh script
+ # and rename it. Its actions have been incorporated here.
+ chmod a-x setup.sh
+ mv setup.sh setup.sh.done
+
+ dodoc changelog.txt copyright.txt doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+ rm -rf changelog.txt copyright.txt doc/ INSTALL license.txt README
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local DIR DIRENTRY
+ local DIRS="backups db dump files img/trackers img/wiki
+ img/wiki_up modules/cache temp
+ templates_c templates styles maps whelp mods
+ lib/Galaxia/processes"
+
+ # Recursively set server ownership to allow server to write
+ # This is the rough equivalent of the setup.sh script
+ # provided in the distribution.
+ # Note: Cannot use xargs or find -exec here because
+ # these don't work with shell functions.
+
+ webapp_serverowned "${MY_HTDOCSDIR}"
+ webapp_serverowned "${MY_HTDOCSDIR}"/tiki-install.php
+
+ # ensure that directories exist, some don't.
+ # (part of original setup.sh)
+ for DIR in ${DIRS}; do
+ dodir "${MY_HTDOCSDIR}/${DIR}"
+ webapp_serverowned -R "${MY_HTDOCSDIR}/${DIR}"
+ done
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}