summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-03-10 15:38:12 +0000
committerMichael Januszewski <spock@gentoo.org>2007-03-10 15:38:12 +0000
commit78df935da21e8df202f15f07aee0009ba6435921 (patch)
treea47e9ecf19ece047d1b621316ef20ce54e1be07d /www-client/elinks
parentAdded xfce-extra/xarchiver arj to p.use.mask (diff)
downloadgentoo-2-78df935da21e8df202f15f07aee0009ba6435921.tar.gz
gentoo-2-78df935da21e8df202f15f07aee0009ba6435921.tar.bz2
gentoo-2-78df935da21e8df202f15f07aee0009ba6435921.zip
Fix support for >Guile-1.6.8 and Lua 5.1.
(Portage version: 2.1.2.2)
Diffstat (limited to 'www-client/elinks')
-rw-r--r--www-client/elinks/ChangeLog7
-rw-r--r--www-client/elinks/elinks-0.11.2.ebuild26
-rw-r--r--www-client/elinks/files/elinks-0.11.2-lua-5.1.patch16
-rw-r--r--www-client/elinks/files/elinks-0.11.2-lua-5.patch60
4 files changed, 100 insertions, 9 deletions
diff --git a/www-client/elinks/ChangeLog b/www-client/elinks/ChangeLog
index 42bdef3fb9ae..04c73bca2a3e 100644
--- a/www-client/elinks/ChangeLog
+++ b/www-client/elinks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/elinks
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/ChangeLog,v 1.73 2007/02/17 23:04:12 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/ChangeLog,v 1.74 2007/03/10 15:38:12 spock Exp $
+
+ 10 Mar 2007; Michał Januszewski <spock@gentoo.org>
+ +files/elinks-0.11.2-lua-5.1.patch, +files/elinks-0.11.2-lua-5.patch,
+ elinks-0.11.2.ebuild:
+ Fix support for >Guile-1.6.8 and Lua 5.1.
17 Feb 2007; Fabian Groffen <grobian@gentoo.org>
-files/elinks-osx-configure.diff, elinks-0.10.5.ebuild,
diff --git a/www-client/elinks/elinks-0.11.2.ebuild b/www-client/elinks/elinks-0.11.2.ebuild
index 449e70b7adcd..7722677dd745 100644
--- a/www-client/elinks/elinks-0.11.2.ebuild
+++ b/www-client/elinks/elinks-0.11.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/elinks-0.11.2.ebuild,v 1.11 2007/01/27 09:48:28 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/elinks-0.11.2.ebuild,v 1.12 2007/03/10 15:38:12 spock Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="1.4"
-inherit eutils autotools
+inherit eutils autotools flag-o-matic
MY_P="${P/_/}"
DESCRIPTION="Advanced and well-established text-mode web browser"
@@ -37,6 +37,15 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ if use guile && has_version ">dev-scheme/guile-1.6.8" &&
+ ! built_with_use -a dev-scheme/guile deprecated discouraged; then
+ eerror "To install elinks with the 'guile' USE flag, dev-scheme/guile has to"
+ eerror "be built with 'deprecated' and 'discouraged' USE flags."
+ die "dev-scheme/guile not built with deprecated/discouraged"
+ fi
+}
+
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PN}-0.10.4.conf-syscharset.diff
@@ -49,9 +58,16 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-0.11.0-gcc4-inline.patch
epatch ${FILESDIR}/${PN}-0.11.0-ruby.patch
epatch ${FILESDIR}/${PN}-0.11.1-time.patch
+ epatch ${FILESDIR}/${PN}-0.11.2-lua-5.patch
+
+ if use lua && has_version ">=dev-lang/lua-5.1"; then
+ epatch ${FILESDIR}/${PN}-0.11.2-lua-5.1.patch
+ fi
+
if use unicode ; then
epatch ${FILESDIR}/elinks-0.10.1-utf_8_io-default.patch
fi
+
sed -i -e 's/-Werror//' configure*
}
@@ -127,12 +143,6 @@ pkg_postinst() {
einfo
einfo "Please have a look at /etc/elinks/keybind-full.sample and"
einfo "/etc/elinks/keybind.conf.sample for some bindings examples."
- if use guile ; then
- einfo
- einfo "Since you have compiled ELinks with Guile support, you will have to"
- einfo "copy internal-hooks.scm and user-hooks.scm from"
- einfo "/usr/share/doc/${PF}/contrib/guile/ to ~/.elinks/"
- fi
einfo
einfo "You will have to set your TERM variable to 'xterm-256color'"
einfo "to be able to use 256 colors in elinks."
diff --git a/www-client/elinks/files/elinks-0.11.2-lua-5.1.patch b/www-client/elinks/files/elinks-0.11.2-lua-5.1.patch
new file mode 100644
index 000000000000..20db8a484598
--- /dev/null
+++ b/www-client/elinks/files/elinks-0.11.2-lua-5.1.patch
@@ -0,0 +1,16 @@
+diff -Naurp elinks-0.11.2/src/scripting/lua/core.c elinks-0.11.2-lua/src/scripting/lua/core.c
+--- elinks-0.11.2/src/scripting/lua/core.c 2006-11-19 14:46:37.000000000 +0100
++++ elinks-0.11.2-lua/src/scripting/lua/core.c 2007-03-10 15:34:47.000000000 +0100
+@@ -646,11 +646,7 @@ init_lua(struct module *module)
+ {
+ L = lua_open();
+
+- luaopen_base(L);
+- luaopen_table(L);
+- luaopen_io(L);
+- luaopen_string(L);
+- luaopen_math(L);
++ luaL_openlibs(L);
+
+ lua_register(L, LUA_ALERT, l_alert);
+ lua_register(L, "current_url", l_current_url);
diff --git a/www-client/elinks/files/elinks-0.11.2-lua-5.patch b/www-client/elinks/files/elinks-0.11.2-lua-5.patch
new file mode 100644
index 000000000000..2b4bf611d8be
--- /dev/null
+++ b/www-client/elinks/files/elinks-0.11.2-lua-5.patch
@@ -0,0 +1,60 @@
+diff -Naur elinks-0.11.1.orig/configure.in elinks-0.11.1/configure.in
+--- elinks-0.11.1.orig/configure.in 2006-01-29 14:10:33.000000000 +0100
++++ elinks-0.11.1/configure.in 2006-03-01 17:32:58.000000000 +0100
+@@ -739,7 +739,7 @@
+ for luadir in "$withval" "" /usr /usr/local; do
+ for suffix in "" 50 51; do
+ if test "$cf_result" = no; then
+- LUA_LIBS="-llua$suffix -llualib$suffix -lm"
++ LUA_LIBS="`pkg-config --libs lua`"
+
+ if test ! -z "$luadir"; then
+ LUA_LIBS="-L$luadir/lib $LUA_LIBS"
+@@ -754,10 +754,10 @@
+ AC_TRY_LINK([ #include <lua.h>
+ #include <lualib.h>],
+ [ lua_State *L = lua_open();
+- lua_baselibopen(L);
+- lua_mathlibopen(L);
+- lua_strlibopen(L);
+- lua_tablibopen(L);
++ luaopen_base(L);
++ luaopen_math(L);
++ luaopen_string(L);
++ luaopen_table(L);
+ lua_pushboolean(L, 1);
+ lua_close(L);],
+ cf_result=yes, cf_result=no)
+diff -Naur elinks-0.11.1.orig/src/scripting/lua/core.c elinks-0.11.1/src/scripting/lua/core.c
+--- elinks-0.11.1.orig/src/scripting/lua/core.c 2006-01-29 14:10:39.000000000 +0100
++++ elinks-0.11.1/src/scripting/lua/core.c 2006-03-01 17:41:43.000000000 +0100
+@@ -633,7 +633,7 @@
+ if (file_can_read(file)) {
+ int oldtop = lua_gettop(S);
+
+- if (lua_dofile(S, file) != 0)
++ if (luaL_dofile(S, file) != 0)
+ sleep(3); /* Let some time to see error messages. */
+ lua_settop(S, oldtop);
+ }
+@@ -755,7 +755,7 @@
+ int oldtop = lua_gettop(L);
+
+ if (prepare_lua(ses) == 0) {
+- lua_dostring(L, expr);
++ luaL_dostring(L, expr);
+ lua_settop(L, oldtop);
+ finish_lua();
+ }
+diff -Naur elinks-0.11.1.orig/src/scripting/lua/hooks.c elinks-0.11.1/src/scripting/lua/hooks.c
+--- elinks-0.11.1.orig/src/scripting/lua/hooks.c 2006-01-29 14:10:39.000000000 +0100
++++ elinks-0.11.1/src/scripting/lua/hooks.c 2006-03-01 17:41:07.000000000 +0100
+@@ -200,7 +200,7 @@
+ script_hook_quit(va_list ap, void *data)
+ {
+ if (!prepare_lua(NULL)) {
+- lua_dostring(lua_state, "if quit_hook then quit_hook() end");
++ luaL_dostring(lua_state, "if quit_hook then quit_hook() end");
+ finish_lua();
+ }
+