summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-06-08 18:20:13 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-06-08 18:20:13 +0000
commit3409d9bfb5606a2a0a7581b0d64ca87d92a315ed (patch)
treec6c351694e30c173720b87b09b9e90e7002e60ef /www-client/midori/midori-9999.ebuild
parentbump to 2.14.13. Clean up old revisions. (diff)
downloadgentoo-2-3409d9bfb5606a2a0a7581b0d64ca87d92a315ed.tar.gz
gentoo-2-3409d9bfb5606a2a0a7581b0d64ca87d92a315ed.tar.bz2
gentoo-2-3409d9bfb5606a2a0a7581b0d64ca87d92a315ed.zip
Initial import from sunrise overlay
(Portage version: 2.1.5.4)
Diffstat (limited to 'www-client/midori/midori-9999.ebuild')
-rw-r--r--www-client/midori/midori-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/www-client/midori/midori-9999.ebuild b/www-client/midori/midori-9999.ebuild
new file mode 100644
index 000000000000..2b47e591723a
--- /dev/null
+++ b/www-client/midori/midori-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-9999.ebuild,v 1.1 2008/06/08 18:20:13 jokey Exp $
+
+inherit git eutils
+
+DESCRIPTION="A lightweight web browser"
+HOMEPAGE="http://software.twotoasts.de/?page=midori"
+EGIT_REPO_URI="http://software.twotoasts.de/media/midori.git"
+EGIT_PROJECT="midori"
+EGIT_BOOTSTRAP="NOCONFIGURE=1 ./autogen.sh"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="x11-libs/gtk+
+ x11-libs/libsexy
+ net-libs/webkitgtk"
+
+pkg_setup() {
+ ewarn "Note: this software is not yet in a too marture status so expect some minor things to break"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ dodoc AUTHORS ChangeLog INSTALL TODO
+}
+