summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-30 21:19:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-30 21:19:32 +0000
commit18429e8750a0fa992a23427c9d6b04592938eb8a (patch)
tree1a66c59ee61494857192d59a910b66e43a2490fc /www-client/midori
parentClone the ffmpeg from git as svn external was removed. (diff)
downloadgentoo-2-18429e8750a0fa992a23427c9d6b04592938eb8a.tar.gz
gentoo-2-18429e8750a0fa992a23427c9d6b04592938eb8a.tar.bz2
gentoo-2-18429e8750a0fa992a23427c9d6b04592938eb8a.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'www-client/midori')
-rw-r--r--www-client/midori/ChangeLog6
-rw-r--r--www-client/midori/files/midori-0.2.9-libnotify-0.7.patch25
-rw-r--r--www-client/midori/midori-0.2.9-r1.ebuild4
-rw-r--r--www-client/midori/midori-0.2.9.ebuild6
4 files changed, 36 insertions, 5 deletions
diff --git a/www-client/midori/ChangeLog b/www-client/midori/ChangeLog
index 61e6c679ec4c..210ad6d0503a 100644
--- a/www-client/midori/ChangeLog
+++ b/www-client/midori/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/midori
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/ChangeLog,v 1.46 2011/01/16 18:32:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/ChangeLog,v 1.47 2011/01/30 21:19:32 ssuominen Exp $
+
+ 30 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> midori-0.2.9-r1.ebuild,
+ +files/midori-0.2.9-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
*midori-0.2.9-r1 (16 Jan 2011)
diff --git a/www-client/midori/files/midori-0.2.9-libnotify-0.7.patch b/www-client/midori/files/midori-0.2.9-libnotify-0.7.patch
new file mode 100644
index 000000000000..d1e604ab6da6
--- /dev/null
+++ b/www-client/midori/files/midori-0.2.9-libnotify-0.7.patch
@@ -0,0 +1,25 @@
+--- midori/midori-app.c
++++ midori/midori-app.c
+@@ -42,6 +42,9 @@
+
+ #if HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
++ #ifndef NOTIFY_CHECK_VERSION
++ #define NOTIFY_CHECK_VERSION(x,y,z) 0
++ #endif
+ #endif
+
+ struct _MidoriApp
+@@ -1203,8 +1206,11 @@
+ if (notify_is_initted ())
+ {
+ NotifyNotification* note;
+-
++ #if NOTIFY_CHECK_VERSION(0, 7, 0)
++ note = notify_notification_new (title, message, "midori");
++ #else
+ note = notify_notification_new (title, message, "midori", NULL);
++ #endif
+ notify_notification_show (note, NULL);
+ g_object_unref (note);
+ }
diff --git a/www-client/midori/midori-0.2.9-r1.ebuild b/www-client/midori/midori-0.2.9-r1.ebuild
index d9678e897572..fb7a18e4b6e4 100644
--- a/www-client/midori/midori-0.2.9-r1.ebuild
+++ b/www-client/midori/midori-0.2.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.2.9-r1.ebuild,v 1.1 2011/01/16 18:32:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.2.9-r1.ebuild,v 1.2 2011/01/30 21:19:32 ssuominen Exp $
EAPI=2
inherit eutils multilib python xfconf
@@ -36,6 +36,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+
# moving docs to version-specific directory
sed -i -e "s:/${PN}/user/midori.html:/user/midori.html:g" midori/midori-browser.c || die
}
diff --git a/www-client/midori/midori-0.2.9.ebuild b/www-client/midori/midori-0.2.9.ebuild
index e37e53839894..3e303259f184 100644
--- a/www-client/midori/midori-0.2.9.ebuild
+++ b/www-client/midori/midori-0.2.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.2.9.ebuild,v 1.2 2010/12/18 18:02:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.2.9.ebuild,v 1.3 2011/01/30 21:19:32 ssuominen Exp $
EAPI=2
inherit pax-utils eutils multilib python xfconf
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~ppc x86 ~x86-fbsd"
IUSE="doc gnome +html idn libnotify nls +unique"
-RDEPEND="libnotify? ( x11-libs/libnotify )
+RDEPEND="libnotify? ( <x11-libs/libnotify-0.7 )
>=net-libs/libsoup-2.25.2
>=net-libs/webkit-gtk-1.1.1
>=dev-db/sqlite-3.0