summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-07-02 19:49:39 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-07-02 19:49:39 +0000
commit53e74256d218c6a22cdc6b19090f3bb592175ad0 (patch)
tree36da9295439c0fc17c5c4ed630723873303766c9 /www-client
parentarm/s390/sh stable (diff)
downloadgentoo-2-53e74256d218c6a22cdc6b19090f3bb592175ad0.tar.gz
gentoo-2-53e74256d218c6a22cdc6b19090f3bb592175ad0.tar.bz2
gentoo-2-53e74256d218c6a22cdc6b19090f3bb592175ad0.zip
migrate to seamonkey. require firefox if you are sparc. cleanup old versions.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany-extensions/ChangeLog14
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-1.8.1-r1.ebuild79
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-2.14.1-r1.ebuild70
-rw-r--r--www-client/epiphany-extensions/files/digest-epiphany-extensions-1.8.1-r13
-rw-r--r--www-client/epiphany-extensions/files/digest-epiphany-extensions-2.14.1-r13
5 files changed, 168 insertions, 1 deletions
diff --git a/www-client/epiphany-extensions/ChangeLog b/www-client/epiphany-extensions/ChangeLog
index 84f14c274b1d..341776649eb5 100644
--- a/www-client/epiphany-extensions/ChangeLog
+++ b/www-client/epiphany-extensions/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for www-client/epiphany-extensions
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.25 2006/05/05 16:17:43 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/ChangeLog,v 1.26 2006/07/02 19:49:39 allanonjl Exp $
+
+*epiphany-extensions-2.14.1-r1 (02 Jul 2006)
+*epiphany-extensions-1.8.1-r1 (02 Jul 2006)
+
+ 02 Jul 2006; John N. Laliberte <allanonjl@gentoo.org>
+ -files/epiphany-extensions-1.6.0-disable_bookmarks-tray_label.patch,
+ -files/epiphany-extensions-1.6.0-fix_includes.patch,
+ -epiphany-extensions-1.6.0.ebuild, -epiphany-extensions-1.6.4-r1.ebuild,
+ +epiphany-extensions-1.8.1-r1.ebuild,
+ -epiphany-extensions-2.14.0.1.ebuild,
+ +epiphany-extensions-2.14.1-r1.ebuild:
+ migrate to seamonkey. require firefox if you are sparc. cleanup old versions.
05 May 2006; John N. Laliberte <allanonjl@gentoo.org>
epiphany-extensions-2.14.1.ebuild:
diff --git a/www-client/epiphany-extensions/epiphany-extensions-1.8.1-r1.ebuild b/www-client/epiphany-extensions/epiphany-extensions-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..72a3c59c5d28
--- /dev/null
+++ b/www-client/epiphany-extensions/epiphany-extensions-1.8.1-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-1.8.1-r1.ebuild,v 1.1 2006/07/02 19:49:39 allanonjl Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Extensions for the Epiphany web browser"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/extensions.html"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="dbus debug firefox pcre python"
+
+RDEPEND=">=www-client/epiphany-1.8.1
+ >=dev-libs/libxml2-2.6
+ >=dev-libs/glib-2.8
+ >=x11-libs/gtk+-2.8
+ >=gnome-base/libglade-2
+ app-text/opensp
+ sparc? ( >=www-client/mozilla-firefox-1.0.2-r1 )
+ !sparc? ( !firefox? ( www-client/seamonkey ) )
+ firefox? ( >=www-client/mozilla-firefox-1.0.2-r1 )
+ pcre? ( dev-libs/libpcre )
+ dbus? ( >=sys-apps/dbus-0.34 )
+ python? ( >=dev-lang/python-2.3 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.29"
+
+USE_DESTDIR="1"
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+
+pkg_setup() {
+ local extensions="actions auto-scroller bookmarks-tray certificates \
+ dashboard error-viewer extensions-manager-ui gestures page-info \
+ sample sample-mozilla select-stylesheet sidebar smart-bookmarks \
+ tab-groups tab-states tabsmenu"
+
+ if use dbus && ! built_with_use www-client/epiphany dbus; then
+ ewarn
+ ewarn "To enable the extensions using dbus you neet to emerge"
+ ewarn "www-client/epiphany with the 'dbus' USE flag enabled as well."
+ ewarn
+ ewarn "Skipping for now."
+ ewarn
+ else
+ use dbus && extensions="${extensions} net-monitor rss"
+ fi
+
+ use pcre && extensions="${extensions} greasemonkey"
+ # adblock causes segmentation faults. See bug #100618.
+
+ use python && extensions="${extensions} python-console sample-python \
+ favicon"
+
+ local list_exts=""
+ for ext in $extensions; do
+ [ "x${list_exts}" != "x" ] && list_exts="${list_exts},"
+ list_exts="${list_exts}${ext}"
+ done
+
+ G2CONF="${G2CONF} --with-extensions=${list_exts}"
+
+ if use firefox || use sparc; then
+ G2CONF="${G2CONF} --with-mozilla=firefox"
+ else
+ G2CONF="${G2CONF} --with-mozilla=seamonkey"
+ fi
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ epatch ${FILESDIR}/${PN}-1.8.0-fix-includes.patch
+}
diff --git a/www-client/epiphany-extensions/epiphany-extensions-2.14.1-r1.ebuild b/www-client/epiphany-extensions/epiphany-extensions-2.14.1-r1.ebuild
new file mode 100644
index 000000000000..59ed73153900
--- /dev/null
+++ b/www-client/epiphany-extensions/epiphany-extensions-2.14.1-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.14.1-r1.ebuild,v 1.1 2006/07/02 19:49:39 allanonjl Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Extensions for the Epiphany web browser"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/extensions.html"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="dbus debug firefox pcre python"
+
+RDEPEND=">=www-client/epiphany-2.14.1
+ >=dev-libs/libxml2-2.6
+ >=dev-libs/glib-2.8
+ >=x11-libs/gtk+-2.8
+ >=gnome-base/libglade-2
+ app-text/opensp
+ sparc? ( >=www-client/mozilla-firefox-1.0.2-r1 )
+ !sparc? ( !firefox? ( www-client/seamonkey ) )
+ firefox? ( >=www-client/mozilla-firefox-1.0.2-r1 )
+ pcre? ( >=dev-libs/libpcre-3.9-r2 )
+ dbus? ( >=sys-apps/dbus-0.34 )
+ python? ( >=dev-lang/python-2.3 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.29"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ local extensions="actions auto-reload auto-scroller certificates \
+ dashboard error-viewer extensions-manager-ui gestures page-info \
+ push-scroller sample sample-mozilla select-stylesheet sidebar smart-bookmarks \
+ tab-groups tab-states tabsmenu"
+
+ if use dbus && ! built_with_use www-client/epiphany dbus; then
+ ewarn
+ ewarn "To enable the extensions using dbus you neet to emerge"
+ ewarn "www-client/epiphany with the 'dbus' USE flag enabled as well."
+ ewarn
+ ewarn "Skipping for now."
+ ewarn
+ else
+ use dbus && extensions="${extensions} rss"
+ fi
+
+ use pcre && extensions="${extensions} greasemonkey adblock"
+
+ use python && extensions="${extensions} python-console sample-python \
+ favicon"
+
+ local list_exts=""
+ for ext in $extensions; do
+ [ "x${list_exts}" != "x" ] && list_exts="${list_exts},"
+ list_exts="${list_exts}${ext}"
+ done
+
+ G2CONF="${G2CONF} --with-extensions=${list_exts}"
+
+ if use firefox || use sparc; then
+ G2CONF="${G2CONF} --with-mozilla=firefox"
+ else
+ G2CONF="${G2CONF} --with-mozilla=seamonkey"
+ fi
+}
+
diff --git a/www-client/epiphany-extensions/files/digest-epiphany-extensions-1.8.1-r1 b/www-client/epiphany-extensions/files/digest-epiphany-extensions-1.8.1-r1
new file mode 100644
index 000000000000..83b8fe671ac5
--- /dev/null
+++ b/www-client/epiphany-extensions/files/digest-epiphany-extensions-1.8.1-r1
@@ -0,0 +1,3 @@
+MD5 d1c40978c89a845973ed131774fa7769 epiphany-extensions-1.8.1.tar.bz2 611775
+RMD160 b43695aab32a7cc60d16a590e3679ec7b5956afb epiphany-extensions-1.8.1.tar.bz2 611775
+SHA256 16cf575b8567cb86f311963273071b03380fe753ba95233a996c973d7c11769e epiphany-extensions-1.8.1.tar.bz2 611775
diff --git a/www-client/epiphany-extensions/files/digest-epiphany-extensions-2.14.1-r1 b/www-client/epiphany-extensions/files/digest-epiphany-extensions-2.14.1-r1
new file mode 100644
index 000000000000..6444d2e35af5
--- /dev/null
+++ b/www-client/epiphany-extensions/files/digest-epiphany-extensions-2.14.1-r1
@@ -0,0 +1,3 @@
+MD5 8be9c522284b0a9d7ba2797e141cf26e epiphany-extensions-2.14.1.tar.bz2 820099
+RMD160 e8668970d0ea94957e8547dea9474919a3bca7db epiphany-extensions-2.14.1.tar.bz2 820099
+SHA256 6b97e1160203869741c57c6720b2d1e5d16ad104b83d0391f73169542e72305c epiphany-extensions-2.14.1.tar.bz2 820099