summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-06-17 13:42:44 +0000
committerJim Ramsay <lack@gentoo.org>2010-06-17 13:42:44 +0000
commita1f0a0af5ee4ffdeee79ef33f94135445642edb0 (patch)
treedb65c9204eb5be23311e8fb20f61fd4cbf0e1183 /www-plugins/adobe-flash/adobe-flash-9.0.277.0.ebuild
parenteapi bump (diff)
downloadgentoo-2-a1f0a0af5ee4ffdeee79ef33f94135445642edb0.tar.gz
gentoo-2-a1f0a0af5ee4ffdeee79ef33f94135445642edb0.tar.bz2
gentoo-2-a1f0a0af5ee4ffdeee79ef33f94135445642edb0.zip
Version 9 was also bumped (Bug #254011)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/adobe-flash/adobe-flash-9.0.277.0.ebuild')
-rw-r--r--www-plugins/adobe-flash/adobe-flash-9.0.277.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/www-plugins/adobe-flash/adobe-flash-9.0.277.0.ebuild b/www-plugins/adobe-flash/adobe-flash-9.0.277.0.ebuild
new file mode 100644
index 000000000000..4da81a8c0ba0
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-9.0.277.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-9.0.277.0.ebuild,v 1.1 2010/06/17 13:42:44 lack Exp $
+
+inherit nsplugins
+
+DESCRIPTION="Adobe Flash Player"
+SRC_URI="http://download.macromedia.com/pub/flashplayer/installers/current/9/install_flash_player_9.tar.gz"
+HOMEPAGE="http://www.adobe.com/go/kb406791"
+IUSE=""
+SLOT="0"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-9.0.31.0"
+RESTRICT="strip mirror"
+
+S=${WORKDIR}
+
+RDEPEND="amd64? ( app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-gtklibs
+ app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-xlibs )
+ x86? ( x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXt
+ =x11-libs/gtk+-2*
+ media-libs/freetype
+ media-libs/fontconfig )
+ || ( media-fonts/liberation-fonts media-fonts/corefonts )"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ cd "${S}/install_flash_player_9_linux/"
+ exeinto /opt/netscape/plugins
+ doexe libflashplayer.so
+ inst_plugin /opt/netscape/plugins/libflashplayer.so
+}
+
+pkg_postinst() {
+ ewarn "Flash player is closed-source, with a long history of security"
+ ewarn "issues. Please consider only running flash applets you know to"
+ ewarn "be safe."
+
+ if has_version 'www-client/mozilla-firefox'; then
+ elog "The firefox 'flashblock' extension may help:"
+ elog " https://addons.mozilla.org/en-US/firefox/addon/433"
+ fi
+}