summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-12-04 21:57:10 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-12-04 21:57:10 +0000
commit21eb3cbab57e88f40904b79026c7c6cddb3353e7 (patch)
tree05958ab00a5500008dcccab90b16e48f0ced28e5 /www-plugins/lightspark
parentversion bump; fixes some bugs, heuristics have saner defaults, mask handling ... (diff)
downloadgentoo-2-21eb3cbab57e88f40904b79026c7c6cddb3353e7.tar.gz
gentoo-2-21eb3cbab57e88f40904b79026c7c6cddb3353e7.tar.bz2
gentoo-2-21eb3cbab57e88f40904b79026c7c6cddb3353e7.zip
Restore patch that was accidentally dropped, bug #445740.
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'www-plugins/lightspark')
-rw-r--r--www-plugins/lightspark/ChangeLog6
-rw-r--r--www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0001.patch38
2 files changed, 43 insertions, 1 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index b85aeecf8841..02cb8402e3ac 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.47 2012/11/18 13:43:34 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.48 2012/12/04 21:57:10 chithanh Exp $
+
+ 04 Dec 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/lightspark-0.6.0.1-gcc-4.5_0001.patch:
+ Restore patch that was accidentally dropped, bug #445740.
18 Nov 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+files/lightspark-0.7.0-libxmlpp-gles.patch, lightspark-0.7.0.ebuild:
diff --git a/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0001.patch b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0001.patch
new file mode 100644
index 000000000000..7d409b5bfe6f
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0001.patch
@@ -0,0 +1,38 @@
+From 83f57ba569eab78581b3a682edca70592b2b2577 Mon Sep 17 00:00:00 2001
+From: Alessandro Pignotti <a.pignotti@sssup.it>
+Date: Sun, 10 Jun 2012 19:32:22 +0200
+Subject: [PATCH] Restore NullRef instead of std::nullptr_t
+
+std::nullptr is ambiguos since it's acceptable also as Ref constructor
+
+This reverts commit 3d243ec18be069b27774b5cef10305b48156fc1c.
+---
+ src/smartrefs.h | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/src/smartrefs.h b/src/smartrefs.h
+index d7f51bd..5087b2f 100644
+--- a/src/smartrefs.h
++++ b/src/smartrefs.h
+@@ -119,15 +119,14 @@ class Ref
+ return Ref<T>(a);
+ }
+
+-#if defined(__GNUC__) && (__GNUC__ == 4 && __GNUC_MINOR__ < 6)
++//#if defined(__GNUC__) && (__GNUC__ == 4 && __GNUC_MINOR__ < 6)
+ /* Fallback for gcc < 4.6 not supporting nullptr */
+ class NullRef_t {};
+ extern NullRef_t NullRef;
+-#else
+-/* This is needed for MSVC and can be used on gcc >= 4.6 */
++/*#else
+ typedef std::nullptr_t NullRef_t;
+ #define NullRef (nullptr)
+-#endif
++#endif*/
+
+ template<class T>
+ class NullableRef
+--
+1.7.10
+