summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-03 13:31:33 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-03 13:31:33 +0000
commit3f6565b80b00e09265dcd559df104a8f826d302c (patch)
tree90cdca1148760d4fa410d9aec8f7a1e8e3440c4b /www-plugins/lightspark
parentRestore -r1 and drop -r2 as it caused annoying problems (diff)
downloadgentoo-2-3f6565b80b00e09265dcd559df104a8f826d302c.tar.gz
gentoo-2-3f6565b80b00e09265dcd559df104a8f826d302c.tar.bz2
gentoo-2-3f6565b80b00e09265dcd559df104a8f826d302c.zip
Fix building with llvm-3.1, reported by maksbotan.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/lightspark')
-rw-r--r--www-plugins/lightspark/ChangeLog8
-rw-r--r--www-plugins/lightspark/files/lightspark-0.5.7-llvm-3.1_0000.patch87
-rw-r--r--www-plugins/lightspark/files/lightspark-0.5.7-llvm-3.1_0001.patch30
-rw-r--r--www-plugins/lightspark/files/lightspark-0.5.7-llvm-3.1_0002.patch33
-rw-r--r--www-plugins/lightspark/lightspark-0.5.7.ebuild8
5 files changed, 164 insertions, 2 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 07ad723344de..5a6cbd2a9bf5 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.42 2012/05/18 01:11:22 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.43 2012/06/03 13:31:33 chithanh Exp $
+
+ 03 Jun 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/lightspark-0.5.7-llvm-3.1_0000.patch,
+ +files/lightspark-0.5.7-llvm-3.1_0001.patch,
+ +files/lightspark-0.5.7-llvm-3.1_0002.patch, lightspark-0.5.7.ebuild:
+ Fix building with llvm-3.1, reported by maksbotan.
*lightspark-0.5.7 (18 May 2012)
diff --git a/www-plugins/lightspark/files/lightspark-0.5.7-llvm-3.1_0000.patch b/www-plugins/lightspark/files/lightspark-0.5.7-llvm-3.1_0000.patch
new file mode 100644
index 000000000000..292ace7f6497
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.5.7-llvm-3.1_0000.patch
@@ -0,0 +1,87 @@
+From eaed71005f8cfc1a421790ea2def20882e7d25c3 Mon Sep 17 00:00:00 2001
+From: Alessandro Pignotti <a.pignotti@sssup.it>
+Date: Mon, 21 May 2012 13:05:36 +0200
+Subject: [PATCH] Add support for LLVM 3.1
+
+---
+ CMakeLists.txt | 9 ++++++---
+ src/scripting/abc.cpp | 14 +++++++++++++-
+ src/scripting/abc.h | 2 +-
+ 3 files changed, 20 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index be30cb1..6de575b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -229,9 +229,12 @@ ENDIF(${LLVM_STRING_VERSION} VERSION_EQUAL 2.9)
+ IF(${LLVM_STRING_VERSION} VERSION_EQUAL 2.8)
+ ADD_DEFINITIONS(-DLLVM_28)
+ ENDIF(${LLVM_STRING_VERSION} VERSION_EQUAL 2.8)
+-IF(${LLVM_STRING_VERSION} VERSION_GREATER 2.9)
+- ADD_DEFINITIONS(-DLLVM_3)
+-ENDIF(${LLVM_STRING_VERSION} VERSION_GREATER 2.9)
++IF(${LLVM_STRING_VERSION} VERSION_EQUAL 3.0)
++ ADD_DEFINITIONS(-DLLVM_30)
++ENDIF(${LLVM_STRING_VERSION} VERSION_EQUAL 3.0)
++IF(${LLVM_STRING_VERSION} VERSION_GREATER 3.0)
++ ADD_DEFINITIONS(-DLLVM_31)
++ENDIF(${LLVM_STRING_VERSION} VERSION_GREATER 3.0)
+ INCLUDE(FindZLIB REQUIRED)
+ INCLUDE(FindFreetype REQUIRED)
+ IF(NOT(ENABLE_GLES2))
+diff --git a/src/scripting/abc.cpp b/src/scripting/abc.cpp
+index 59700f6..e1d2834 100644
+--- a/src/scripting/abc.cpp
++++ b/src/scripting/abc.cpp
+@@ -23,7 +23,7 @@
+ #include <llvm/ExecutionEngine/JIT.h>
+ #include <llvm/LLVMContext.h>
+ #include <llvm/Target/TargetData.h>
+-#ifdef LLVM_3
++#ifdef LLVM_30
+ #include <llvm/Support/TargetSelect.h>
+ #else
+ #include <llvm/Target/TargetSelect.h>
+@@ -1442,14 +1442,26 @@ void ABCVm::Run(ABCVm* th)
+
+ if(th->m_sys->useJit)
+ {
++#ifdef LLVM_31
++ llvm::TargetOptions Opts;
++ Opts.JITExceptionHandling = true;
++#else
+ llvm::JITExceptionHandling = true;
++#endif
+ #ifndef NDEBUG
++#ifdef LLVM_31
++ Opts.JITEmitDebugInfo = true;
++#else
+ llvm::JITEmitDebugInfo = true;
+ #endif
++#endif
+ llvm::InitializeNativeTarget();
+ th->module=new llvm::Module(llvm::StringRef("abc jit"),th->llvm_context);
+ llvm::EngineBuilder eb(th->module);
+ eb.setEngineKind(llvm::EngineKind::JIT);
++#ifdef LLVM_31
++ eb.setTargetOptions(Opts);
++#endif
+ eb.setOptLevel(llvm::CodeGenOpt::Default);
+ th->ex=eb.create();
+ assert_and_throw(th->ex);
+diff --git a/src/scripting/abc.h b/src/scripting/abc.h
+index f56a2a7..d3adfeb 100644
+--- a/src/scripting/abc.h
++++ b/src/scripting/abc.h
+@@ -23,7 +23,7 @@
+ #ifdef LLVM_28
+ #define alignof alignOf
+ #endif
+-#ifdef LLVM_3
++#ifdef LLVM_30
+ #define LLVMTYPE llvm::Type*
+ #define LLVMMAKEARRAYREF(T) makeArrayRef(T)
+ #else
+--
+1.7.10
+
diff --git a/www-plugins/lightspark/files/lightspark-0.5.7-llvm-3.1_0001.patch b/www-plugins/lightspark/files/lightspark-0.5.7-llvm-3.1_0001.patch
new file mode 100644
index 000000000000..6b778c089e34
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.5.7-llvm-3.1_0001.patch
@@ -0,0 +1,30 @@
+From 1d9004f0cc14bff0a4f35590fa94e51c4723174d Mon Sep 17 00:00:00 2001
+From: Alessandro Pignotti <a.pignotti@sssup.it>
+Date: Sun, 27 May 2012 16:15:07 +0200
+Subject: [PATCH] Fix support for LLVM 3.1
+
+---
+ src/scripting/abc.cpp | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/scripting/abc.cpp b/src/scripting/abc.cpp
+index 5fdae55..de7e0f3 100644
+--- a/src/scripting/abc.cpp
++++ b/src/scripting/abc.cpp
+@@ -23,10 +23,10 @@
+ #include <llvm/ExecutionEngine/JIT.h>
+ #include <llvm/LLVMContext.h>
+ #include <llvm/Target/TargetData.h>
+-#ifdef LLVM_30
+-#include <llvm/Support/TargetSelect.h>
+-#else
++#ifdef LLVM_28
+ #include <llvm/Target/TargetSelect.h>
++#else
++#include <llvm/Support/TargetSelect.h>
+ #endif
+ #include <llvm/Target/TargetOptions.h>
+ #include <llvm/Analysis/Verifier.h>
+--
+1.7.10
+
diff --git a/www-plugins/lightspark/files/lightspark-0.5.7-llvm-3.1_0002.patch b/www-plugins/lightspark/files/lightspark-0.5.7-llvm-3.1_0002.patch
new file mode 100644
index 000000000000..5fd6348b2b23
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.5.7-llvm-3.1_0002.patch
@@ -0,0 +1,33 @@
+From 8381e86216b4cf23102cee566104cd38e5fb9208 Mon Sep 17 00:00:00 2001
+From: alex <devkral@web.de>
+Date: Sun, 27 May 2012 17:24:37 +0200
+Subject: [PATCH] fix second compile bug with llvm 3.1
+
+---
+ src/scripting/abc.h | 8 +++-----
+ 1 file changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/src/scripting/abc.h b/src/scripting/abc.h
+index 8ec3e8c..c8839cf 100644
+--- a/src/scripting/abc.h
++++ b/src/scripting/abc.h
+@@ -22,13 +22,11 @@
+
+ #ifdef LLVM_28
+ #define alignof alignOf
+-#endif
+-#ifdef LLVM_30
+-#define LLVMTYPE llvm::Type*
+-#define LLVMMAKEARRAYREF(T) makeArrayRef(T)
+-#else
+ #define LLVMTYPE const llvm::Type*
+ #define LLVMMAKEARRAYREF(T) T
++#else
++#define LLVMTYPE llvm::Type*
++#define LLVMMAKEARRAYREF(T) makeArrayRef(T)
+ #endif
+
+ #include "compat.h"
+--
+1.7.10
+
diff --git a/www-plugins/lightspark/lightspark-0.5.7.ebuild b/www-plugins/lightspark/lightspark-0.5.7.ebuild
index af72db7daf9d..bffb1ed5aab4 100644
--- a/www-plugins/lightspark/lightspark-0.5.7.ebuild
+++ b/www-plugins/lightspark/lightspark-0.5.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.5.7.ebuild,v 1.1 2012/05/18 01:11:22 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.5.7.ebuild,v 1.2 2012/06/03 13:31:33 chithanh Exp $
EAPI=4
inherit cmake-utils nsplugins multilib versionator
@@ -48,6 +48,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P/_rc*/}
+PATCHES=(
+ "${FILESDIR}"/${P}-llvm-3.1_0000.patch
+ "${FILESDIR}"/${P}-llvm-3.1_0001.patch
+ "${FILESDIR}"/${P}-llvm-3.1_0002.patch
+)
+
src_configure() {
local audiobackends
use pulseaudio && audiobackends+="pulse"