summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-11 21:28:15 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-11 21:28:15 +0000
commit059082be8b9e553b750ad809b16e2feae439fd59 (patch)
tree159740c2c345b69719f858302c916e796b07d2ab /www-plugins
parentbump to 0.1.10 (diff)
downloadgentoo-2-059082be8b9e553b750ad809b16e2feae439fd59.tar.gz
gentoo-2-059082be8b9e553b750ad809b16e2feae439fd59.tar.bz2
gentoo-2-059082be8b9e553b750ad809b16e2feae439fd59.zip
Version bump.
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/lightspark/ChangeLog15
-rw-r--r--www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0000.patch28
-rw-r--r--www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0001.patch38
-rw-r--r--www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0002.patch57
-rw-r--r--www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0003.patch42
-rw-r--r--www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0004.patch60
-rw-r--r--www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0005.patch32
-rw-r--r--www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0006.patch25
-rw-r--r--www-plugins/lightspark/lightspark-0.6.0.1.ebuild109
-rw-r--r--www-plugins/lightspark/metadata.xml1
10 files changed, 406 insertions, 1 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 5a6cbd2a9bf5..8cb60f189910 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.43 2012/06/03 13:31:33 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.44 2012/06/11 21:28:15 chithanh Exp $
+
+*lightspark-0.6.0.1 (11 Jun 2012)
+
+ 11 Jun 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/lightspark-0.6.0.1-gcc-4.5_0000.patch,
+ +files/lightspark-0.6.0.1-gcc-4.5_0001.patch,
+ +files/lightspark-0.6.0.1-gcc-4.5_0002.patch,
+ +files/lightspark-0.6.0.1-gcc-4.5_0003.patch,
+ +files/lightspark-0.6.0.1-gcc-4.5_0004.patch,
+ +files/lightspark-0.6.0.1-gcc-4.5_0005.patch,
+ +files/lightspark-0.6.0.1-gcc-4.5_0006.patch, +lightspark-0.6.0.1.ebuild,
+ metadata.xml:
+ Version bump.
03 Jun 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+files/lightspark-0.5.7-llvm-3.1_0000.patch,
diff --git a/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0000.patch b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0000.patch
new file mode 100644
index 000000000000..be2e1ae813b3
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0000.patch
@@ -0,0 +1,28 @@
+From ef5b6b87f200a3cdf1cd9fd936724677e70c568d Mon Sep 17 00:00:00 2001
+From: Alessandro Pignotti <a.pignotti@sssup.it>
+Date: Sun, 10 Jun 2012 18:57:48 +0200
+Subject: [PATCH] [Build] Avoid new for each syntax to keep GCC 4.5
+ compatibility
+
+---
+ src/swf.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/swf.cpp b/src/swf.cpp
+index b735081..8501407 100644
+--- a/src/swf.cpp
++++ b/src/swf.cpp
+@@ -83,8 +83,8 @@ ParseThread* lightspark::getParseThread()
+
+ RootMovieClip::~RootMovieClip()
+ {
+- for(DictionaryTag* it: dictionary)
+- delete it;
++ for(auto it=dictionary.begin();it!=dictionary.end();++it)
++ delete *it;
+ }
+
+ void RootMovieClip::parsingFailed()
+--
+1.7.10
+
diff --git a/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0001.patch b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0001.patch
new file mode 100644
index 000000000000..7d409b5bfe6f
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0001.patch
@@ -0,0 +1,38 @@
+From 83f57ba569eab78581b3a682edca70592b2b2577 Mon Sep 17 00:00:00 2001
+From: Alessandro Pignotti <a.pignotti@sssup.it>
+Date: Sun, 10 Jun 2012 19:32:22 +0200
+Subject: [PATCH] Restore NullRef instead of std::nullptr_t
+
+std::nullptr is ambiguos since it's acceptable also as Ref constructor
+
+This reverts commit 3d243ec18be069b27774b5cef10305b48156fc1c.
+---
+ src/smartrefs.h | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/src/smartrefs.h b/src/smartrefs.h
+index d7f51bd..5087b2f 100644
+--- a/src/smartrefs.h
++++ b/src/smartrefs.h
+@@ -119,15 +119,14 @@ class Ref
+ return Ref<T>(a);
+ }
+
+-#if defined(__GNUC__) && (__GNUC__ == 4 && __GNUC_MINOR__ < 6)
++//#if defined(__GNUC__) && (__GNUC__ == 4 && __GNUC_MINOR__ < 6)
+ /* Fallback for gcc < 4.6 not supporting nullptr */
+ class NullRef_t {};
+ extern NullRef_t NullRef;
+-#else
+-/* This is needed for MSVC and can be used on gcc >= 4.6 */
++/*#else
+ typedef std::nullptr_t NullRef_t;
+ #define NullRef (nullptr)
+-#endif
++#endif*/
+
+ template<class T>
+ class NullableRef
+--
+1.7.10
+
diff --git a/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0002.patch b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0002.patch
new file mode 100644
index 000000000000..dc7d165161f6
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0002.patch
@@ -0,0 +1,57 @@
+From ea52ebb26e6b3923c6ac9b7492e67cfcc9039d4b Mon Sep 17 00:00:00 2001
+From: Alessandro Pignotti <a.pignotti@sssup.it>
+Date: Sun, 10 Jun 2012 19:35:49 +0200
+Subject: [PATCH] Restore NullRef instead of std::nullptr_t
+
+std::nullptr is ambiguos since it's acceptable also as Ref constructor
+
+This reverts commit 95fc48d50e8ae28a43585d9aa4d275ec84e4a4cf.
+---
+ src/scripting/abc.cpp | 2 +-
+ src/smartrefs.h | 9 +--------
+ 2 files changed, 2 insertions(+), 9 deletions(-)
+
+diff --git a/src/scripting/abc.cpp b/src/scripting/abc.cpp
+index 0bad425..8110666 100644
+--- a/src/scripting/abc.cpp
++++ b/src/scripting/abc.cpp
+@@ -170,7 +170,7 @@ void ScriptLimitsTag::execute(RootMovieClip* root) const
+
+ void ABCVm::registerClasses()
+ {
+- Global* builtin=Class<Global>::getInstanceS((ABCContext*)0, 0);
++ Global* builtin=Class<Global>::getInstanceS(nullptr, 0);
+ //Register predefined types, ASObject are enough for not implemented classes
+ builtin->registerBuiltin("Object","",Class<ASObject>::getRef());
+ builtin->registerBuiltin("Class","",Class_object::getRef());
+diff --git a/src/smartrefs.h b/src/smartrefs.h
+index 5087b2f..09ce760 100644
+--- a/src/smartrefs.h
++++ b/src/smartrefs.h
+@@ -119,14 +119,7 @@ class Ref
+ return Ref<T>(a);
+ }
+
+-//#if defined(__GNUC__) && (__GNUC__ == 4 && __GNUC_MINOR__ < 6)
+-/* Fallback for gcc < 4.6 not supporting nullptr */
+-class NullRef_t {};
+-extern NullRef_t NullRef;
+-/*#else
+-typedef std::nullptr_t NullRef_t;
+ #define NullRef (nullptr)
+-#endif*/
+
+ template<class T>
+ class NullableRef
+@@ -136,7 +129,7 @@ class NullableRef
+ public:
+ NullableRef(): m(NULL) {}
+ explicit NullableRef(T* o):m(o){}
+- NullableRef(NullRef_t):m(NULL){}
++ NullableRef(std::nullptr_t):m(NULL){}
+ NullableRef(const NullableRef& r):m(r.m)
+ {
+ if(m)
+--
+1.7.10
+
diff --git a/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0003.patch b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0003.patch
new file mode 100644
index 000000000000..9b3087e91284
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0003.patch
@@ -0,0 +1,42 @@
+From bc81ca2f4330d2a287289317837b7ad8058cb591 Mon Sep 17 00:00:00 2001
+From: Alessandro Pignotti <a.pignotti@sssup.it>
+Date: Sun, 10 Jun 2012 19:54:54 +0200
+Subject: [PATCH] [BitmapContainer] Add ::reset
+
+---
+ src/scripting/flash/display/BitmapContainer.cpp | 9 +++++++++
+ src/scripting/flash/display/BitmapContainer.h | 1 +
+ 2 files changed, 10 insertions(+)
+
+diff --git a/src/scripting/flash/display/BitmapContainer.cpp b/src/scripting/flash/display/BitmapContainer.cpp
+index fa480a0..e057db2 100644
+--- a/src/scripting/flash/display/BitmapContainer.cpp
++++ b/src/scripting/flash/display/BitmapContainer.cpp
+@@ -80,3 +80,12 @@ bool BitmapContainer::fromPNG(std::istream &s)
+ return fromRGB(rgb, (int32_t)w, (int32_t)h, false);
+ }
+
++void BitmapContainer::reset()
++{
++ data.clear();
++ data.shrink_to_fit();
++ stride=0;
++ dataSize=0;
++ width=0;
++ height=0;
++}
+diff --git a/src/scripting/flash/display/BitmapContainer.h b/src/scripting/flash/display/BitmapContainer.h
+index fb0912d..69a363d 100644
+--- a/src/scripting/flash/display/BitmapContainer.h
++++ b/src/scripting/flash/display/BitmapContainer.h
+@@ -45,6 +45,7 @@ class BitmapContainer
+ bool fromPNG(std::istream& s);
+ int getWidth() const { return width; }
+ int getHeight() const { return height; }
++ void reset();
+ };
+
+ };
+--
+1.7.10
+
diff --git a/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0004.patch b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0004.patch
new file mode 100644
index 000000000000..65d21d3ad934
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0004.patch
@@ -0,0 +1,60 @@
+From eded7abeb7d70a5d8dd7454c64812c49721a96d6 Mon Sep 17 00:00:00 2001
+From: Alessandro Pignotti <a.pignotti@sssup.it>
+Date: Sun, 10 Jun 2012 19:55:17 +0200
+Subject: [PATCH] Reintroduce NullRef and add comparison operators against it
+
+---
+ src/smartrefs.h | 16 ++++++++++++++--
+ 1 file changed, 14 insertions(+), 2 deletions(-)
+
+diff --git a/src/smartrefs.h b/src/smartrefs.h
+index 09ce760..85b7e06 100644
+--- a/src/smartrefs.h
++++ b/src/smartrefs.h
+@@ -119,7 +119,11 @@ class Ref
+ return Ref<T>(a);
+ }
+
+-#define NullRef (nullptr)
++class NullRef_t
++{
++};
++
++extern NullRef_t NullRef;
+
+ template<class T>
+ class NullableRef
+@@ -129,7 +133,7 @@ class NullableRef
+ public:
+ NullableRef(): m(NULL) {}
+ explicit NullableRef(T* o):m(o){}
+- NullableRef(std::nullptr_t):m(NULL){}
++ NullableRef(NullRef_t):m(NULL){}
+ NullableRef(const NullableRef& r):m(r.m)
+ {
+ if(m)
+@@ -187,6 +191,10 @@ class NullableRef
+ {
+ return m==r;
+ }
++ bool operator==(NullRef_t) const
++ {
++ return m==NULL;
++ }
+ template<class D> bool operator!=(const NullableRef<D>& r) const
+ {
+ return m!=r.getPtr();
+@@ -199,6 +207,10 @@ class NullableRef
+ {
+ return m!=r;
+ }
++ bool operator!=(NullRef_t) const
++ {
++ return m!=NULL;
++ }
+ /*explicit*/ operator bool() const
+ {
+ return m != NULL;
+--
+1.7.10
+
diff --git a/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0005.patch b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0005.patch
new file mode 100644
index 000000000000..4dcbf51baa4d
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0005.patch
@@ -0,0 +1,32 @@
+From 631cb37ae66c0150a148a29df7a3c3e26dc03fb4 Mon Sep 17 00:00:00 2001
+From: Alessandro Pignotti <a.pignotti@sssup.it>
+Date: Sun, 10 Jun 2012 19:55:40 +0200
+Subject: [PATCH] Fix a couple of stale reference assignment
+
+---
+ src/swftypes.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/swftypes.cpp b/src/swftypes.cpp
+index 69de488..a2d05e9 100644
+--- a/src/swftypes.cpp
++++ b/src/swftypes.cpp
+@@ -761,13 +761,13 @@ inline RGBA medianColor(const RGBA& a, const RGBA& b, float factor)
+ {
+ //Thrown if the bitmapId does not exists in dictionary
+ LOG(LOG_ERROR,"Exception in FillStyle parsing: " << e.what());
+- v.bitmap=NullRef;
++ v.bitmap.reset();
+ }
+ }
+ else
+ {
+ //The bitmap might be invalid, the style should not be used
+- v.bitmap=NullRef;
++ v.bitmap.reset();
+ }
+ }
+ else
+--
+1.7.10
+
diff --git a/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0006.patch b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0006.patch
new file mode 100644
index 000000000000..47ee6fb7f5d8
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.6.0.1-gcc-4.5_0006.patch
@@ -0,0 +1,25 @@
+From 2f54ea1ee730c8bb250d360949badb500d4e1687 Mon Sep 17 00:00:00 2001
+From: Alessandro Pignotti <a.pignotti@sssup.it>
+Date: Sun, 10 Jun 2012 20:20:01 +0200
+Subject: [PATCH] Do not use nullptr for compatibility with GCC 4.5
+
+---
+ src/scripting/abc.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/scripting/abc.cpp b/src/scripting/abc.cpp
+index 8110666..8c71a07 100644
+--- a/src/scripting/abc.cpp
++++ b/src/scripting/abc.cpp
+@@ -170,7 +170,7 @@ void ScriptLimitsTag::execute(RootMovieClip* root) const
+
+ void ABCVm::registerClasses()
+ {
+- Global* builtin=Class<Global>::getInstanceS(nullptr, 0);
++ Global* builtin=Class<Global>::getInstanceS((ABCContext*)NULL, 0);
+ //Register predefined types, ASObject are enough for not implemented classes
+ builtin->registerBuiltin("Object","",Class<ASObject>::getRef());
+ builtin->registerBuiltin("Class","",Class_object::getRef());
+--
+1.7.10
+
diff --git a/www-plugins/lightspark/lightspark-0.6.0.1.ebuild b/www-plugins/lightspark/lightspark-0.6.0.1.ebuild
new file mode 100644
index 000000000000..9c93dda057fc
--- /dev/null
+++ b/www-plugins/lightspark/lightspark-0.6.0.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.6.0.1.ebuild,v 1.1 2012/06/11 21:28:15 chithanh Exp $
+
+EAPI=4
+inherit cmake-utils nsplugins multilib
+
+DESCRIPTION="High performance flash player"
+HOMEPAGE="http://lightspark.sourceforge.net/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${P}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl ffmpeg gles nsplugin profile pulseaudio rtmp sdl"
+
+RDEPEND=">=dev-cpp/libxmlpp-2.33.1:2.6
+ >=dev-libs/boost-1.42
+ dev-libs/libpcre[cxx]
+ media-fonts/liberation-fonts
+ media-libs/libsdl
+ >=sys-devel/gcc-4.4
+ || (
+ >=sys-devel/llvm-3
+ =sys-devel/llvm-2.8*
+ )
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ curl? (
+ net-misc/curl
+ )
+ ffmpeg? (
+ virtual/ffmpeg
+ )
+ !gles? (
+ >=media-libs/glew-1.5.3
+ virtual/opengl
+ )
+ gles? (
+ media-libs/mesa[gles2]
+ )
+ pulseaudio? (
+ media-sound/pulseaudio
+ )
+ rtmp? (
+ media-video/rtmpdump
+ )"
+DEPEND="${RDEPEND}
+ amd64? ( dev-lang/nasm )
+ x86? ( dev-lang/nasm )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P/_rc*/}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-4.5_0000.patch
+ "${FILESDIR}"/${P}-gcc-4.5_0001.patch
+ "${FILESDIR}"/${P}-gcc-4.5_0002.patch
+ "${FILESDIR}"/${P}-gcc-4.5_0003.patch
+ "${FILESDIR}"/${P}-gcc-4.5_0004.patch
+ "${FILESDIR}"/${P}-gcc-4.5_0005.patch
+ "${FILESDIR}"/${P}-gcc-4.5_0006.patch
+)
+
+src_configure() {
+ local audiobackends
+ use pulseaudio && audiobackends+="pulse"
+ use sdl && audiobackends+="sdl"
+
+ local mycmakeargs=(
+ $(cmake-utils_use curl ENABLE_CURL)
+ $(cmake-utils_use gles ENABLE_GLES2)
+ $(cmake-utils_use ffmpeg ENABLE_LIBAVCODEC)
+ $(cmake-utils_use nsplugin COMPILE_PLUGIN)
+ $(cmake-utils_use profile ENABLE_MEMORY_USAGE_PROFILING)
+ $(cmake-utils_use profile ENABLE_PROFILING)
+ $(cmake-utils_use rtmp ENABLE_RTMP)
+ -DAUDIO_BACKEND="${audiobackends}"
+ -DPLUGIN_DIRECTORY="${EPREFIX}"/usr/$(get_libdir)/${PN}/plugins
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use nsplugin && inst_plugin /usr/$(get_libdir)/${PN}/plugins/liblightsparkplugin.so
+
+ # default to sdl audio if pulseaudio plugin is not built, bug #406197
+ if use sdl && ! use pulseaudio; then
+ sed -i 's/backend = pulseaudio/backend = sdl/' "${ED}/etc/xdg/${PN}.conf" || die
+ fi
+}
+
+pkg_postinst() {
+ if use nsplugin && ! has_version www-plugins/gnash; then
+ elog "Lightspark now supports gnash fallback for its browser plugin."
+ elog "Install www-plugins/gnash to take advantage of it."
+ fi
+ if use nsplugin && has_version www-plugins/gnash[nsplugin]; then
+ elog "Having two plugins installed for the same MIME type may confuse"
+ elog "Mozilla based browsers. It is recommended to disable the nsplugin"
+ elog "USE flag for either gnash or lightspark. For details, see"
+ elog "https://bugzilla.mozilla.org/show_bug.cgi?id=581848"
+ fi
+}
diff --git a/www-plugins/lightspark/metadata.xml b/www-plugins/lightspark/metadata.xml
index fe1d55fe14e2..28a2c322df9f 100644
--- a/www-plugins/lightspark/metadata.xml
+++ b/www-plugins/lightspark/metadata.xml
@@ -6,6 +6,7 @@
<name>Chí-Thanh Christopher Nguyễn</name>
</maintainer>
<use>
+ <flag name='gles'>Replace default OpenGL renderer with GLESv2</flag>
<flag name='rtmp'>Enable Real Time Messaging Protocol using librtmp</flag>
</use>
</pkgmetadata>