summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-02 11:01:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-02 11:01:42 +0000
commit85a45f817987c51a45186e3de2fc3078738712c4 (patch)
treee64f7a0d228656a2f22b94c14e1a2f7a499a2694 /www-plugins
parentamd64/x86 stable, bug #198632. Drop old. (diff)
downloadgentoo-2-85a45f817987c51a45186e3de2fc3078738712c4.tar.gz
gentoo-2-85a45f817987c51a45186e3de2fc3078738712c4.tar.bz2
gentoo-2-85a45f817987c51a45186e3de2fc3078738712c4.zip
Fix building with libpng14 wrt #326599 by Serhij S. Stasyuk.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/gnash/ChangeLog6
-rw-r--r--www-plugins/gnash/files/gnash-0.8.x-libpng14.patch11
-rw-r--r--www-plugins/gnash/gnash-0.8.5.ebuild4
-rw-r--r--www-plugins/gnash/gnash-0.8.6.ebuild4
4 files changed, 22 insertions, 3 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index 237d2bb3ea60..9dcaaff45866 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.28 2010/06/27 12:52:11 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.29 2010/07/02 11:01:42 ssuominen Exp $
+
+ 02 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +files/gnash-0.8.x-libpng14.patch, gnash-0.8.5.ebuild, gnash-0.8.6.ebuild:
+ Fix building with libpng14 wrt #326599 by Serhij S. Stasyuk.
27 Jun 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
gnash-0.8.7.ebuild:
diff --git a/www-plugins/gnash/files/gnash-0.8.x-libpng14.patch b/www-plugins/gnash/files/gnash-0.8.x-libpng14.patch
new file mode 100644
index 000000000000..63668da2b3fc
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.x-libpng14.patch
@@ -0,0 +1,11 @@
+--- libbase/GnashImagePng.cpp
++++ libbase/GnashImagePng.cpp
+@@ -164,7 +164,7 @@
+ if (type == PNG_COLOR_TYPE_GRAY && bitDepth < 8)
+ {
+ log_debug("Setting grey bit depth(%d) to 8", bitDepth);
+- png_set_gray_1_2_4_to_8(_pngPtr);
++ png_set_expand_gray_1_2_4_to_8(_pngPtr);
+ }
+
+ // Apply the transparency block if it exists.
diff --git a/www-plugins/gnash/gnash-0.8.5.ebuild b/www-plugins/gnash/gnash-0.8.5.ebuild
index 6cb0a33e8d6e..e00bd101e824 100644
--- a/www-plugins/gnash/gnash-0.8.5.ebuild
+++ b/www-plugins/gnash/gnash-0.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.5.ebuild,v 1.12 2010/05/01 00:58:17 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.5.ebuild,v 1.13 2010/07/02 11:01:42 ssuominen Exp $
EAPI="2"
CMAKE_REQUIRED="never"
@@ -113,6 +113,8 @@ src_prepare() {
# gentoo bug #283905
epatch "${FILESDIR}"/${P}-moc-qt4.patch
+ epatch "${FILESDIR}"/${PN}-0.8.x-libpng14.patch
+
# Conflict headers with npapi.h from mozilla-sdk embedded stuffs and libxul-unstable header
# in case where xpcom (implicitly added with gtk) is enabled, we use the system header
if use gtk; then
diff --git a/www-plugins/gnash/gnash-0.8.6.ebuild b/www-plugins/gnash/gnash-0.8.6.ebuild
index e7caaba27109..c660a53b1051 100644
--- a/www-plugins/gnash/gnash-0.8.6.ebuild
+++ b/www-plugins/gnash/gnash-0.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.6.ebuild,v 1.10 2010/05/01 00:58:17 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.6.ebuild,v 1.11 2010/07/02 11:01:42 ssuominen Exp $
EAPI="2"
CMAKE_REQUIRED="never"
@@ -131,6 +131,8 @@ src_prepare() {
# when AS3 support is enabled (as default)
epatch "${FILESDIR}"/${P}-libcore-as3-headers.patch
+ epatch "${FILESDIR}"/${PN}-0.8.x-libpng14.patch
+
# Conflict headers with npapi.h from mozilla-sdk embedded stuffs and libxul-unstable header
# in case where xpcom (implicitly added with gtk) is enabled, we use the system header
if use gtk; then