summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2005-09-16 07:06:28 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2005-09-16 07:06:28 +0000
commitd2419f0a772a71c3f4ade694a13119aa0a47e802 (patch)
tree0fae10bc251823aaa8825dc1eec96ec0884b6620 /www-servers/bozohttpd/bozohttpd-20050410.ebuild
parentModify deps slightly. (diff)
downloadgentoo-2-d2419f0a772a71c3f4ade694a13119aa0a47e802.tar.gz
gentoo-2-d2419f0a772a71c3f4ade694a13119aa0a47e802.tar.bz2
gentoo-2-d2419f0a772a71c3f4ade694a13119aa0a47e802.zip
Version bump. Previous version stable for x86. Wiped out older version.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-servers/bozohttpd/bozohttpd-20050410.ebuild')
-rw-r--r--www-servers/bozohttpd/bozohttpd-20050410.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/www-servers/bozohttpd/bozohttpd-20050410.ebuild b/www-servers/bozohttpd/bozohttpd-20050410.ebuild
new file mode 100644
index 000000000000..d3c9515e8cc5
--- /dev/null
+++ b/www-servers/bozohttpd/bozohttpd-20050410.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/bozohttpd/bozohttpd-20050410.ebuild,v 1.1 2005/09/16 07:06:28 s4t4n Exp $
+
+inherit eutils
+
+DESCRIPTION="bozohttpd is a small and secure http server"
+HOMEPAGE="http://www.eterna.com.au/bozohttpd/"
+SRC_URI="http://www.eterna.com.au/bozohttpd/${P}.tar.bz2"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-libs/openssl-0.9.7d-r1"
+
+src_unpack()
+{
+ unpack ${A}
+
+ # We substitute the Makefile because the original works only with BSD make
+ cd ${S}
+ rm -f Makefile
+ cp ${FILESDIR}/${P}.Makefile Makefile
+}
+
+src_install ()
+{
+ dodir usr/bin
+ dodir usr/share/man
+ PREFIX="${D}/usr" einstall || die
+
+ insinto /etc/conf.d; newins ${FILESDIR}/${PN}.conffile bozohttpd
+ exeinto /etc/init.d; newexe ${FILESDIR}/${PN}.initscript bozohttpd
+}
+
+pkg_postinst()
+{
+ einfo "Remember to edit /etc/conf.d/bozohttpd to suit your needs."
+}