summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-06-23 13:53:59 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-06-23 13:53:59 +0000
commit46c4c808502fed89627379f5c58cfb20b515b929 (patch)
tree9a6c3feab6d8354b22851e85ccf5a8f9ca56485e /www-servers/nginx
parentChanged to only apply binary_drivers patch on x86/amd64. (diff)
downloadgentoo-2-46c4c808502fed89627379f5c58cfb20b515b929.tar.gz
gentoo-2-46c4c808502fed89627379f5c58cfb20b515b929.tar.bz2
gentoo-2-46c4c808502fed89627379f5c58cfb20b515b929.zip
* bump
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest2
-rw-r--r--www-servers/nginx/files/digest-nginx-0.1.371
-rw-r--r--www-servers/nginx/nginx-0.1.37.ebuild81
4 files changed, 90 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 02cc51747938..ff59cf237373 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.31 2005/06/16 09:00:49 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.32 2005/06/23 13:53:59 voxus Exp $
+
+*nginx-0.1.37 (23 Jun 2005)
+
+ 23 Jun 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.1.37.ebuild:
+ Version bump. David's ppc patch is now merged by author.
*nginx-0.1.36 (16 Jun 2005)
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index 1ffec4d290b1..cfc57bc6ee47 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -1,11 +1,13 @@
MD5 efcde21f75e7a0cbc83d4342ff4d5a0a nginx-0.1.36.ebuild 2174
MD5 ba17b5c0456ed0e8f4ec17e2690fc394 nginx-0.1.35.ebuild 2166
+MD5 39838cfae888941d897f0ac7a163b986 nginx-0.1.37.ebuild 2080
MD5 114f655395217d77dfab2e257cdd9fe4 nginx-0.1.34.ebuild 2073
MD5 08ab7ad5bb5dd2db36c7e1dcf67fb0d5 ChangeLog 5584
MD5 822f3c821527e6a34f23a6a92a884766 metadata.xml 220
MD5 b4e5149fed4a89f9561a32a8245dd1a7 files/digest-nginx-0.1.34 64
MD5 ec8d24578f3f015eabf58f8bef4bb939 files/digest-nginx-0.1.35 64
MD5 776c824b0b5e7e0a0014f1bdbc361409 files/digest-nginx-0.1.36 64
+MD5 23dc869263233b746e0a92df932c1d77 files/digest-nginx-0.1.37 64
MD5 d8f7e621e098b58848a6b5fb045c49c3 files/nginx 994
MD5 0dc86e18f344498c4c2e72952637e88e files/nginx-0.1.35-ppc.patch 240
MD5 fecedd05099122b1f8169152e5bc9462 files/nginx.conf 1400
diff --git a/www-servers/nginx/files/digest-nginx-0.1.37 b/www-servers/nginx/files/digest-nginx-0.1.37
new file mode 100644
index 000000000000..b3727e73e06e
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.1.37
@@ -0,0 +1 @@
+MD5 200dfa108e45e26eaf2697613f30ee4a nginx-0.1.37.tar.gz 298187
diff --git a/www-servers/nginx/nginx-0.1.37.ebuild b/www-servers/nginx/nginx-0.1.37.ebuild
new file mode 100644
index 000000000000..10a88af59289
--- /dev/null
+++ b/www-servers/nginx/nginx-0.1.37.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.37.ebuild,v 1.1 2005/06/23 13:53:59 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi pcre threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || myconf="${myconf} --without-pcre"
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+
+ cd ${S} && ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || "failed to compile"
+}
+
+src_install() {
+ cd ${S} || die
+
+ dodir /var/log/${PN}
+ keepdir /var/log/${PN}
+
+ dodir /var/tmp/${PN}
+
+ dodir /var/tmp/${PN}/client
+ keepdir /var/tmp/${PN}/client
+
+ dodir /var/tmp/${PN}/proxy
+ keepdir /var/tmp/${PN}/proxy
+
+ dodir /var/tmp/${PN}/fastcgi
+ keepdir /var/tmp/${PN}/fastcgi
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}