summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-12-02 15:54:33 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-12-02 15:54:33 +0000
commit43f73e1724739deb259c3450adb5149ea8440219 (patch)
tree695f51eb8728e1f0c9de67e3a092c2c5ccd65a22 /x11-apps/xfs/xfs-1.0.4.ebuild
parentVersion bump for 7.2RC3. Includes a minor build fix. (diff)
downloadgentoo-2-43f73e1724739deb259c3450adb5149ea8440219.tar.gz
gentoo-2-43f73e1724739deb259c3450adb5149ea8440219.tar.bz2
gentoo-2-43f73e1724739deb259c3450adb5149ea8440219.zip
Version bump for 7.2RC3. Includes a minor build fix.
(Portage version: 2.1.2_rc2-r3)
Diffstat (limited to 'x11-apps/xfs/xfs-1.0.4.ebuild')
-rw-r--r--x11-apps/xfs/xfs-1.0.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-apps/xfs/xfs-1.0.4.ebuild b/x11-apps/xfs/xfs-1.0.4.ebuild
new file mode 100644
index 000000000000..cb5c55cd56ba
--- /dev/null
+++ b/x11-apps/xfs/xfs-1.0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/xfs-1.0.4.ebuild,v 1.1 2006/12/02 15:54:33 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X font server"
+
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6"
+
+RDEPEND="x11-apps/ttmkfdir
+ x11-libs/libFS
+ x11-libs/libXfont"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6) --libdir=/etc"
+
+pkg_setup() {
+ enewgroup xfs 33
+ enewuser xfs 33 -1 /etc/X11/fs xfs
+}
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^configdir =.*:configdir = \$(sysconfdir)/X11/fs:g" \
+ "${S}"/Makefile.am
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+
+ insinto /etc/X11/fs
+ newins "${FILESDIR}"/xfs.config config
+ newinitd "${FILESDIR}"/xfs.start xfs
+ newconfd "${FILESDIR}"/xfs.conf.d xfs
+}