summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2007-04-06 19:00:48 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2007-04-06 19:00:48 +0000
commit227fd403a5f7de7de1ddc9728e47e2cf3691f609 (patch)
tree32193c57c8026401fc038c845a9005139aedb2ae /x11-apps/xman
parentMark stable on amd64 and remove generation 1 ebuild (bug #173003). (diff)
downloadgentoo-2-227fd403a5f7de7de1ddc9728e47e2cf3691f609.tar.gz
gentoo-2-227fd403a5f7de7de1ddc9728e47e2cf3691f609.tar.bz2
gentoo-2-227fd403a5f7de7de1ddc9728e47e2cf3691f609.zip
If building with xprint enabled, make sure libXaw is also built with xprint
enabled. (Bug #150954, Scott Alfter) (Portage version: 2.1.2.3)
Diffstat (limited to 'x11-apps/xman')
-rw-r--r--x11-apps/xman/ChangeLog8
-rw-r--r--x11-apps/xman/xman-1.0.2.ebuild14
2 files changed, 18 insertions, 4 deletions
diff --git a/x11-apps/xman/ChangeLog b/x11-apps/xman/ChangeLog
index 9305afba6e20..99d28cc0d404 100644
--- a/x11-apps/xman/ChangeLog
+++ b/x11-apps/xman/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-apps/xman
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xman/ChangeLog,v 1.17 2006/10/10 23:55:18 dberkholz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xman/ChangeLog,v 1.18 2007/04/06 19:00:48 joshuabaergen Exp $
+
+ 06 Apr 2007; Joshua Baergen <joshuabaergen@gentoo.org> xman-1.0.2.ebuild:
+ If building with xprint enabled, make sure libXaw is also built with xprint
+ enabled. (Bug #150954, Scott Alfter)
10 Oct 2006; Donnie Berkholz <dberkholz@gentoo.org>; xman-1.0.2.ebuild:
Update description to be less generic.
diff --git a/x11-apps/xman/xman-1.0.2.ebuild b/x11-apps/xman/xman-1.0.2.ebuild
index 5bf85c9be2f3..00f59131a714 100644
--- a/x11-apps/xman/xman-1.0.2.ebuild
+++ b/x11-apps/xman/xman-1.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xman/xman-1.0.2.ebuild,v 1.7 2006/10/10 23:55:18 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xman/xman-1.0.2.ebuild,v 1.8 2007/04/06 19:00:48 joshuabaergen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -16,3 +16,13 @@ RDEPEND="xprint? ( x11-libs/libXprintUtil )"
DEPEND="${RDEPEND}"
CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint; then
+ if ! built_with_use x11-libs/libXaw xprint; then
+ msg="You must build libXaw with xprint enabled."
+ eerror ${msg}
+ die ${msg}
+ fi
+ fi
+}