summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-02-01 22:04:50 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-02-01 22:04:50 +0000
commit3b2a4f86d2df2595b39fceab4cd78eeea1868d13 (patch)
treed5e9ca3a6da2777e1e63351dbfd08b0fcda21ead /x11-apps
parentAdd necessary curl USE flag depend on PHP. bug #352791. Add an EAPI=4 version... (diff)
downloadgentoo-2-3b2a4f86d2df2595b39fceab4cd78eeea1868d13.tar.gz
gentoo-2-3b2a4f86d2df2595b39fceab4cd78eeea1868d13.tar.bz2
gentoo-2-3b2a4f86d2df2595b39fceab4cd78eeea1868d13.zip
new ebuild, close bug #348288
(Portage version: 2.2.0_alpha13/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/python-whiteboard/ChangeLog10
-rw-r--r--x11-apps/python-whiteboard/metadata.xml34
-rw-r--r--x11-apps/python-whiteboard/python-whiteboard-20101012.ebuild36
3 files changed, 80 insertions, 0 deletions
diff --git a/x11-apps/python-whiteboard/ChangeLog b/x11-apps/python-whiteboard/ChangeLog
new file mode 100644
index 000000000000..45f1bed3365c
--- /dev/null
+++ b/x11-apps/python-whiteboard/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-apps/python-whiteboard
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/python-whiteboard/ChangeLog,v 1.1 2011/02/01 22:04:50 lxnay Exp $
+
+*python-whiteboard-20101012 (01 Feb 2011)
+
+ 01 Feb 2011; Fabio Erculiani <lxnay@gentoo.org>
+ +python-whiteboard-20101012.ebuild, +metadata.xml:
+ new ebuild, close bug #348288
+
diff --git a/x11-apps/python-whiteboard/metadata.xml b/x11-apps/python-whiteboard/metadata.xml
new file mode 100644
index 000000000000..4ba4c008552e
--- /dev/null
+++ b/x11-apps/python-whiteboard/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>lxnay@gentoo.com</email>
+ <name>Fabio Erculiani</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>ziapannocchia@gmail.com</email>
+ <name>Marco Clocchiatti</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <longdescription lang="en">
+ Build and operate an electronic whiteboard using gnu/linux, a wiimote and an IR pen.
+ </longdescription>
+ <maintainer>
+ <email>ziapanocchia@gmail.com</email>
+ <name>Marco Clocchiatti</name>
+ </maintainer>
+ <use>
+ </use>
+ <upstream>
+ <maintainer status="active">
+ <email></email>
+ <name>Pietro Pilloli</name>
+ </maintainer>
+ <changelog>https://github.com/pnegre/python-whiteboard/commits/master</changelog>
+ <doc>https://github.com/pnegre/python-whiteboard/wiki</doc>
+ <bugs-to>http://groups.google.com/group/python-whiteboard</bugs-to>
+ <remote-id type="sourceforge">git://github.com/pnegre/python-whiteboard.git</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-apps/python-whiteboard/python-whiteboard-20101012.ebuild b/x11-apps/python-whiteboard/python-whiteboard-20101012.ebuild
new file mode 100644
index 000000000000..7f0e4d95a485
--- /dev/null
+++ b/x11-apps/python-whiteboard/python-whiteboard-20101012.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/python-whiteboard/python-whiteboard-20101012.ebuild,v 1.1 2011/02/01 22:04:50 lxnay Exp $
+
+EAPI="3"
+
+inherit python multilib
+
+SRC_URI="http://dev.gentoo.org/~lxnay/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~x86 ~amd64"
+DESCRIPTION="Build and operate a electronic whiteboard Wiimote and IR Pen"
+HOMEPAGE="http://github.com/pnegre/python-whiteboard"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-misc/cwiid[python]
+ dev-python/numpy
+ dev-python/pybluez
+ dev-python/PyQt4
+ dev-python/python-xlib"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/$(get_libdir)/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/${PN}"
+}