summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-11-28 15:33:42 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-11-28 15:33:42 +0000
commit9829f8e60bd9e095f7f3b71229e5f819b0450bb6 (patch)
treec12ae6da3abd5faaee622b35ff4a1f37fa487ebe /x11-apps
parentVersion bump, bug #513494. (diff)
downloadgentoo-2-9829f8e60bd9e095f7f3b71229e5f819b0450bb6.tar.gz
gentoo-2-9829f8e60bd9e095f7f3b71229e5f819b0450bb6.tar.bz2
gentoo-2-9829f8e60bd9e095f7f3b71229e5f819b0450bb6.zip
Address test failures, bug #511202
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2324E7B566DF2611!)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xauth/ChangeLog8
-rw-r--r--x11-apps/xauth/xauth-1.0.7.ebuild25
-rw-r--r--x11-apps/xauth/xauth-1.0.9-r1.ebuild34
3 files changed, 41 insertions, 26 deletions
diff --git a/x11-apps/xauth/ChangeLog b/x11-apps/xauth/ChangeLog
index cb27d0c96f72..b5e08e4d24a9 100644
--- a/x11-apps/xauth/ChangeLog
+++ b/x11-apps/xauth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xauth
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xauth/ChangeLog,v 1.99 2014/06/08 09:15:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xauth/ChangeLog,v 1.100 2014/11/28 15:33:42 chithanh Exp $
+
+*xauth-1.0.9-r1 (28 Nov 2014)
+
+ 28 Nov 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xauth-1.0.9-r1.ebuild, -xauth-1.0.7.ebuild:
+ Address test failures, bug #511202
08 Jun 2014; Agostino Sarubbo <ago@gentoo.org> xauth-1.0.8.ebuild:
Stable for arm, wrt bug #500368
diff --git a/x11-apps/xauth/xauth-1.0.7.ebuild b/x11-apps/xauth/xauth-1.0.7.ebuild
deleted file mode 100644
index 3005aa93d5a7..000000000000
--- a/x11-apps/xauth/xauth-1.0.7.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xauth/xauth-1.0.7.ebuild,v 1.10 2013/02/22 19:24:56 zmedico Exp $
-
-EAPI=4
-
-inherit xorg-2
-
-DESCRIPTION="X authority file utility"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="ipv6"
-
-RDEPEND="x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXext
- x11-libs/libXmu"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- )
- xorg-2_pkg_setup
-}
diff --git a/x11-apps/xauth/xauth-1.0.9-r1.ebuild b/x11-apps/xauth/xauth-1.0.9-r1.ebuild
new file mode 100644
index 000000000000..0450aedf4be4
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.0.9-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xauth/xauth-1.0.9-r1.ebuild,v 1.1 2014/11/28 15:33:42 chithanh Exp $
+
+EAPI=4
+
+inherit autotools-utils xorg-2
+
+DESCRIPTION="X authority file utility"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+# Tests dependend on dev-util/cmdtest awaiting keywording, bug #511202.
+# test? ( dev-util/cmdtest )
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ )
+ xorg-2_src_configure
+}
+
+src_test() {
+ # Address sandbox failure, bug #527574
+ addwrite /proc/self/comm
+ autotools-utils_src_test
+}