summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-05-21 12:03:22 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-05-21 12:03:22 +0000
commitc608573ad24e41749a11b0b4d111c1e0841ab321 (patch)
tree4d6c60b03a1e1d35fc3df03a0e3a3cb6c9e1b2dd /x11-apps
parentnot maintaining this anymore, removed myself from metadata.xml (diff)
downloadgentoo-2-c608573ad24e41749a11b0b4d111c1e0841ab321.tar.gz
gentoo-2-c608573ad24e41749a11b0b4d111c1e0841ab321.tar.bz2
gentoo-2-c608573ad24e41749a11b0b4d111c1e0841ab321.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xdpyinfo/ChangeLog11
-rw-r--r--x11-apps/xdpyinfo/xdpyinfo-1.3.1.ebuild46
2 files changed, 54 insertions, 3 deletions
diff --git a/x11-apps/xdpyinfo/ChangeLog b/x11-apps/xdpyinfo/ChangeLog
index cf7735cabb34..59022f9c1ce1 100644
--- a/x11-apps/xdpyinfo/ChangeLog
+++ b/x11-apps/xdpyinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xdpyinfo
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/ChangeLog,v 1.78 2012/06/11 12:58:14 scarabeus Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/ChangeLog,v 1.79 2013/05/21 12:03:22 chithanh Exp $
+
+*xdpyinfo-1.3.1 (21 May 2013)
+
+ 21 May 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xdpyinfo-1.3.1.ebuild:
+ Version bump.
*xdpyinfo-1.3.0-r1 (11 Jun 2012)
@@ -289,4 +295,3 @@
08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+xdpyinfo-0.99.0.ebuild:
Initial commit for modular X.
-
diff --git a/x11-apps/xdpyinfo/xdpyinfo-1.3.1.ebuild b/x11-apps/xdpyinfo/xdpyinfo-1.3.1.ebuild
new file mode 100644
index 000000000000..6be814f43e52
--- /dev/null
+++ b/x11-apps/xdpyinfo/xdpyinfo-1.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/xdpyinfo-1.3.1.ebuild,v 1.1 2013/05/21 12:03:22 chithanh Exp $
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="Display information utility for X"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris ~x86-winnt"
+IUSE="dga dmx xinerama"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ dga? ( x11-libs/libXxf86dga )
+ dmx? ( x11-libs/libdmx )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${RDEPEND}
+ x11-proto/compositeproto
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/renderproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ dga? ( x11-proto/xf86dgaproto )
+ dmx? ( x11-proto/dmxproto )
+ xinerama? ( x11-proto/xineramaproto )
+"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ "--without-xf86misc"
+ $(use_with dga)
+ $(use_with dmx)
+ $(use_with xinerama)
+ )
+
+}