summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-01-25 08:19:31 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-01-25 08:19:31 +0000
commitdf7c68092a84c5ecd9874df1c0993332df21c14b (patch)
treec03a4b040f4f9f6b060df43d1af9a7016557577f /x11-base
parentfix HOMEPAGE; clean old ebuilds (diff)
downloadgentoo-2-df7c68092a84c5ecd9874df1c0993332df21c14b.tar.gz
gentoo-2-df7c68092a84c5ecd9874df1c0993332df21c14b.tar.bz2
gentoo-2-df7c68092a84c5ecd9874df1c0993332df21c14b.zip
Don't create libMesaGL.so .
(Portage version: 2.0.51-r14)
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/opengl-update/opengl-update-2.1_pre1.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/x11-base/opengl-update/opengl-update-2.1_pre1.ebuild b/x11-base/opengl-update/opengl-update-2.1_pre1.ebuild
index 5183dd922095..d01d9122f083 100644
--- a/x11-base/opengl-update/opengl-update-2.1_pre1.ebuild
+++ b/x11-base/opengl-update/opengl-update-2.1_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/opengl-update-2.1_pre1.ebuild,v 1.2 2005/01/25 01:14:14 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/opengl-update-2.1_pre1.ebuild,v 1.3 2005/01/25 08:19:31 eradicator Exp $
inherit multilib toolchain-funcs
@@ -35,14 +35,9 @@ pkg_preinst() {
OABI="${ABI}"
for ABI in $(get_abi_order); do
if [ -e "${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so" ]; then
- einfo "Removing libMesaGL from xorg-x11 profile and making stub lib in"
- einfo "${ROOT}/usr/$(get_libdir) to force using xorg-x11's libGL when libMesaGL is requested"
- einfo "This will be taken care of by future releases of xorg-x11. See"
- einfo "bug #47598 for more information."
- echo ""
- rm -f ${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so
- rm -f ${ROOT}/usr/$(get_libdir)/libMesaGL.so*
- $(tc-getCC) -shared -Wl,--soname,libMesaGL.so,-L,${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib,-R,${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib -lGL -o ${ROOT}/usr/$(get_libdir)/libMesaGL.so
+ einfo "Removing libMesaGL* from xorg-x11 profile. See bug #47598."
+ rm -f ${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL*
+ rm -f ${ROOT}/usr/$(get_libdir)/libMesaGL*
fi
done
ABI="${OABI}"