summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-10-22 18:11:24 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-10-22 18:11:24 +0000
commit54118f3e3acd316f4a2224ab1c10967d400f3b39 (patch)
treea55ab3f4de24eb60b4e44439cd228a9b699a5192 /x11-drivers/xf86-video-tdfx
parentVersion bump with minor changes. (diff)
downloadgentoo-2-54118f3e3acd316f4a2224ab1c10967d400f3b39.tar.gz
gentoo-2-54118f3e3acd316f4a2224ab1c10967d400f3b39.tar.bz2
gentoo-2-54118f3e3acd316f4a2224ab1c10967d400f3b39.zip
Version bump with minor changes.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'x11-drivers/xf86-video-tdfx')
-rw-r--r--x11-drivers/xf86-video-tdfx/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-tdfx/files/digest-xf86-video-tdfx-1.2.26
-rw-r--r--x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.2.2.ebuild31
3 files changed, 44 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-tdfx/ChangeLog b/x11-drivers/xf86-video-tdfx/ChangeLog
index c0ffd5113f16..722ab87cfca0 100644
--- a/x11-drivers/xf86-video-tdfx/ChangeLog
+++ b/x11-drivers/xf86-video-tdfx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-tdfx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-tdfx/ChangeLog,v 1.27 2006/10/13 23:15:49 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-tdfx/ChangeLog,v 1.28 2006/10/22 18:11:24 joshuabaergen Exp $
+
+*xf86-video-tdfx-1.2.2 (21 Oct 2006)
+
+ 21 Oct 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xf86-video-tdfx-1.2.2.ebuild:
+ Version bump.
13 Oct 2006; Joshua Baergen <joshuabaergen@gentoo.org>
xf86-video-tdfx-1.2.1-r1.ebuild:
diff --git a/x11-drivers/xf86-video-tdfx/files/digest-xf86-video-tdfx-1.2.2 b/x11-drivers/xf86-video-tdfx/files/digest-xf86-video-tdfx-1.2.2
new file mode 100644
index 000000000000..e03ce1faea1e
--- /dev/null
+++ b/x11-drivers/xf86-video-tdfx/files/digest-xf86-video-tdfx-1.2.2
@@ -0,0 +1,6 @@
+MD5 56566e8c3fb4bb99791d1788d0a9a1a8 x11-driver-patches-4.tar.bz2 346
+RMD160 fcbd405de080d07612d46f455b927035fd8123a8 x11-driver-patches-4.tar.bz2 346
+SHA256 07069bbd072f2def50e83801a8f2a41a4c96495104f15cd6f56f7df7f89769bf x11-driver-patches-4.tar.bz2 346
+MD5 68568ca1402d07046b08f82679aefb87 xf86-video-tdfx-1.2.2.tar.bz2 276785
+RMD160 9ebc5c0c5d67f110965c80759a44d82b1d098a8b xf86-video-tdfx-1.2.2.tar.bz2 276785
+SHA256 04abe62a0cb9280dcad6082eea12564468b5940b657795811ddd5d8e2c443ec6 xf86-video-tdfx-1.2.2.tar.bz2 276785
diff --git a/x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.2.2.ebuild b/x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.2.2.ebuild
new file mode 100644
index 000000000000..e15fac1e1dac
--- /dev/null
+++ b/x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-tdfx/xf86-video-tdfx-1.2.2.ebuild,v 1.1 2006/10/22 18:11:24 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+XDPVER=4
+
+inherit x-modular
+
+DESCRIPTION="3Dfx video driver"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}