summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-08-31 11:29:55 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-08-31 11:29:55 +0000
commit4de1082b55aa908504d346e9e6ff8a13000295ac (patch)
tree4f918d8965e70572f46039a90a504d113ed01bf5 /x11-drivers
parentexport QTDIR to avoid qt3 vs. qt4 confusion wrt #283222 by Silvio Gerli (diff)
downloadgentoo-2-4de1082b55aa908504d346e9e6ff8a13000295ac.tar.gz
gentoo-2-4de1082b55aa908504d346e9e6ff8a13000295ac.tar.bz2
gentoo-2-4de1082b55aa908504d346e9e6ff8a13000295ac.zip
Add new in-kernel check for LOCKDEP. Per bug #283301. Thx to loki_val for the patch.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/ati-drivers/ChangeLog7
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-9.8.ebuild16
2 files changed, 21 insertions, 2 deletions
diff --git a/x11-drivers/ati-drivers/ChangeLog b/x11-drivers/ati-drivers/ChangeLog
index 56598498a7d4..a8a88cee2902 100644
--- a/x11-drivers/ati-drivers/ChangeLog
+++ b/x11-drivers/ati-drivers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/ati-drivers
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.178 2009/08/29 15:45:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.179 2009/08/31 11:29:55 scarabeus Exp $
+
+ 31 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ ati-drivers-9.8.ebuild:
+ Add new in-kernel check for LOCKDEP. Per bug #283301. Thx to loki_val for
+ the patch.
29 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org>
ati-drivers-9.8.ebuild:
diff --git a/x11-drivers/ati-drivers/ati-drivers-9.8.ebuild b/x11-drivers/ati-drivers/ati-drivers-9.8.ebuild
index 1694509fedd6..8c42ee271f23 100644
--- a/x11-drivers/ati-drivers/ati-drivers-9.8.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-9.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-9.8.ebuild,v 1.9 2009/08/29 15:45:59 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-9.8.ebuild,v 1.10 2009/08/31 11:29:55 scarabeus Exp $
EAPI="2"
@@ -127,6 +127,20 @@ _check_kernel_config() {
eerror "in the kernel config."
die "CONFIG_PCI_MSI disabled"
fi
+
+ if linux_chkconfig_present LOCKDEP; then
+ eerror "You've enabled LOCKDEP -- lock tracking -- in the kernel."
+ eerror "Unfortunately, this option exports the symbol lock_acquire as GPL-only."
+ eerror "This prevents ${P} from compiling with an error like this:"
+ eerror "FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol 'lock_acquire'"
+ eerror "Please make sure the following options have been unset:"
+ eerror " Kernel hacking --->"
+ eerror " [ ] Lock debugging: detect incorrect freeing of live locks"
+ eerror " [ ] Lock debugging: prove locking correctness"
+ eerror " [ ] Lock usage statistics"
+ eerror "in 'menuconfig'"
+ die "LOCKDEP enabled"
+ fi
}
pkg_setup() {