summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2007-10-22 16:49:46 +0000
committerLuca Barbato <lu_zero@gentoo.org>2007-10-22 16:49:46 +0000
commitc8fddc929d602f438ae05fc2b030facad3a1e10c (patch)
tree4da1e3ba61a3d81649346a8acf0b4330e512473c /x11-drivers
parentStable on x86 wrt bug 73107 (diff)
downloadgentoo-2-c8fddc929d602f438ae05fc2b030facad3a1e10c.tar.gz
gentoo-2-c8fddc929d602f438ae05fc2b030facad3a1e10c.tar.bz2
gentoo-2-c8fddc929d602f438ae05fc2b030facad3a1e10c.zip
Endian fix
(Portage version: 2.1.3.15)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-xgi/ChangeLog5
-rw-r--r--x11-drivers/xf86-video-xgi/files/digest-xf86-video-xgi-1.5.03
-rw-r--r--x11-drivers/xf86-video-xgi/xf86-video-xgi-1.5.0.ebuild12
3 files changed, 17 insertions, 3 deletions
diff --git a/x11-drivers/xf86-video-xgi/ChangeLog b/x11-drivers/xf86-video-xgi/ChangeLog
index fe45d02d7bd6..9eae66e535b6 100644
--- a/x11-drivers/xf86-video-xgi/ChangeLog
+++ b/x11-drivers/xf86-video-xgi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-drivers/xf86-video-xgi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-xgi/ChangeLog,v 1.1 2007/09/08 08:29:26 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-xgi/ChangeLog,v 1.2 2007/10/22 16:49:45 lu_zero Exp $
+
+ 22 Oct 2007; Luca Barbato <lu_zero@gentoo.org> xf86-video-xgi-1.5.0.ebuild:
+ Fix endianess issues and add ~ppc and ~ppc64 keywords
*xf86-video-xgi-1.5.0 (08 Sep 2007)
diff --git a/x11-drivers/xf86-video-xgi/files/digest-xf86-video-xgi-1.5.0 b/x11-drivers/xf86-video-xgi/files/digest-xf86-video-xgi-1.5.0
index 9a59845ab9d9..c1296713bf46 100644
--- a/x11-drivers/xf86-video-xgi/files/digest-xf86-video-xgi-1.5.0
+++ b/x11-drivers/xf86-video-xgi/files/digest-xf86-video-xgi-1.5.0
@@ -1,6 +1,9 @@
MD5 56566e8c3fb4bb99791d1788d0a9a1a8 x11-driver-patches-4.tar.bz2 346
RMD160 fcbd405de080d07612d46f455b927035fd8123a8 x11-driver-patches-4.tar.bz2 346
SHA256 07069bbd072f2def50e83801a8f2a41a4c96495104f15cd6f56f7df7f89769bf x11-driver-patches-4.tar.bz2 346
+MD5 3b76ccfb48a5444bb35b3f9b6126885d xf86-video-xgi-1.5.0-bigendian.patch 24001
+RMD160 f406856cd69effb2e90f30e5317122beccfaad62 xf86-video-xgi-1.5.0-bigendian.patch 24001
+SHA256 14ce8b887933af312db51726f8a0f2486e25308d604cab8422ec8ffd5430190a xf86-video-xgi-1.5.0-bigendian.patch 24001
MD5 08529fd015191be9244f598aa0894aa6 xf86-video-xgi-1.5.0.tar.bz2 426471
RMD160 f874392130df77d3dfc74102c35ca27785995c71 xf86-video-xgi-1.5.0.tar.bz2 426471
SHA256 5fb23432ee8940c04494744da8b5f58bebc6ef113e96a50a74f0aa7d98a69194 xf86-video-xgi-1.5.0.tar.bz2 426471
diff --git a/x11-drivers/xf86-video-xgi/xf86-video-xgi-1.5.0.ebuild b/x11-drivers/xf86-video-xgi/xf86-video-xgi-1.5.0.ebuild
index d046c818d26d..8b6df1ecb5b5 100644
--- a/x11-drivers/xf86-video-xgi/xf86-video-xgi-1.5.0.ebuild
+++ b/x11-drivers/xf86-video-xgi/xf86-video-xgi-1.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-xgi/xf86-video-xgi-1.5.0.ebuild,v 1.1 2007/09/08 08:29:26 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-xgi/xf86-video-xgi-1.5.0.ebuild,v 1.2 2007/10/22 16:49:45 lu_zero Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -9,8 +9,10 @@ XDPVER=4
inherit x-modular
DESCRIPTION="XGI video driver"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~ppc ~ppc64"
RDEPEND=">=x11-base/xorg-server-1.0.99"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${P}-bigendian.patch"
DEPEND="${RDEPEND}
x11-proto/fontsproto
x11-proto/randrproto
@@ -19,3 +21,9 @@ DEPEND="${RDEPEND}
x11-proto/xextproto
x11-proto/xf86dgaproto
x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${DISTDIR}/${P}-bigendian.patch"
+}